X
Tap here to go to the mobile version of the site.

Support Forum

dropdown menu's disappear

Posted

I recently updated to the most recent firefox (4.0.1). Since the update I have been having issues with all dropdown menus in Firefox. They disappear while i'm trying to look at them or click them. This includes the address bar, the search bar, or any drop-down menu's on any website.

If I move my mouse of the drop down boxes, it will reappear for a split second and then disappear again.

I recently updated to the most recent firefox (4.0.1). Since the update I have been having issues with all dropdown menus in Firefox. They disappear while i'm trying to look at them or click them. This includes the address bar, the search bar, or any drop-down menu's on any website. If I move my mouse of the drop down boxes, it will reappear for a split second and then disappear again.

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


In Firefox 4 Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

This started when...

I upgraded to 4.0.1

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • npdnu
  • npdnupdater2
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Shockwave Flash 10.2 r159
  • GEPlugin
  • 4.0.60310.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Adblock Plus
1.3.6
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
extensions.lastAppVersion
4.0.1
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729; .NET4.0C)
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1305065121
places.history.expiration.transient_current_max_pages
128774
places.last_vacuum
1301269237
print.print_printer
Adobe PDF
print.printer_Adobe_PDF.print_bgcolor
false
print.printer_Adobe_PDF.print_bgimages
false
print.printer_Adobe_PDF.print_command
print.printer_Adobe_PDF.print_downloadfonts
false
print.printer_Adobe_PDF.print_edge_bottom
0
print.printer_Adobe_PDF.print_edge_left
0
print.printer_Adobe_PDF.print_edge_right
0
print.printer_Adobe_PDF.print_edge_top
0
print.printer_Adobe_PDF.print_evenpages
true
print.printer_Adobe_PDF.print_footercenter
print.printer_Adobe_PDF.print_footerleft
&PT
print.printer_Adobe_PDF.print_footerright
&D
print.printer_Adobe_PDF.print_headercenter
print.printer_Adobe_PDF.print_headerleft
&T
print.printer_Adobe_PDF.print_headerright
&U
print.printer_Adobe_PDF.print_in_color
true
print.printer_Adobe_PDF.print_margin_bottom
0.5
print.printer_Adobe_PDF.print_margin_left
0.5
print.printer_Adobe_PDF.print_margin_right
0.5
print.printer_Adobe_PDF.print_margin_top
0.5
print.printer_Adobe_PDF.print_oddpages
true
print.printer_Adobe_PDF.print_orientation
0
print.printer_Adobe_PDF.print_pagedelay
500
print.printer_Adobe_PDF.print_paper_data
1
print.printer_Adobe_PDF.print_paper_height
11.00
print.printer_Adobe_PDF.print_paper_size_type
0
print.printer_Adobe_PDF.print_paper_size_unit
0
print.printer_Adobe_PDF.print_paper_width
8.50
print.printer_Adobe_PDF.print_reversed
false
print.printer_Adobe_PDF.print_scaling
1.00
print.printer_Adobe_PDF.print_shrink_to_fit
true
print.printer_Adobe_PDF.print_to_file
false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom
0
print.printer_Adobe_PDF.print_unwriteable_margin_left
0
print.printer_Adobe_PDF.print_unwriteable_margin_right
0
print.printer_Adobe_PDF.print_unwriteable_margin_top
0
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 9600 GT
Vendor ID
10de
Device ID
0622
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.5896
Driver Date
7-9-2010
Direct2D Enabled
true
DirectWrite Enabled
true (7.0.6002.18409, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
1/1 Direct3D 10

Question owner

Dear Firefox,

Any word on this issue as it seems I am not the only one with this problem.

Thanks!

Dear Firefox, Any word on this issue as it seems I am not the only one with this problem. Thanks!
silkphoenix 91 solutions 1257 answers

Press ALT key on your keyboard or use F10, when the Menu Bar is shown:


View > Toolbars and CHECK whatever toolbars you want to display.

Press ALT key on your keyboard or use F10, when the Menu Bar is shown: View > Toolbars and CHECK whatever toolbars you want to display.
cor-el
  • Top 10 Contributor
  • Moderator
17478 solutions 157951 answers

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


In Firefox 4 Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). * Don't make any changes on the Safe mode start window. * https://support.mozilla.com/kb/Safe+Mode * https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes In Firefox 4 [http://kb.mozillazine.org/Safe_mode Safe mode] disables extensions and disables hardware acceleration. * Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Question owner

SilkPhoenix: Thank you but it is not a toolbar issue. An example of my issue is when I start to enter a website into the address bar, for example I will type in "www.net" and the address bar will start giving you a list of previously visited websites starting with www.net but that list is only there for a split second to the point where you can't see the words.

It's not only an address bar issue but any drop down menu on any website.

SilkPhoenix: Thank you but it is not a toolbar issue. An example of my issue is when I start to enter a website into the address bar, for example I will type in "www.net" and the address bar will start giving you a list of previously visited websites starting with www.net but that list is only there for a split second to the point where you can't see the words. It's not only an address bar issue but any drop down menu on any website.

Modified by scotty1009

Helpful Reply

cor-el: THANKS!!!! It didn't have anything to do with the theme as mine was set as default but, the un-checking of "use hardware acceleration when available" fixed it.

I think my hardware wanted to accelerated it so fast that it was too fast for the human eye lol.

Again, thanks a lot this has been driving me nuts.

cor-el: THANKS!!!! It didn't have anything to do with the theme as mine was set as default but, the un-checking of "use hardware acceleration when available" fixed it. I think my hardware wanted to accelerated it so fast that it was too fast for the human eye lol. Again, thanks a lot this has been driving me nuts.
Kovyn 0 solutions 1 answers

Not a theme related problem as said. The problem was solved for me also by disabling the "hardware acceleration".

Not a theme related problem as said. The problem was solved for me also by disabling the "hardware acceleration".
Rocdufer 0 solutions 2 answers

I have this problem in tool-bars dropdown menus least since Firefox and Thunderbird 11.0.x in Ubuntu LTS. Disabling hardware acceleration did not solve the problem in a definitive way, it reappeared. However, this trick works faster all the time: Minimize windows and then maximize them. Even when I have both programs running, and the problem appears in the drop-down menus in Firefox, if I maximize and minimize Thunderbird, this also solves the problem in Firefox for a random while. And Vice-versa works for Thunderbird. It is not a definitive solution, but it makes using these programs less annoying, and perhaps gives a straight clue to solve it.

I have this problem in tool-bars dropdown menus least since Firefox and Thunderbird 11.0.x in Ubuntu LTS. Disabling hardware acceleration did not solve the problem in a definitive way, it reappeared. However, this trick works faster all the time: '''''Minimize windows and then maximize them'''''. Even when I have both programs running, and the problem appears in the drop-down menus in Firefox, if I maximize and minimize Thunderbird, this also solves the problem in Firefox for a random while. And Vice-versa works for Thunderbird. It is not a definitive solution, but it makes using these programs less annoying, and perhaps gives a straight clue to solve it.

Modified by Rocdufer