X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox does not ask me if i want to save my password

Posted

i just bought a new computer, downloaded the latest firefox (did not import any info from my old computer's firefox yet), and though i saw the expected prompt to save a password when entering one on a site once (i did not save it at the time), the prompt no longer appears. the same thing occurs for any site, it never asks me if i want to save a password. i've rechecked my settings, and i have it set correctly to ask for it (the box IS clicked to 'remember passwords for sites', don't have it in 'private browsing' mode either (the option is grayed oust), have disabled any add-ons that i had (i only have AdBlock and McAfee as add-ons), have restarted Firefox multiple times, and still no luck, it never asks me if i want to save a password for any logons on any sites. i'm running Windows 7, and using Firefox 3.6.11. HELP! thanks.

Chosen solution

Tools > Options > Privacy
un-check Automatically start Firefox in a private browsing session
Then restart Firefox

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

More Information

Application Basics
Name
Firefox
Version
3.6.11
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
McAfee SiteAdvisor
3.1
true
{B7082FAA-CB62-4872-9106-E42DD88EDE45}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://myspace.com/
browser.startup.homepage_override.mstone
rv:1.9.2.11
browser.tabs.loadInBackground
false
browser.tabs.warnOnOpen
false
extensions.lastAppVersion
3.6.11
network.cookie.cookieBehavior
2
network.cookie.prefsMigrated
true
places.last_vacuum
1287719377
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

What do you mean with "the option is grayed oust": don't have it in 'private browsing' mode either (the option is grayed oust)

If you see a grayed Stop Private Browsing in the Tools menu then that means that you are in Private Browsing mode. Firefox won't offer to store passwords if you are in Private Browsing mode.

Question owner

yeah, the Stop Private Browsing option is grayed out (i'm unable to click it)... so that means i'm IN Private Browsing???? how do i get OUT of private browsing?

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Chosen Solution

Tools > Options > Privacy
un-check Automatically start Firefox in a private browsing session
Then restart Firefox

Question owner

awesome, problem resolved!! i didn't see that, i'm an idiot... thanks!!!!!!!!

Sandry65 0 solutions 4 answers

Nope, 'Automatically start Firefox in a private browsing session' was unchecked and I'm still having this problems of Firefox not asking and not saving my passwords.

This started with the new update of Firefox 3.6.12.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Is remember passwords still checked: Tools > Options > Security: Passwords: "Remember passwords for sites" ?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

wolmo 0 solutions 2 answers

I have FF 3.6.12 on a new computer with Windows 7 64 bit. Private browsing is not on.

mr94608 0 solutions 1 answers

I have FF 3.6.12 as well. Firefox saves MOST of my passwords but sometimes it does not...specifically tvguide.com/listings. How can I "force" the password to be saved or can I type it in somewhere?

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Helpful Reply

You can use the Saved Password Editor extension to add passwords to Firefox manually.
https://addons.mozilla.org/en-US/firefox/addon/60265

RichardD66 0 solutions 5 answers

I have downloaded the saved password editor, and it does not show any option to add passwords, only to delete or edit ones there. What am I doing wrong now ?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

That extension should add a Tools > Saved Passwords menu entry that will open the Password Manager.
In the Password Manager (Tools > Options > Security: Passwords: "Saved Passwords") you will notice an Add button to add a new password with a Guess button to fill the fields based upon the website in the currently open tab.

supedersen 0 solutions 1 answers

Helpful Reply

Its simply too complicated - it is NOT userfriendly and the help is a laugh. Firefox is becomming just like any other program that does not work with humans. Like windows....

KiAnCaFleur 0 solutions 1 answers

My settings have "Automatically start firefox in a private browsing session" UNchecked. I have "Remember passwords for sites" checked and there are NO "Exceptions." Originally there were two exceptions, but neither is the site in question. Also, there are only a few sites that never pop up the form asking remember/never for this site/not now --for the site in question, firefox stores passwords for two other accounts, but never asks about the third, which happens to be the one I use most often. I wish there was a way to manually add passwords to save!

driver8m3 0 solutions 1 answers

try this:

tools>>options>>privacy -make sure "accept cookies from sites" is checked -make sure "accept 3rd party cookies" is checked -for "keep until" use "they expire"

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Cookie settings don't affect the saving of passwords.

KiAnCaFleu...,
If you're gonna post in a thread marked as "SOLVED" please read all the support information that was provided. The Saved Password Editor extension allows you to manually add a username & password for a website that Firefox doesn't offer the option to save that data.

Some websites code their login page with autocomplete = "off" to tell the web browser not to save the login information. This bookmarklet makes the browser ignore autocomplete="off" temporarily, allowing you to save passwords even on sites that use autocomplete="off".

Remember Password bookmarklet: https://www.squarefree.com/bookmarklets/forms.html#remember_password

Muix2006 0 solutions 1 answers

- Go to C:\Documents and Settings\<user>\Application Data\Mozilla\Firefox\Profiles\<your profilename> (i assume you’re using C:\ as the drive where you have Firefox installed). - look for the file called "signons2.txt" or "signons.sqlite" or "signons3.txt" and delete it.

After that Firefox was prompting me again to save my login and password information.

okester 0 solutions 1 answers

I've done all the check box "remember passwords for sites", the privacy/remember hx thing, making sure it is not privately browsing ... Why doesn't Firefox just say it won't work with Win 7 and save us all a lot of time, then tell us when it is fixed.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

See:

casagozo 0 solutions 1 answers

This is made more complicated than necessary. The security section under tools/options should just have a "Ask me each time" or "Offer to save passwords" (like Google Chrome does). If somebody could just go do that for us this morning that would be great.

dpbrick 0 solutions 1 answers

This may be so simple -- you may want to kick yourself. Go to Tools>Options>Security and in the Passwords section, click on the "Exceptions..." button. Look through the sites in this list and make sure the site you're having the problem with is not on the list. When you find it, click on "Remove", then click "Close" and "Ok" and you should be good to go.

Still, it would be nice to have a quick and easy way to force FF to prompt to save a password / username pair. Roboform does this when you hold the "Alt" key down when clicking on the login button. Just an idea...