X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox does not ask me if i want to save my password

Posted

i just bought a new computer, downloaded the latest firefox (did not import any info from my old computer's firefox yet), and though i saw the expected prompt to save a password when entering one on a site once (i did not save it at the time), the prompt no longer appears. the same thing occurs for any site, it never asks me if i want to save a password. i've rechecked my settings, and i have it set correctly to ask for it (the box IS clicked to 'remember passwords for sites', don't have it in 'private browsing' mode either (the option is grayed oust), have disabled any add-ons that i had (i only have AdBlock and McAfee as add-ons), have restarted Firefox multiple times, and still no luck, it never asks me if i want to save a password for any logons on any sites. i'm running Windows 7, and using Firefox 3.6.11. HELP! thanks.

Chosen solution

Tools > Options > Privacy
un-check Automatically start Firefox in a private browsing session
Then restart Firefox

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

More Information

Application Basics
Name
Firefox
Version
3.6.11
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
McAfee SiteAdvisor
3.1
true
{B7082FAA-CB62-4872-9106-E42DD88EDE45}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://myspace.com/
browser.startup.homepage_override.mstone
rv:1.9.2.11
browser.tabs.loadInBackground
false
browser.tabs.warnOnOpen
false
extensions.lastAppVersion
3.6.11
network.cookie.cookieBehavior
2
network.cookie.prefsMigrated
true
places.last_vacuum
1287719377
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

See also Saved Password Editor: https://addons.mozilla.org/firefox/addon/60265

Higzy 0 solutions 1 answers

Me too.

coneos 0 solutions 1 answers

IT IS SOLVED FOR ME !!! Hope it will help some people too...

Thanks to cor-el for pointing out the right direction when having a compatibility issue : Troubleshooting extensions and themes

Solution : I had to Turn off hardware acceleration , restart Firefox then it worked again, I could finally save my passwords :)

rtforbes40 0 solutions 1 answers

@ the-edmeister - Thank you!!!!! The Saved Password Editor extension works beautifully!!!!

David McRitchie 321 solutions 3089 answers

There is still one possibility that I didn't see mentioned and the person who said she tried everything and it didn't work never indicated finding a solution. This one is similar to private browsing. Make sure you are not clearing passwords when ending Firefox (or clearing history from the Tools menu).

Make sure the "Clear Saved Passwords" is not checked on the "Settings for Clearing History" panel.

Yadda 0 solutions 3 answers

If you cancel a prompted password save request, Firefox will put an entry into the Password manager with nothing for password. I found this entry by inspecting account list and deleted the record with blank password and then Firefox prompted me again. BUG!!!

fireniko 1 solutions 23 answers

This is really really annoying, it has been happening to me randomly in various sites. Sometimes it remembers the password and/or username and other times it randomly does not! The problem is, it is not only the fact that it used to remember them before, it is the fact that it does NOT ask me if I want to remember them again or not! The passwords just simply do not show up! It has been happening since version 2.0 and now with version 5.0 and still not a permanent fix/solution. Popular websites that this has occurring since I can remember is ebay.com.au

Modified by fireniko

David McRitchie 321 solutions 3089 answers

try solutions starting at following, and check out the links, especially those at the end of the article, like "Password Manager" which has additional suggestions and links. When you find a solution, if eBay is a particular problem it can be added to the following page as well. Clearing eBay cookies is a possibility, did you look at the other 27 replies (some of which like yours are questions).

User name and password not remembered - MozillaZine Knowledge Base

http://kb.mozillazine.org/User_name_and_password_not_remembered
SwearBox 0 solutions 1 answers

I fixed this problem. What worked for me was that for some reason google was added to the exceptions list for saving passwords. Even though it still saved ones I had in it previously.

I did Tools -> Options -> Exceptions (the one in the password settings area) -> Then remove the site that you can't save your password on if it's there.

Cnote2002 0 solutions 1 answers

1. Go to: -Options -Privacy Select, history/Firefox will: "use custom settings for history" from the drop dox Select "Accept cookies from sites" 2. Go to: -Security Select "Remember passwords for sites"

That fixed it for me. You can have any combination of selections you want in the Privacy tab (eg. I have them all unchecked).

A tad cumbersome for such a basic option. Come on Firefox....come on man.