Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot scroll outlook navigation pane in firefox

  • 13 replies
  • 1 has this problem
  • 83 views
  • Last reply by Dungogvolts

more options

Hi All, All of a sudden cannot scroll folders in outlook/hotmail.com navigation pane in Firefox. As mentioned this has just started it has worked no problem from the change over from Hotmail to Outlook years ago up until about two weeks age. I am using an old version of Firefox 86.0.1 (64-bit) because I don't not like the layout of newer versions and 86 works for me and does what I want it too so you know "if it ain't broke don't fix it" anyway just of late I can not scroll my folders where I save emails and therefore have a hard time finding folders that don't show in the navigation pane without scrolling you get the gist. As you can see in attached photo. I have done all the clearing of Cookies, Cached Web Content ect as mentioned in some google searches but still no go. It's now a problem except I have found if I click on "View" and change the settings under Density to "Compact" all the folders in the nav pane show but even with my good reading glasses on the type is so small it's hard to read and I would prefer if I could just scroll the list of folders. Oh also I have not done any updates to Outlook, don't know if I can, or for that matter Firefox or any other app on my PC.

Many thanks in advance.

Hi All, All of a sudden cannot scroll folders in outlook/hotmail.com navigation pane in Firefox. As mentioned this has just started it has worked no problem from the change over from Hotmail to Outlook years ago up until about two weeks age. I am using an old version of Firefox 86.0.1 (64-bit) because I don't not like the layout of newer versions and 86 works for me and does what I want it too so you know "if it ain't broke don't fix it" anyway just of late I can not scroll my folders where I save emails and therefore have a hard time finding folders that don't show in the navigation pane without scrolling you get the gist. As you can see in attached photo. I have done all the clearing of Cookies, Cached Web Content ect as mentioned in some google searches but still no go. It's now a problem except I have found if I click on "View" and change the settings under Density to "Compact" all the folders in the nav pane show but even with my good reading glasses on the type is so small it's hard to read and I would prefer if I could just scroll the list of folders. Oh also I have not done any updates to Outlook, don't know if I can, or for that matter Firefox or any other app on my PC. Many thanks in advance.
Attached screenshots

Chosen solution

You need to use CSS code in userChrome.css to get the spacing tighter than with compact mode.

:root[uidensity=compact] menupopup :is(menu,menuitem) {
 padding-block: 2px !important;  /*adjust: 0px-4px*/
 min-height: 22px !important;    /*adjust: 21px-24px or unset*/
 height: 26px !important;        /*adjust*/
}
:root[uidensity=compact] {
 --arrowpanel-menuitem-margin: 0 4px !important;
 --arrowpanel-menuitem-padding:2px 6px !important; /*adjust only 2px value*/
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder with the random name (xxxxxxxx.default-release).

You can find the button to go to the profile folder under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in the profile folder with the random name (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt or .css file extension and you end up with a file like userChrome.css.txt or userChrome.css.css. To avoid this, you need to make sure to select "All files" in the "Save File" dialog in the text editor.

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

More info about userChrome.css/userContent.css in case you are not familiar:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css.

Read this answer in context 👍 1

All Replies (13)

more options

Since your still in the same old version from weeks ago you know nothing changed on the browser side. Are you in Window home or pro version? Did you try with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode Did you clear the browser cache? https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

I have no problem scrolling in the current version. see screenshot With mouse over the folders, the scroll wheel works and middle clicking.

Modified by jonzn4SUSE

Helpful?

more options

jonzn4SUSE thanks for reply. Sorry forgot to add this Windows 11 Home

Tried Firefox in Safe Mode same result

Not only did I clear the browser cache I did Cookies, Cached Web Content as just about google answer from as far back as 2011 yes that far suggest these measures as a first port of call

You say that you "have no problem scrolling in the current version" that does not mean other people, and over the years it has been lots of people, do not have trouble. That said I am using Outlook online I think it is called but don't know what version it is. I migrated across from Hotmail all those years ago when Microsoft took over Hotmail.

I have always just turned the center wheel on my mouse and the page ect scrolls not sure what you are referring to when you say "middle clicking." I highlight my "inbox" move the cursor over said folders and turn the scroll wheel as I have always done but now it does not scroll the folders but will scroll anything else on any webpage just like when I click your attachment and use the wheel on my mouse to scroll it down to view the bottom of attachment.. The problem is only in Outlook.

Oh and "Since your still in the same old version from weeks ago you know nothing changed on the browser side." I am asking here as well as Outlook forums as if I just asked in one I would end up with the answer like " oh not our fault must be your browser" or visa versa so asking in both hoping to get a fix.

Thanks again.

Helpful?

more options

I was also using Hotmail in 97 when MS bought it for $550 million. It's a website so lets not worry about what version it is. Middle clicking over the folders scrolls them for me, but you're on that version and I'm not sure of the behavior. Check your settings to see if autoscroll is checked. see screenshot Everyone is going to tell you to upgrade, but you want to stick with the old version. Enjoy that version because IMHO there is nothing more to do here. Jones out

Modified by jonzn4SUSE

Helpful?

more options

Further to my problem. After a message session with Outlook people turns out the scrolling works while using Microsoft Edge just not Firefox. As mentioned I am using Outlook.com and an old version of Firefox and the feature was working up until about 3/4 weeks ago so why would Firefox all of a sudden not scroll? I have not updated Firefox only windows updates. I would really like to keep using this version 86 of Firefox as I do not like the new look. It's driving me crazy....

Helpful?

more options

Does it work in a more recent version like Developer Edition? Installing this won't affect your existing Firefox 86.

Helpful?

more options

zeroknight said

Does it work in a more recent version like Developer Edition? Installing this won't affect your existing Firefox 86.

It works in Developer Edition.....but does this mean I have to update?

Helpful?

more options

You can install the portable version of the current release that uses its own profile or do a custom installation of the current release in another folder and make sure that you do not launch Firefox, but use the Profile Manager.

Using a developer build like DE for permanent use is not a good idea and this version updates twice per week just like Beta.

You can install a portable (ESR) Firefox version to access websites that do not work with your current Firefox release. The portable version comes with its own profile folder and doesn't interfere with currently installed Firefox versions.

Helpful?

more options

I gave in and downloaded the newest version 121 of Firefox but this now opens up a whole new set of problems I was trying to avoid like.....how to reduce the gap between bookmarks in the drop down way to much space between them. See attached.

Helpful?

more options

Helpful?

more options

zeroknight said

Enable compact mode.

Thanks but did not make a very noticeable difference. I would like them to be almost on top of each other if at all like in the attached from the old version 86

from version 121 https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-12-24-01-38-20-31eabe.png

from version 86 https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-12-24-16-11-17-911af7.png

oh while I am here anyone know what's causing these 00 appearing at the front of whatever I am pasting when I use CtrlV to paste from the clipboard?

AND Merry Christmas to all.

Modified by Dungogvolts

Helpful?

more options

zeroknight said

Enable compact mode.

Thanks but did not make a very noticeable difference. I would like them to be almost on top of each other if at all like in the attached from the old version 86

from version 121 https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-12-24-01-38-20-31eabe.png

from version 86 https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-12-24-16-11-17-911af7.png

oh while I am here anyone know what's causing these 00 appearing at the front of whatever I am pasting when I use CtrlV to paste from the clipboard?

AND Merry Christmas to all.

Helpful?

more options

Chosen Solution

You need to use CSS code in userChrome.css to get the spacing tighter than with compact mode.

:root[uidensity=compact] menupopup :is(menu,menuitem) {
 padding-block: 2px !important;  /*adjust: 0px-4px*/
 min-height: 22px !important;    /*adjust: 21px-24px or unset*/
 height: 26px !important;        /*adjust*/
}
:root[uidensity=compact] {
 --arrowpanel-menuitem-margin: 0 4px !important;
 --arrowpanel-menuitem-padding:2px 6px !important; /*adjust only 2px value*/
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder with the random name (xxxxxxxx.default-release).

You can find the button to go to the profile folder under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in the profile folder with the random name (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt or .css file extension and you end up with a file like userChrome.css.txt or userChrome.css.css. To avoid this, you need to make sure to select "All files" in the "Save File" dialog in the text editor.

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

More info about userChrome.css/userContent.css in case you are not familiar:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css.

Modified by cor-el

Helpful?

more options

cor-el Moderator Top 10 Contributor Dec 26th Thank you for your detailed reply. At first I must have not understood what I was doing so went away came back after a few hours had another look and got it to work the space is much tighter and works better for me. So thank you again and I hope you had a great Christmas Day.

Modified by Dungogvolts

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.