Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube

  • 4 replies
  • 0 have this problem
  • 12 views
  • Last reply by zeroknight

more options

Not sure what's going on, but when I am on YouTube this happens and nothing loads at all. The website is working on Edge and so I think it's YouTube angry that I have ad blocking enabled. Any advice

Not sure what's going on, but when I am on YouTube this happens and nothing loads at all. The website is working on Edge and so I think it's YouTube angry that I have ad blocking enabled. Any advice
Attached screenshots

All Replies (4)

more options

You said you have ad blocking enabled so it may very well be an extension causing the issue. Does it still happen in Troubleshoot Mode?

If it doesn't, try to narrow down the specific extension that causes it. You may need to switch to a different ad blocker.

more options

I will have to try troubleshoot mode next time. The ad blockers have been enabled all this time with no problem at all, it just recently just started happening. Today when I woke up I refreshed the page and it works now (yesterday it didn't work when I refreshed the page) weird....

more options

Having the same issue in Troubleshoot Mode, video doesn't load at all. I tried with blockers disabled and ts mode.

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.