X
Tap here to go to the mobile version of the site.

Support Forum

Why embedded YouTube videos are not playing?

Posted

Embedded YouTube videos will not play in any website. It just shows image saying 'click here' which redirects to YouTube website to play it. Which plays fine.

Attached preview.

Embedded YouTube videos will not play in any website. It just shows image saying 'click here' which redirects to YouTube website to play it. Which plays fine. Attached preview.
Attached screenshots

Chosen solution

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/content-blocking ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 0
Quote

Question owner

None of this help, I also get same issue on Developer Edition with no addons. Tracking is turned off, shield icon is crossed out.

It can be any link on any website, eg https://www.w3schools.com/html/tryit.asp?filename=tryhtml_youtubeiframe

Works fine on Chrome.

None of this help, I also get same issue on Developer Edition with no addons. Tracking is turned off, shield icon is crossed out. It can be any link on any website, eg https://www.w3schools.com/html/tryit.asp?filename=tryhtml_youtubeiframe Works fine on Chrome.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

No problems here with playing the embedded video in that link in Firefox 70 with tracking protection enabled.

Are there any messages in the Web Console related to this issue?

  • "3-bar" menu button or Tools -> Web Developer
No problems here with playing the embedded video in that link in Firefox 70 with tracking protection enabled. Are there any messages in the Web Console related to this issue? *"3-bar" menu button or Tools -> Web Developer
Was this helpful to you? 0
Quote

Question owner

Attached. But it has nothing to do with it, I don't get same errors in any other websites with embedded YouTube videos.

Someone has posted same issue with same message at https://stackoverflow.com/questions/58502467/the-embedded-player-shows-please-click-here-to-watch-this-video-on-youtube-to 3 days ago

Attached. But it has nothing to do with it, I don't get same errors in any other websites with embedded YouTube videos. Someone has posted same issue with same message at https://stackoverflow.com/questions/58502467/the-embedded-player-shows-please-click-here-to-watch-this-video-on-youtube-to 3 days ago

Modified by rhazor

Was this helpful to you?
Quote

Question owner

I think you're lost.

(okay you removed your post who's gonna remove mine)

I think you're lost. (okay you removed your post who's gonna remove mine)

Modified by rhazor

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

Yes, that reply was meant for another tread, sorry about that.

I don't know why embedded vireos do not work for you. Since this affects Firefox DE as well that would suggest either some other (security) software on your computer or something with your connection (VPN, proxy, ISP)that is interfering. I don't know if blocking cookies or blocking the referrer can cause such issues.

Maybe try this in a new clean profile without modifications (do not use a refresh/reset).

Yes, that reply was meant for another tread, sorry about that. I don't know why embedded vireos do not work for you. Since this affects Firefox DE as well that would suggest either some other (security) software on your computer or something with your connection (VPN, proxy, ISP)that is interfering. I don't know if blocking cookies or blocking the referrer can cause such issues. Maybe try this in a new clean profile without modifications (do not use a refresh/reset). *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Was this helpful to you?
Quote

Question owner

Unticking Cookies on Developer Edition fixes it but not on regular Firefox.

Last time I played with profiles I lost all my saved passwords and bookmarks.

Unticking Cookies on Developer Edition fixes it but not on regular Firefox. Last time I played with profiles I lost all my saved passwords and bookmarks.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

What cookie settings are you unticking in DE ? Is this about third-party cookies ?

What cookie settings are you unticking in DE ? Is this about third-party cookies ?
Was this helpful to you?
Quote

Question owner

Just that box attached in screenshot in previous post.

Just that box attached in screenshot in previous post.
Was this helpful to you?
Quote
smihiran98 1 solutions 9 answers

Chosen Solution

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.
Was this helpful to you? 1
Quote

Question owner

I unchecked Recommended and it works now, but I don't understand why. Attached.

I unchecked Recommended and it works now, but I don't understand why. Attached.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.