Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar doesn't fill every webpage correctly

  • 3 replies
  • 0 have this problem
  • 15 views
  • Last reply by techguy150

more options

So, migrating after more than 10 years in chrome I'm currently struggling with the function that completes a webpage while you type (it happens in some webpages, not all). For instance, if I start typing "www.itau", firefox doesn't fill with a known webpage (www.itau.cl). This behaviour is different for, say, typing "www.sa", in wich case firefox fills the missing letters to (www.santander.cl).

I've tryed to delete the suggestion "www.itau" from the address bar with shift + delete, but this isn't a webpage suggestion, so it does nothing.

I'm leaving two screenshots to show.

Sorry for any spelling error, english ain't my main language.

So, migrating after more than 10 years in chrome I'm currently struggling with the function that completes a webpage while you type (it happens in some webpages, not all). For instance, if I start typing "www.itau", firefox doesn't fill with a known webpage (www.itau.cl). This behaviour is different for, say, typing "www.sa", in wich case firefox fills the missing letters to (www.santander.cl). I've tryed to delete the suggestion "www.itau" from the address bar with shift + delete, but this isn't a webpage suggestion, so it does nothing. I'm leaving two screenshots to show. Sorry for any spelling error, english ain't my main language.
Attached screenshots

All Replies (3)

more options

Dropa dijo

Firefox uses what was previously typed in to match url if you don't want the suggest url then you need to turn off that feature. Worse to worse you need to clear the cache/history to remove those url links. But that could remove logins and sites in the URL. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox Archive: https://support.mozilla.org/en-US/questions/1277857

So, I'm not saying that I don't want the suggestion, but that the suggestion system ain't working in this case. I have entered at least 30 times the complete direction "www.itau.cl", and still firefox doesn't suggest that webpage, it still waits for additional letters.

I have successfully deleted some suggestions of other webpages, but in this case it's a problem of missing suggestions, rather than too much suggestions.

This isn't specific to this particular webpage, there are about 5 other ones that the system doesn't auto fill, and by this time it should. All the rest of the webpages I use on a daily basis (more than 50) auto fill correctly.

more options

Dropa dijo

So did you do look here as well. https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Doesn't have results in this case.

It's like firefox doesn't recognize that I've entered the webpage in all this time.

I suspect this becausse www.itau.cl (one of the main banks here in Chile) redirects to ww2.itau.cl, and so from the point of view of firefox I've never gone to www.itau.cl. This behavior was never a problem in chrome by the way (I've migrated this week to firefox).

more options

Clearing your cache and cookies can significantly improve your browser's performance. It is particularly helpful if you have persistent problems with pages not loading as expected when using databases. These problems are often caused by your browser calling up old information from your cache or cookie folder.

Greetings, TG