Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't connect to Google since Firefox 100

  • 5 replies
  • 2 have this problem
  • 80 views
  • Last reply by cor-el

more options

For the 2 weeks or so, I've been having an intermittent problem connecting to any Google services (Gmail, google.com, Google Calendar, Youtube). In gmail, it tells me that I'm offline or "Oops, error getting emails". If I browse to www.google.com, I just get a blank screen.

This seems to have coincided approximately with the release of Firefox 100, but I'm not totally sure it's related. If I clear all cookies and cache, that seems to resolve the problem temporarily, but it comes back. If I open a Private window or another container, that also seems to resolve the problem temporarily, but it comes back.

Other browsers work with no problem.

If I open a new container, it will work for a while, but eventually stop connecting. This doesn't happen with other websites. Only Google related websites.

I have tried doing a Firefox refresh, but that didn't resolve the problem.

For the 2 weeks or so, I've been having an intermittent problem connecting to any Google services (Gmail, google.com, Google Calendar, Youtube). In gmail, it tells me that I'm offline or "Oops, error getting emails". If I browse to www.google.com, I just get a blank screen. This seems to have coincided approximately with the release of Firefox 100, but I'm not totally sure it's related. If I clear all cookies and cache, that seems to resolve the problem temporarily, but it comes back. If I open a Private window or another container, that also seems to resolve the problem temporarily, but it comes back. Other browsers work with no problem. If I open a new container, it will work for a while, but eventually stop connecting. This doesn't happen with other websites. Only Google related websites. I have tried doing a Firefox refresh, but that didn't resolve the problem.

Chosen solution

Some users are having trouble with Google sites because of the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You could try changing this preference to false. You may have to restart the browser. security.tls.enable_0rtt_data

https://support.mozilla.org/en-US/questions/1377212 https://support.mozilla.org/en-US/kb/about-config-editor-firefox

You could also try clearing cookies (which will mean having to log in again) and the cache.

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Some troubleshooting articles.

https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems (also deals with hardware acceleration)

https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

Read this answer in context 👍 1

All Replies (5)

more options

Hi peterkronenberg,

You can try to uninstall the browser and install back the latest version again.

Hope it helps you!

Helpful?

more options

Chosen Solution

Some users are having trouble with Google sites because of the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You could try changing this preference to false. You may have to restart the browser. security.tls.enable_0rtt_data

https://support.mozilla.org/en-US/questions/1377212 https://support.mozilla.org/en-US/kb/about-config-editor-firefox

You could also try clearing cookies (which will mean having to log in again) and the cache.

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Some troubleshooting articles.

https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems (also deals with hardware acceleration)

https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

Helpful?

more options

This was it! Thank you

Helpful?

more options

I have a similar problem with 103.0 (64 bit) When I try to go to Google.com I get this:

Secure Connection Failed

An error occurred during a connection to www.google.com. PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Toggling security.tls.enable_0rtt_data to FALSE does not fix the problem for me. My workaround is to enable DuckDuckGo as my default search engine, but I would rather use Google.

Helpful?

more options

Hi brucegoren

You can try to disable DNS over HTTPS.

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.