Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Pause notifications until Firefox restarts" no longer visible or available in Firefox 90.0, what are some other possible options?

  • 13 replies
  • 1 has this problem
  • 22 views
  • Last reply by AliceWyman

more options

I am trying to disable Firefox notifications whenever I take screenshots, and googling for solutions, I found the commonly suggested solution is to uncheck the "Pause notifications until Firefox restarts" box in Permissions:

How to turn off forever the "screenshot" splash notification

"shot Copied" window

This option is not available in my browser version; thus, I'm hoping there's a newer workaround for this.

Attached screenshots

Modified by cor-el

Chosen solution

The preference alerts.useSystemBackend is set to "true" by default in Firefox 90 on my husband's iMac, so the "Pause notifications until Firefox restarts" Privacy & Security Permissions - Notification setting is not available and the operating system's notification system is used. You can set that preference to "false" in about:config - see Configuration Editor for Firefox for details.

On my Windows 7 computer, that setting is "false" by default and I do see the "Pause notifications until Firefox restarts" setting in my Permissions settings. Related bug: Bug 1621280 Opened 2020-03-10 09:26 EDT Closed 2020-03-10 13:11 EDT `alerts.useSystemBackend` is now false by default on Windows?

Some, but not all Linux systems may also have "Pause notifications until Firefox restarts" available by default. See: Bug 1605842 [Ubuntu] "Pause notifications until Firefox restarts" is not available until the first notification (quote) Matthew N. [:MattN] Comment 2 • 2020-01-09 13:37 EST It should be available on release, beta, and Nightly only on operating systems that don't use the system for display native notifications (that means it should always be there on Windows and some Linux configurations that don't have libnotify).

Read this answer in context 👍 2

All Replies (13)

more options

Any volunteers, please? Or is this a permanent problem (annoyance) that's unfixable? As jscher2000 said, it's been around since a few versions back. And the links I shared are messed up somehow, resulting into a "Page Not Found" error. Here are the links again:

[[How to turn off forever the "screenshot" splash notification|https://support.mozilla.org/en-US/questions/1237229]] [["shot Copied" window|https://support.mozilla.org/en-US/questions/1237229]]

Modified by 0zen

Helpful?

more options

That is where the option should be.


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

You can run this code in the Browser Console to check if this feature is available.

let alertService;
try{
alertService = Cc["@mozilla.org/alerts-service;1"].getService(Ci.nsIAlertsService).QueryInterface(Ci.nsIAlertsDoNotDisturb);
alertService.manualDoNotDisturb = true;
}catch(e){console.log("Do not disturb is not available on this platform: " + e.message)}

Helpful?

more options

cor-el, I got the following result from your suggestion:

Uncaught SyntaxError: redeclaration of let alertService

   <anonymous> debugger eval code:1
   getEvalResult resource://devtools/server/actors/webconsole/eval-with-debugger.js:243
   evalWithDebugger resource://devtools/server/actors/webconsole/eval-with-debugger.js:167
   evaluateJS resource://devtools/server/actors/webconsole.js:1119
   evaluateJSAsync resource://devtools/server/actors/webconsole.js:1011
   makeInfallible resource://devtools/shared/ThreadSafeDevToolsUtils.js:103

I'm not so well-versed with programming, but I tried running the script as you instructed; not sure if this is what I should be getting.

Helpful?

more options

FredMcD, yes, the problem is still there. The option is still missing.

Helpful?

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Firefox ESR; Extended Support Release {web link}

Beta, Developer, Nightly versions https://www.mozilla.org/en-US/firefox/channel/desktop/

Install Older Version Of Firefox {web link}


Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

How to Start all Computers in Safe Mode; {web link} Free Online Encyclopedia

Helpful?

more options

Chosen Solution

The preference alerts.useSystemBackend is set to "true" by default in Firefox 90 on my husband's iMac, so the "Pause notifications until Firefox restarts" Privacy & Security Permissions - Notification setting is not available and the operating system's notification system is used. You can set that preference to "false" in about:config - see Configuration Editor for Firefox for details.

On my Windows 7 computer, that setting is "false" by default and I do see the "Pause notifications until Firefox restarts" setting in my Permissions settings. Related bug: Bug 1621280 Opened 2020-03-10 09:26 EDT Closed 2020-03-10 13:11 EDT `alerts.useSystemBackend` is now false by default on Windows?

Some, but not all Linux systems may also have "Pause notifications until Firefox restarts" available by default. See: Bug 1605842 [Ubuntu] "Pause notifications until Firefox restarts" is not available until the first notification (quote) Matthew N. [:MattN] Comment 2 • 2020-01-09 13:37 EST It should be available on release, beta, and Nightly only on operating systems that don't use the system for display native notifications (that means it should always be there on Windows and some Linux configurations that don't have libnotify).

Helpful?

more options

P.S. If you don't want to make changes in about:config, you can temporarily set Firefox to block new requests asking to allow notifications, in Firefox preferences -> Privacy & Security / Permissions -> Notifications -> Settings and then revert that change, when you no longer need it. See Web Push notifications in Firefox under How do I stop Firefox asking me to allow notifications?

Note: I haven't tried this for blocking the Firefox notifications when you take a screenshot, so I don't know if it works.

Modified by AliceWyman

Helpful?

more options

Thanks Alice

Note that the console output you posted indicates that the 'manualDoNotDisturb" pause feature isn't available on your OS, otherwise there shouldn't have been an error thrown and it should display 'true'.

When I set alerts.useSystemBackend = false, I see "Pause notifications until Firefox restarts" and the code I posted returns 'true' indicating that this feature is supported.

Helpful?

more options

cor-el, you're welcome.

To ozen, Since Firefox is set up to use your Mac system for notifications by default, something else you may want to try is to pause notifications in your Apple menu -> System Preferences -> Notifications preferences (Do Not Disturb setting). See https://support.apple.com/guide/mac-help/receive-pause-or-stop-notifications-mh40609/mac for details.

Helpful?

more options

Helpful?

more options

AliceWyman, you deserve the best accolades for your help, seriously. Thanks so much for your suggestion, it worked smashingly. Sorry, FredMcD, was skeptical about your approach and was glad I didn't follow up on it, but thanks for replying all the same, and to cor-el, too. You were all trying to help and I appreciate that very much.

Helpful?

more options

0zen said

AliceWyman, you deserve the best accolades for your help, seriously. Thanks so much for your suggestion, it worked smashingly.

You're very welcome.

Thanks for marking my reply about the alerts.useSystemBackend preference as the solution. So, you set this preference to false in about:config and that solved the problem? That's great!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.