Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some webpage images do not show

  • 3 replies
  • 2 have this problem
  • 30 views
  • Last reply by LudwigWN

more options

I find that images generally show on webpages such as the front page of a news site. However, when I click into a specific article, the image which is usually near the start of an article in a lot of cases does not show (so it's not a "always never shown" situation); it's as if it's been removed from the webpage syntax i.e. there's no white space section showing something is missing. One example (of many I could include!) is https://www.nzherald.co.nz/nz/phonics-revolution-the-new-sound-of-reading-in-the-nations-schools/7A5UVZ55NAOJEQACLKELCNEU6U/ I verified there are images there by restarting Firefox with Add-ons disabled (which starts Firefox in Safe Mode), and also by opening in another browser. So I went thru and disabled *all* add-ons and restarted Firefox. Images still don't show! These missing images only show when I run Firefox in Safe Mode.

In the back of my mind, there is/used-to-be an option to limit the size of images on a page(?) but I can't find any option now. I have also refreshed Firefox (a number of times; including a total de-install, reboot, re-install) but the problem remains. .. What am I missing? I'd like to be able to see these images.

Thanks.

Chosen solution

Thanks for your answers cor-el & Scribe. Useful information in each (Advanced Tracking info which showed nothing [I haven't gone in there before], and what's disabled in Safe Mode) which I've stored links to in case of future need. Unfortunately I couldn't see anything to tweak, so tried yet another step - create a new profile (which I'm sure refresh & reinstall would have already done). This time at least it seemed to clear the problem!

What I did notice is the prefs.js in the original profile was 84Kb. The new one is only 20Kb, & that's after I re-installed my add-ons & customised a couple of Firefox things (e.g. Bookmarks open in new tab).

So, in the end, not sure what caused the issue (prefx.js got bloated & hence 'corrupt' somehow?) but now resolved. Didn't know which post to mark "Resolved" on so did it on this one, hope that's ok.

Read this answer in context 👍 0

All Replies (3)

more options

Hi, try disabling hardware acceleration - Upgrade your graphics drivers to use hardware acceleration and WebGL.

If you use userChrome.css or userContent.css - you don't have it if you don't know what it is, this is also disabled in Safe Mode, so should be regarded as an additional if rather unlikely suspect, and can be disabled to test by placing /* before, and */ after the file in the chrome folder, then restarting Firefox.

For reference, this is everything that is disabled in Safe Mode: http://kb.mozillazine.org/Safe_mode

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

Are there messages in the Web Console about images not loading ?

See also:

Helpful?

more options

Chosen Solution

Thanks for your answers cor-el & Scribe. Useful information in each (Advanced Tracking info which showed nothing [I haven't gone in there before], and what's disabled in Safe Mode) which I've stored links to in case of future need. Unfortunately I couldn't see anything to tweak, so tried yet another step - create a new profile (which I'm sure refresh & reinstall would have already done). This time at least it seemed to clear the problem!

What I did notice is the prefs.js in the original profile was 84Kb. The new one is only 20Kb, & that's after I re-installed my add-ons & customised a couple of Firefox things (e.g. Bookmarks open in new tab).

So, in the end, not sure what caused the issue (prefx.js got bloated & hence 'corrupt' somehow?) but now resolved. Didn't know which post to mark "Resolved" on so did it on this one, hope that's ok.

Modified by LudwigWN

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.