Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Embedded tweets don't load on any webpage, even on Safe Mode. The tweets load fine in other browsers. What can I do to fix this?

more options

Every time I load a page that has embedded tweets in it--say, a news article that cites content from Twitter--the tweets show up as plain text and nothing else. My solution, in the past, was to just open up Chrome and view the page from there, and return to Firefox when done (is this unreasonable loyalty? haha).

Today, I decided to just isolate the problem and get it fixed once and for all, so I restarted Firefox on Safe Mode. It was still the same! Embedded tweets showing up as plain text. Meanwhile, I wasn't encountering the same problem for the same webpage in Chrome.

Attached are images that show what the embedded tweets look like on Firefox (already in Safe Mode) and Chrome. The first image is for Firefox, the second, Chrome.

I would really hate to switch to Chrome as I prefer Firefox. Help!

Attached screenshots

Chosen solution

hi, are you using firefox in permanent private browsing mode ("never remember history" in the options > privacy panel)? in this case it might be the tracking protection feature that is kicking in: What happened to Tracking Protection?

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

hi, are you using firefox in permanent private browsing mode ("never remember history" in the options > privacy panel)? in this case it might be the tracking protection feature that is kicking in: What happened to Tracking Protection?

more options

Hi, thanks for the quick reply! Yeah, I'm on permanent private browsing mode, so I followed the instructions for disabling the tracking function.

No dice. The embedded tweets still aren't showing, even after I've restarted Firefox.

Is there another solution that might work?

more options

Whoa, OK, I don't know what happened, but I gave it one more shot (rebooted Firefox one more time) and it worked! Embedded tweets are finally showing.

Thank you!