Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Random tabs never load ("rotten" FF sub-processes?)

more options

First I need to point out I'm very difficult user for FF :) Right now I have 52 windows and 476 tabs open

This not a hardware problem as I have good CPU (Ryzen 5 3600) and 64 gigs of memory - running FF 80.0.1 x64 on Windows 10 19041 x64

Until recently everything was fine - I'm not able to tell when that changed but it's just few days

When I start FF, some tabs (from "restore" session) never load. Tab just shows its loading but never finishes. Moreover if I try to open new tabs, they RANDOMLY also never load - doesn't matter which site/page (in other browser same url opens instantly). I need to open X new tabs, paste URL and hit enter into each and after a while the Xth tab loads instantly. X is changing - with freshly started browser its something like 2-4 new tabs. Later it can be 10 or more until "I find" the tab which loads. When I do that, i can open Dev Tools before pasting URL - Networking tab shows no requests, nothing. Same with right-clicking links in working tabs (open link in new tab).

Working tabs are usually good - left clicking links or F5 works fine. But if the tab is left open for some time without activity, it can also stop working (F5 doesn't help)

What i tried: - disable my Firewall (Kaspersky) - restart FF in safe mode without plugins - no "clear cache and cookies" as its not related to any specific site or page

I got the idea recently that maybe there is some problem with FF processes "rotting" (multi process architecture) so I'v tried to kill some of the sub-processes in Task Manager. Of course its hard to find the right one but I'v managed multiple times to hit the right process and suddenly all "loading forever" tabs showed as "crashed" and when I hit "Restart all crashed", all loaded instantly

Any help appriciated! Thanks!

All Replies (1)

more options

> I'm happy to report my problem seems to be fixed after updating to FF 81

Unfortunately I was too fast and optimistic...FF 81 didn't fixed the problem :(

Modified by Michal Levý