Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

prompt text on wrong elements

  • 4 replies
  • 1 has this problem
  • 16 views
  • Last reply by Maxim

more options

Hello community! I have some weird behavior with my fox. On every site, like youtube, twitter and almost every other site, I see prompt text blinking pipeline. This appears on youtube videos in left bottom corner, on icons on websites, etc and also allows to highlight text in places that not mean(implied) to perform that. This is doesn't interrupt my experience, but it's kinda annoying and I would like understand what it is and how to disable this. Safe-mod reduces the frequency of behavior appear, but does not fix that completely. Appear on windows and mac os as one. Thanks in advance.

Attached screenshots

Modified by Maxim

Chosen solution

I can't be sure because I've never seen it in dark mode, but I think it probably is the "caret browsing" feature. There's a checkbox for that:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cursor and Firefox should filter to the section with this checkbox which you can "uncheck": "Always use the cursor keys to navigate within pages"


There also is another way to manage this feature that is a little more under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste caret and pause while the list is filtered

(3) If the accessibility.browsewithcaret preference is bolded and has a value of true, double-click it to restore the default value of false

(4) If you do not want the F7 key to switch this feature on and off, double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hope that helps!

P.S. If you quote a URL like an image address in a reply, your post may be delayed while it is checked for spam.

Read this answer in context 👍 1

All Replies (4)

more options

another example

more options

Maxim said

another example
more options

Chosen Solution

I can't be sure because I've never seen it in dark mode, but I think it probably is the "caret browsing" feature. There's a checkbox for that:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cursor and Firefox should filter to the section with this checkbox which you can "uncheck": "Always use the cursor keys to navigate within pages"


There also is another way to manage this feature that is a little more under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste caret and pause while the list is filtered

(3) If the accessibility.browsewithcaret preference is bolded and has a value of true, double-click it to restore the default value of false

(4) If you do not want the F7 key to switch this feature on and off, double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hope that helps!

P.S. If you quote a URL like an image address in a reply, your post may be delayed while it is checked for spam.

more options

jscher2000 said

I can't be sure because I've never seen it in dark mode, but I think it probably is the "caret browsing" feature. There's a checkbox for that:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type cursor and Firefox should filter to the section with this checkbox which you can "uncheck": "Always use the cursor keys to navigate within pages"

There also is another way to manage this feature that is a little more under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste caret and pause while the list is filtered

(3) If the accessibility.browsewithcaret preference is bolded and has a value of true, double-click it to restore the default value of false

(4) If you do not want the F7 key to switch this feature on and off, double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hope that helps!

P.S. If you quote a URL like an image address in a reply, your post may be delayed while it is checked for spam.

Thank you for such detailed answer and p.s.! Appreciate this. Seems that this actually was my case and TIL. Have a great day!