Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Setting: Check spelling when typing.

more options

Hi, the settings feature has stopped working for me for a while now: Check spelling when typing. How can I turn it on? It is enabled in the settings. Sorry for my English, I use an interpreter.

Chosen solution

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Language and Appearance: "Check your spelling as you type"

You can look here for dictionaries:

Note that for spell checking you need a dictionary.
A language pack provides string translations for the user interface.

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

Read this answer in context 👍 1

All Replies (7)

more options

Hello SilverFalconi,

  • Click on menu icon.
  • Click on Options.
  • In left pane, you will find General menu, Click on it.
  • In this menu, You will find language Setting.
  • Click on the Check your spelling as you type Checkbox.

Hope it works. Thank You.

Helpful?

more options

As I wrote above, I have this check box selected, but the spelling is not checked. Also in my languages I have several, the main one is the first. It doesn't help.

Helpful?

more options

Chosen Solution

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Language and Appearance: "Check your spelling as you type"

You can look here for dictionaries:

Note that for spell checking you need a dictionary.
A language pack provides string translations for the user interface.

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

Helpful?

more options

Thank you very much! It helped.

Helpful?

more options

Can you tell what the problem was in your case as this might help others ?

Helpful?

more options

The check box in the program settings has been enabled, and the language is selected, and what is needed in the first position. But I did not know that the language should be chosen not in the settings, but through the right mouse button. Dictionaries have been installed for me, but the correct spelling language has not been selected. The screenshot showed where the problem was.

Helpful?

more options

The problem was that an English dictionary was chosen. And I do not correspond in English at all. I only need English for work. That's why I didn't see that the spelling is checked only in English. Thank you again!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.