Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell checker doesn't work.

  • 4 replies
  • 19 have this problem
  • 28 views
  • Last reply by Tolqua

more options

Hi,

New PC. Installed Firefox. Spell check does not work. 'Check spelling as you type' is enabled in settings. US English language pack installed. Spell check does not work.

What am I missing?

Thanks.

All Replies (4)

more options

Note that a language pack only includes translations of strings in the user interface and doesn't include a dictionary.

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> Advanced: General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

more options

Installing the language pack and dictionary fixed the problem for me, but I think the language was already installed (isn't this part of the install?). Seems strange to build in the spell-check functionality without including the dictionary necessary for it to work.

Tolqua.

more options

A lot of dictionaries have a specific license that prevents Mozilla from including the dictionary as part of the installation. In such cases you will have to install the dictionary yourself.

more options

Thanks for the explanation, cor-el.

Tolqua.