Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox keeps removing YouTube from address bar dropdown box

  • 10 replies
  • 1 has this problem
  • 91 views
  • Last reply by asterrameth

more options

I have been using firefox since forever and have grown quite accustomed to things being where they have been for the past x years but lately firefox has developed a frustrating tendancy to delete youtube from the dropdown box that appears when clicking the address bar (formerly accessible via the down arrow in the addy bar)

I do not know why it does this, youtube is my most visited website and it vanishing off that bar demanding i manually type youtube to access it is terrible and very anoying. I'm pretty much stuck now reloading youtube hundreds if not thousands of times untill it finally reappears there (already reloaded the homepage about 100 times and its still not back in the list)

So i see people asking how to remove things from there, I need to know a simpler way to ADD things to there. Or better yet a fix so that my most viewed website no longer deletes itself from the TOP of the list

I have added an image of the list as it is now, normally youtube would be at the top, for obvious reasons, instead as of today WHILE firefox has been running, its been removed, Certain sites have been blacked out for obvious privacy reasons

Attached screenshots

Chosen solution

Hi asterrameth, your original screenshot shows a blank address bar, meaning, that is the list Firefox shows before you have attempted to search anything, before typing any characters. Is that correct?

Starting in Firefox 75 (or in 77 if you reverted the bar for 75-76), Firefox automatically shows the first 8 sites from your new tab page Top Sites instead of the old "frequent sites" list. With that in mind, you have a few different options for making frequently visited pages more accessible, including:

(1) After clicking in the address bar, type a space to summon the frequent URLs list

(2) Edit your Top Sites on the new tab page so YouTube is pinned among the first 8 sites

This article has the steps to edit Top Sites: Customize the New Tab page

(3) Create a keyword bookmark so you can summon YouTube more quickly

Here's how:

Bookmark YouTube, then find that bookmark, right-click it, and choose Properties.

In the Keyword field, type y and save the change.

Now when you type y in the address bar and press Enter, Firefox will immediately load that bookmarked URL.

Read this answer in context 👍 1

All Replies (10)

more options

hello asterrameth,

I can understand your problem. Please follow this link, the problem will be solved.

1. Clear the cache

  • Click the menu button. and select Options. ...
  • Select the Privacy & Security panel.
  • In the Cookies and Site Data section, click Clear Data….
  • Remove the check mark in front of Cookies and Site Data. ...
  • With Cached Web Content check marked, click the Clear button.
  • Close the about:preferences page.

for more information:

[https://support.mozilla.org/en-US/kb/how-clear-firefox-cache] 2. Clear all cookies, site data and cache:

  • Click the menu button. and select Options. Preferences.
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Click the Clear Data… button. The Clear Data dialog will appear. ...
  • Click Clear.

for more information:

[https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox]

3. restart your computer:

I hope resolve your problem then reply me back.

Thank you!

Regards, Arman khan

Helpful?

more options

Finally managed to find the absolutely miniscule options for the address bar, of which theres only 3 check boxes relating to the suggested sites it will show

- Browsing history, mostly youtube - Bookmarks, well since i havent BM'd any website more than once I guess my list should be HUGE - and open tabs more than half of all my tabs combined are youtube.

Oops while i was doing my own searches and then typing this I got a reply! I will go try your suggestions now!

Modified by asterrameth

Helpful?

more options

hello asterrameth,

your problem is solved or not reply me please.

I'm grateful to you,

Regards ,

Arman

Helpful?

more options

ARMAN KHAN said

hello asterrameth, your problem is solved or not reply me please. I'm grateful to you, Regards , Arman

hi I just finished restarting my computer but for some reason its not worked this time. I actually think last time I had this happen I cleared cache but this time It hasn't fixed it. Still no youtube, sad days! lol

Helpful?

more options

Hello asterrmath,,

Clearing a single item from the address bar history

   To clear a single item in the address bar history, type or paste enough text for Firefox to show the item in the drop-down.
   Press the ↓ down arrow key or move the mouse, to highlight the entry to delete.
   To clear the highlighted item, hold down the Shift key and press Delete on your keyboard.

Helpful?

more options

yogyta kalwar said

Hello asterrmath,, Clearing a single item from the address bar history To clear a single item in the address bar history, type or paste enough text for Firefox to show the item in the drop-down. Press the ↓ down arrow key or move the mouse, to highlight the entry to delete. To clear the highlighted item, hold down the Shift key and press Delete on your keyboard.

sorry but that is the direct opposite of what I want. I want youtube ON my address bar history. It was there this morning but when firefox updated it went away. Every other website is still there except youtube, which is my most visited website by far, I have over a dozen youtube tabs open right now.

That is the problem, something I had is gone and i cannot find any way of bringing it back, I have been reloading the youtube homepage more tonight, It still is not there, I have loaded the page hundreds of times today trying to bring it back

Helpful?

more options

Could you look at it from a different angle:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autocomplete.enabled preference is not bolded and still has its default value of true, at least one of these must still also be set to true:

(A) browser.urlbar.suggest.bookmark (B) browser.urlbar.suggest.history (C) browser.urlbar.suggest.openpage (D) browser.urlbar.suggest.searches

If you double-click the browser.urlbar.autocomplete.enabled preference to flip its value from true to false, all four of those should also switch to false.

Helpful?

more options

Hi Aman

I just went in and had a look, my preferences in they were a mess, I didnt even have the browser.urlbar.autocomplete.enabled option in the list, I copy pasted it in and hit the plus sign which added it to my preferences list. The other 4 were set to True and I had another - browser.urlbar.suggest.topsites which was set to False. So i'm not sure what I did there, It was probably when i was messing with the version 75 workaround to stop the address bar enlarging.

When i flip browser.urlbar.autocomplete.enabled between True and False nothing happens to anything else in there. I set those all to true and restarted the browser but that didnt do anything, do i need to do a full reset of my computer for that to take effect? Or did I do it backwards and I was meant to have them on False?

Helpful?

more options

Chosen Solution

Hi asterrameth, your original screenshot shows a blank address bar, meaning, that is the list Firefox shows before you have attempted to search anything, before typing any characters. Is that correct?

Starting in Firefox 75 (or in 77 if you reverted the bar for 75-76), Firefox automatically shows the first 8 sites from your new tab page Top Sites instead of the old "frequent sites" list. With that in mind, you have a few different options for making frequently visited pages more accessible, including:

(1) After clicking in the address bar, type a space to summon the frequent URLs list

(2) Edit your Top Sites on the new tab page so YouTube is pinned among the first 8 sites

This article has the steps to edit Top Sites: Customize the New Tab page

(3) Create a keyword bookmark so you can summon YouTube more quickly

Here's how:

Bookmark YouTube, then find that bookmark, right-click it, and choose Properties.

In the Keyword field, type y and save the change.

Now when you type y in the address bar and press Enter, Firefox will immediately load that bookmarked URL.

Helpful?

more options

jscher2000 said

Hi asterrameth, your original screenshot shows a blank address bar, meaning, that is the list Firefox shows before you have attempted to search anything, before typing any characters. Is that correct? Starting in Firefox 75 (or in 77 if you reverted the bar for 75-76), Firefox automatically shows the first 8 sites from your new tab page Top Sites instead of the old "frequent sites" list. With that in mind, you have a few different options for making frequently visited pages more accessible, including: (1) After clicking in the address bar, type a space to summon the frequent URLs list (2) Edit your Top Sites on the new tab page so YouTube is pinned among the first 8 sites This article has the steps to edit Top Sites: Customize the New Tab page (3) Create a keyword bookmark so you can summon YouTube more quickly Here's how: Bookmark YouTube, then find that bookmark, right-click it, and choose Properties. In the Keyword field, type y and save the change. Now when you type y in the address bar and press Enter, Firefox will immediately load that bookmarked URL.

changing the Top Site order when i load a new tab has got my youtube back in the address bar! It happened to be sitting in the number 9 slot which is where it had been all along but I just had to shuffle it that 1 spot. It was the update to 77 which disabled my about:config changes which is why it vanished but now its back to how it always was. I just liked the ability to be on some website then clicking the down arrow (or just clicking the address bar anywhere now) then going straight to youtube. So its really good that I can do that again without having to type or take my hand off the mouse

I knew there had to be some obvious solution I was missing, and the fix took 5 seconds!. Thanks everyone for trying and working with me. Have a nice week!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.