Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell Check

  • 15 replies
  • 1 has this problem
  • 90 views
  • Last reply by FredMcD

more options

My language is set to English (UK) under Options, but any typing on web pages are spell checked in Turkish. How can I corerct this conflict?

Thanks

Attached screenshots

Chosen solution

Dear FredMcD and

Thanks for your advice, sorry for the late response.

Now I spent some time on your guidance, I have managed to uninstall Firefox from the control panel> Programs and Features, shut down and restart the computer and reinstalled.

Sorry but I was unable to follow your directions to the letter.

I think problem was persisting and as I reinstalled, I also opted for an option offered to clean and make a new start or something similar. It solved the problem but created a new problem.

It is showing in the Options>General>Language “English UK set” as well as click on “Choose” and Check your spelling as you type Checked but it is not picking up misspellings. Also right click on the text is not showing spell check option.

Than I realised I have not installed dictionary. It is done now and the problem is solved.

Perfect

A BIG THANK YOU TO ALL.

Read this answer in context 👍 0

All Replies (15)

more options

https://addons.mozilla.org/en-US/firefox/language-tools/

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district are selected.


Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Helpful?

more options

Thanks Fred

I removed Turkish. Tunrned Firefox off and on. Made no difference. Removed English (no language selected for spell check). Tunrned Firefox off and on. Still no difference. Still spell checking to Turkish.

Any Other suggestion please?

Helpful?

more options

Sorry Fred, forgot to thank you and showed my appreciation!

Helpful?

more options

Hi o.karel,

could you please test & report back if the following can mitigate the problem:

  • close all running instances of firefox.
  • press windows-key + R to open the run dialog.
  • open: 'firefox.exe -purgecaches'.
  • check if the language confusion is still present afterwards .

Thank You !

Modified by Shashank Shekhar

Helpful?

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Helpful?

more options

Thank you Shashank Shekhar

Trying again after 'firefox.exe -purgecaches'. Still no change. No language selected for spell check.

Windows-key + R to open the run dialog. open: 'firefox.exe -purgecaches' seem to open immediately a new FirfoxTab, so I am not sure if it is purging any caches?

Can you still help please?

Thanks

Helpful?

more options

Modified by Shashank Shekhar

Helpful?

more options

Thank you cor-el

I beleive I tried all your sugegstions correctly. Even without any languge selected , and now "Check your spelling as you type" unchceked, my typing is still checking my english text in Turkish. Now I tried unchecking right click and the underliend zigzag stopped showing.

I now unchceked Check your spelling as you type. No zigzags. nta highlighting spelling mistakes.

Now I added Englisg GB only from "Choose your preferred language for displaying pages". And typing, no spell check working on my deliberete. Now right clicked and checked spell check and back to the same problem.

Helpful?

more options

Hi Shashank Shekhar

Thanks but I need English UK not US.

I intially unintsalled Turkish and English UK and re installed the language as the attched screen captures. Still no change.

When I right click and curson on language, only Turkish is showing. I tried to add english but it takes me to Add On web page with only option for English UK is to remove. I could not find a way of removing Turkish selected with right click etc.

Helpful?

more options

I just checked, Türkçe (TR) Language Pack appear to have been installed before by me (highlighted in different colur as English but when I select, it gives me the otpion of installing, unlike English with Remove.

Helpful?

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop


Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer.


If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Helpful?

more options

For spell checking you only need to install the correct dictionary and not a language pack, sorry for the confusion.
You can uninstall language packs for languages that you do not need.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary.
A language pack provides string translations for the user interface.

Helpful?

more options

Chosen Solution

Dear FredMcD and

Thanks for your advice, sorry for the late response.

Now I spent some time on your guidance, I have managed to uninstall Firefox from the control panel> Programs and Features, shut down and restart the computer and reinstalled.

Sorry but I was unable to follow your directions to the letter.

I think problem was persisting and as I reinstalled, I also opted for an option offered to clean and make a new start or something similar. It solved the problem but created a new problem.

It is showing in the Options>General>Language “English UK set” as well as click on “Choose” and Check your spelling as you type Checked but it is not picking up misspellings. Also right click on the text is not showing spell check option.

Than I realised I have not installed dictionary. It is done now and the problem is solved.

Perfect

A BIG THANK YOU TO ALL.

Helpful?

more options

Sorry the previous message meant to start as

Dear FredMcD and cor-el

Helpful?

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.