搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Spell checking not working in all forms

  • 5 回覆
  • 4 有這個問題
  • 29 次檢視
  • 最近回覆由 cor-el

more options

Spell check is working in this text box but when I type words into mail.com webmail email compose form, spell checking does not work.

I have already changed the about:config option so that single line text boxes are spell-checked.

Is there some kind of JavaScript option that disables spell-checking? If so then how do I disable this? I want my emails to be spell-checked.

Spell check is working in this text box but when I type words into mail.com webmail email compose form, spell checking does not work. I have already changed the about:config option so that single line text boxes are spell-checked. Is there some kind of JavaScript option that disables spell-checking? If so then how do I disable this? I want my emails to be spell-checked.
附加的畫面擷圖

所有回覆 (5)

more options

Could it be that mail.com has its own spellchecker? Many rich-text webmail portals that I have used do have a spellchecker. Like maybe under the Options button on the right-side of your screenshot? Beyond that, check with their support or help pages to learn how to turn on the spellchecker feature.

more options

I don't want Firefox allowing websites to take control of my browser, it's becoming more and more irritating and Mozilla seems to side with website developers over users.

Give me my spell check back.

more options

Firefox will disable Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

more options

cor-el said

Firefox will disable Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element.

That is the problem, I want a solution that gets me my spell check working again due to Mozilla having allowed websites to disable my browsers features - WTF?

more options

There are cases where you would want this to work like when translating text in a foreign language via Google Translate that would underline every word in such a case.

Did you check all buttons on the toolbar that shows in your above posted screenshot to see if the editor includes its own spelling checker? If an editor like that one disables the spelling checker then you would expect a replacement.