Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google vs. Yahoo

more options

I have my search engine set to Google, but lately when I start searching it automatically switches to Yahoo. Why?

PK

Chosen solution

Hi PK, it would also be useful to know how extreme the hijacking is. Sometimes the problem is so bad that when you search using the search box on Google's own sites, your results come out on Yahoo. As Andrea suggests, that isn't a settings issue, it's likely an extension, or even external malware.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Don't allow unknown third party software to run in your Firefox.

Any improvement?

To scan for and clean up external malware, the following support article lists several useful free tools (completely free or free trial): Troubleshoot Firefox issues caused by malware.


Apparently a bad extension going around makes the Add-ons page unusable, just blank. To use the page, you then need to restart Firefox in its Safe Mode:

Either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Read this answer in context 👍 0

All Replies (10)

more options

Did you install the Yahoo Search and Homepage add-on recently? That one makes Yahoo the default search engine even if your Firefox setting in Preference is Google.

Helpful?

more options

Chosen Solution

Hi PK, it would also be useful to know how extreme the hijacking is. Sometimes the problem is so bad that when you search using the search box on Google's own sites, your results come out on Yahoo. As Andrea suggests, that isn't a settings issue, it's likely an extension, or even external malware.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Don't allow unknown third party software to run in your Firefox.

Any improvement?

To scan for and clean up external malware, the following support article lists several useful free tools (completely free or free trial): Troubleshoot Firefox issues caused by malware.


Apparently a bad extension going around makes the Add-ons page unusable, just blank. To use the page, you then need to restart Firefox in its Safe Mode:

Either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Modified by jscher2000

Helpful?

more options

At first I didn't think there was a problem with my add-ons. But there was a Media Player Add-On that said disabled, but it was still there. After removing it my searches went back to normal. Thank you for your help!

Helpful?

more options

I have followed all the directions to NO AVAIL to remove the Yahoo search engine - it keep popping up as search engine. I need a away to permanently remove The Yahoo search engine or I will delete Firefox as my preferred web browser.

Helpful?

more options

Hi braveheartla, Firefox hasn't included Yahoo search in recent years. Here are some things to check as to why it's showing up:

Default Search Engine Setting

Firefox usually has Google as the default. The article "Change your default search settings in Firefox" has the steps to check and update that setting if needed. If this setting is not stable, is there a pattern to when it changes? For example, when you exit/quit Firefox and start it up again? Or when you restart your system?

Startup (Home) Page Setting

If your startup/home page was changed to Yahoo, this is a separate setting. More info in the following article: How to set the home page. Also check your add-ons as described earlier in this thread.

Sometimes malware will modify your browser shortcuts with a URL to open at startup. More info on that if needed, but also, supplement your regular security software with some additional scans: Troubleshoot Firefox issues caused by malware.

New Tab Page

There are some add-ons that change your new tab page to Yahoo. Check your add-ons as described earlier in this thread.

Search Hijack

In the extreme case, when you type your query in the address bar and the top line of the drop-down says "Search with Google" you may get results on a different site. Check your add-ons as described earlier in this thread.

See also: What to do when searches take you to the wrong search website.

Helpful?

more options

I tried all the recommended solutions then I uninstalled Firefox and did a new install. There are no add on's now. Google search comes up when I open a new tab but when I enter my data incomes up on anew page as a YAHOO search. It only happens in Firefox not Safari (I am MACOS). I even totally reinstalled the operating system MACOS. What next? Janice Wilson

Helpful?

more options

Hi Janice, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If that does not work or if Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

I installed Browse safe add on and it changed my main search engine to yahoo so i removed the add on. But when i searches for things it went to yahoo. In my settings it says my main search engine is google but when i search things it goes to yahoo.

Helpful?

more options

hughsthebesst said

I installed Browse safe add on and it changed my main search engine to yahoo so i removed the add on. But when i searches for things it went to yahoo. In my settings it says my main search engine is google but when i search things it goes to yahoo.

Please check all your other extensions.

You also can scan for malware: Troubleshoot Firefox issues caused by malware

Helpful?

more options

This is a nasty little virus that can block the adds on solution given above. I found Refresh to work perfectly, keeping most of my bookmarks etc. and getting rid of it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.