Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Going to YouTube with Firefox, it will redirect me from the Home page, to a random suscription page.

  • 9 replies
  • 1 has this problem
  • 26 views
  • Last reply by McCoy

more options

Each time I go to YouTube, with Firefox, it will redirect me from the Home page to a random subscription channel. If I click on Home, it will not remain there, but redirects me every time. Disabled AdBlocker, but with no success. Do not have this problem if I use Edge or IE.

Chosen solution

Hello   David Florence,

Do you by any chance have an extension installed called   "YouTube High Definition" ?

I'm asking because it turned out to be the culprit in other threads where the same problem was reported.

Read this answer in context 👍 1

All Replies (9)

more options

Can you provide the URL it directs you to?

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Helpful?

more options

Worked after deleting everything, but as soon as I login to YouTube it redirects me again. As far as a URL, it is never the same, random.

Helpful?

more options

Hello,

Thanks for clearing the cache and cookies.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu , click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Helpful?

more options

Helpful?

more options

Chosen Solution

Hello   David Florence,

Do you by any chance have an extension installed called   "YouTube High Definition" ?

I'm asking because it turned out to be the culprit in other threads where the same problem was reported.

Helpful?

more options

Thank You McCoy, have removed the add-on. BTW, thanks to all of you that responded.

Helpful?

more options

David Florence said

Thank You McCoy, have removed the add-on.

My pleasure   -   I'm glad that everything is back to normal !

Helpful?

more options

Excellent post to a very, very pesty problem at the YouTube site. I had the same problem of being automatically redirected to an ABC marketing site. As suggested, I removed the YouTube High Definition extension, and the problem is fixed. Thank you kindly to all above. Tim

Helpful?

more options

@ tim.krill :

I'm so glad that for you the YouTube High Definition extension turned
out to be the culprit as well;   thank you for letting us know !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.