Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problems signing in to RBC with latest Firefox release Jan 2020

  • 115 replies
  • 20 have this problem
  • 7591 views
  • Last reply by MrSensible

more options

Unable to properly sign in to RBC (Royal Bank of Canada) online banking since install of the latest Firefox release 72.0.1. Windows 10, up to date. Other sites work. Chrome can access RBC ok. No error messages, it just doesn't get through the bank security protocol for some reason via Firefox. Sits with a blank screen.

Chosen solution

Try to set this pref to false on the about:config page.

  • network.http.spdy.enabled.http2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 8

All Replies (15)

more options

This issue has been fixed for Firefox 74 (beta) and Firefox 68 ESR.

  • Bug 1613943 - Intermittent blank page when logging into Royal Canadian Bank

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

I was able to sign in once earlier today with Windows 7, FF 73.0 (64-bit) but not since then.

more options

gord.cath said

Unable to properly sign in to RBC (Royal Bank of Canada) online banking since install of the latest Firefox release 72.0.1. Windows 10, up to date. Other sites work. Chrome can access RBC ok. No error messages, it just doesn't get through the bank security protocol for some reason via Firefox. Sits with a blank screen.

cor-el said

Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Although this may be a temporary solution, disabling a modern protocol like SPDY has a domino effect on all your browsing. This is NOT a solution!

RBC should get their sh*t together and fix their website and servers and come into the 21st century. We can not now configure our browsers for each website that we visit. That is insane!

As a software engineer/programmer, I program my websites to be compatible with all browsers, especially the ones that have the biggest browser market share like Chrome, Firefox, Safari, Edge. You would think that RBC would do the same thing as their clients are from all walks of life with different browsers. Shame on RBC!

more options

I am having the same issue logging into my RBC account with Firefox and I am not using the most recent version in fact I'm running an older version (66). I run Linux (Mint) and it too is an older version so auto updates do not work anymore since the version is supported for 2 years only and my version is now 3 years old. This is why I'm still running the older version of Firefox as I update my system with the auto updates only as manual updates with Linux can sometimes be problematic and I am not very tech savvy. I've called RBC a couple of times and they said they were working on the problem but they mainly just blamed Firefox saying Firefox is being very "slow" about resolving the issue at their end. Since I run an older version of Firefox and am having the same issue as users with the newest Firefox it seems logical that the problem is with the bank and not the browser.

I should mention the problem started for me only 3 or 4 days ago, however the message to clients started appearing on the RBC website at least a week prior. I did not have any problems logging on at that point so I assumed it was an issue limited to users of the newest Firefox version and since I ran version 66, it didn't apply. Of course that changed with time.

more options

Today I successfully signed in 3 times with FF 73.0 (64-bit) using Windows 7. Just tried it with FF 52.9.0 (32-bit) on my Windows XP desktop and it also works now.

more options

I have been signing in to RBC with no problems after updating to Firefox 73.0. I have the latest 64 bit Mac Catalina O/S.

I think 73.0 has handled the problem that arose when 72.0 came out.

John

more options

Also appears to be fixed for me after updating to FF 73.0. Two different machines, both Windows 10; one 32-bit and the other 64-bit.

If you are checking for yourself after updating to FF 73.0, remember to undo your about:config change if you did make the "fix" listed in this topic.

more options

I haven't upgraded to 73 yet, nor made the config change to 72.0.2 (W7).

Just thought I'd try again to see if anything had perhaps been done on RBC's end....

I was able to log in and access my account without issue now.

more options

Sounds OK now. Thanks Saïd

more options

An update to my post of Feb 14th (issue with logging on to RBC with Firefox). Today (Feb 16th) the problem is resolved and I have been able to log on again. The RBC log on page still displays the message to clients that there is a technical problem with Firefox browsers, however that message is either no longer accurate or perhaps it is with certain versions of Firefox. I'm still running an older version (with Linux Mint) and the problem is resolved.

more options

New release of Firefox 73.0.1 out fixes problem with logging on to RBC

more options

gmaracle57 said

New release of Firefox 73.0.1 out fixes problem with logging on to RBC

I haven't updated to 73, still on 72.0.2, but the problem seems resolved. I just logged into my accounts without a problem. I'm hesitant to upgrade to 73 since 72 is working just fine everywhere for me on Win 7. Anyway, all is good here now. I'll read over the changes they've implemented before I upgrade. Thanks to all who replied to my posts. This is a great community {first time user here}. Bye for now.

more options

73.0.1 works fine with RBC sign in a couple of time already.

more options

I haven't had the problem for a week or two now. Using Firefox 73.0.1 on Windows 10, with a private window. I did set the "network.http.spdy.enabled.http2 = false" back to true.

I guess the problem has been solved. Since I started the thread, do I need to be the one to close it?

Modified by gord.cath

more options

gord.cath said

I haven't had the problem for a week or two now. Using Firefox 73.0.1 on Windows 10, with a private window. I did set the "network.http.spdy.enabled.http2 = false" back to true. I guess the problem has been solved. Since I started the thread, do I need to be the one to close it? I have to say that this issue has shaken my faith in both RBC and Firefox, except for the help from this forum.

Suggest you read the Bug Report https://bugzilla.mozilla.org/show_bug.cgi?id=1613943 before assigning any culpability to RBC.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6