Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problems signing in to RBC with latest Firefox release Jan 2020

  • 115 replies
  • 20 have this problem
  • 7591 views
  • Last reply by MrSensible

more options

Unable to properly sign in to RBC (Royal Bank of Canada) online banking since install of the latest Firefox release 72.0.1. Windows 10, up to date. Other sites work. Chrome can access RBC ok. No error messages, it just doesn't get through the bank security protocol for some reason via Firefox. Sits with a blank screen.

Chosen solution

Try to set this pref to false on the about:config page.

  • network.http.spdy.enabled.http2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 8

All Replies (20)

more options

For me this RBC problem only started a couple of days ago. FF 72.0.2, on Win7 32-bit. I don't have any problems with other banking sites, and I do not wish to switch browsers.

Tools\Web Developer\Inspector says that this is the problem:

"Loading failed for the <script> with source “https://nexus.ensighten.com/rbc/olb/serverComponent.php? ... " " [remainder trimmed]

But of course this may not be the *only* problem, just the first one that FF hits.

And I find it hard to believe that any credible IT department would still be recommending its clients to use Internet Explorer as an alternative browser...

more options

My Win7 machine has not had any problems using FF72.0.2 to access RBC online banking. At all. That's why I was beginning to suspect a recent Microsoft update might be involved. Unfortunately I can only back out my Win10 machine to end of January, as I've already cleaned up the older System upgrade backout files. If anyone still has any older (prior to January 2020 or December 2019) MS system upgrade back out files on their machines, and would like to try backing out the more recent MS KB####### upgrades, to see if it affects the FF/RBC access problem, I would say, go for it.

"It's every site's web developers' job to make it work with all popular browsers." Really? That's just a bit arrogant to generalize and dictate anyone's job function. Or to tell RBC that it's "their problem", because one, out of a world full of web browsers and clones, is having intermittent/regular problems accessing them, when all the rest are working fine. They could say with impunity, that if the developers at Mozilla stopped screwing around with Firefox in the interests of "improving or enhancing" the product, to the point where it doesn't work on some websites any more, that they own it. Same argument, reversed. And you cannot deny that FF is fraught with problems, usually self inflicted, since the Quantum roll out over a year ago. Not so with RBC web access. It's been bullet proof.

Modified by MrSensible

more options

Has there been any comment from Mozilla on this issue?

more options

Chosen Solution

Try to set this pref to false on the about:config page.

  • network.http.spdy.enabled.http2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

cor-el said

Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el.

more options

MrSensible said

cor-el said
Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el. Have tried it several times, and I'm golden. I can navigate through the RBC website as normal. Signin and PVQ works as it used to. Looks good now. Thanks for the fix. If you need any other real world testing, reply to this thread. I will try to help.

M. p.s. Win10, laptop, all MS updates in place, FF 72.0.2.

Modified by MrSensible

more options

johnb6 said

MrSensible said
Download and install the Opera browser. It works fine on RBC, and has gotten me around other FF issues over the last 6 months. If you're not familiar with it, it's a functional clone of Google Chrome, but more like a "lite" version of Chrome. Does everything GC and FF do. Just a suggestion.

We are Firefox users for a reason, which is that we find it's the best and all those others are awkward, unfamiliar and inferior. Of course I can access my RBC account with Chrome in an emergency, but I hate it. I just keep Chrome around for experimenting. Abandoning Firefox is not the way to sustain it. We need to keep getting after RBC and Mozilla to get together and fix the problem.

Ooooops? The fix came from Mozilla/FF.

more options

blwtalk said

johmyn said
Thanks much for exploring ,contacting and communicating the problem

You're welcome. If everyone with this problem called RBC Online Banking Support 1-800-769-2555 and mentioned it, maybe it'll prompt them to work a little harder and faster.

The fix suggested was a FF "guts" modification. RBC has no responsibility for this problem;.

more options

gwp99 said

Looks like I'm back to using good old Opera. Good bye Firefox.

There's a fix. See cor-el's comments nesr the end of this topic.

more options

If the RBC site worked before and the problem only started recently then this fix looks like being caused by some changes RBC made.

Flipping the pref is for now only meant as a workaround. Mozilla and RBC need to cooperate and work to get this fixed properly.

I will change the solution for now and point to my above reply to make it easier to find it since both of you confirmed that this works.

more options

johnb6 said

MrSensible said
I'm surprised RBC would care whether or not FF can be used on their website, since it's the only web browser that has demonstrated a problem. I doubt you'll get much help from them. If IE/Edge, Chrome, and the rest are working, they're not going to spend a lot of time trying to fix a problem with one browser that has historically experienced problems for a lot of reasons, most of them self inflicted. No, this one belongs to Mozilla/FF, and they're the ones who need to fix it, if they want to maintain whatever "browser marketshare" they have. I don't know why they keep on tinkering with the base product. I've used it since the late 1990s, when Netscape was on the wane, and it was always a solid, but flexible and forgiving piece of software, until they decided to try to take on the other mainstream browsers, a few years back. That's when the desire to "one up" the competition started to drag them down, with "enhancements" that often created more issues than they solved. Remember the roll out of "Quantum"? That went well, didn't it? I bet that drove more people away, than the coronavirus in China. There's a couple of old (I/T) sayings that go "if it ain't broke, don't fix it" or for those with more vivid imaginations, "if you want it to stay up, stop playing with it". Mozilla apparently doesn't seem to care, either way. Anyway, I've got multiple browser redundancy on my machines, so when Mozilla makes yet another "oops" fixing something that isn't broken, I can easily get around it. Not because I want to, as I do usually prefer Firefox to the rest, but because after a 30+ year career in I/T and over 2 decades of experience in the world of internet browsers has taught me not to rely on just one piece of code. Ever.

Granted, today Firefox is only the 3rd most popular browser after Chrome and Safari, but crippling its access to the site and not attempting to fix it is a really dumb move. Get your act together, RBC and Mozilla. If Mozilla doesn't want Firefox to doe and get relegated to oblivion, they had better work on this. Today most sites work hard to be accessibly by all browsers. Fix this or get out of the business.

Dear John, 2nd, but dropping fast, after this one. The fix was offered by a FF support person. As I said earlier, they owned this from the start. RBC had no responsibility for it, whatsoever. I would suggest "you get out of the business yourself", or at least SFTU. Have a nice day, John.

more options

cor-el said

If the RBC site worked before and the problem only started recently then this fix looks like being caused by some changes RBC made. Flipping the pref is for now only meant as a workaround. Mozilla and RBC need to cooperate and work to get this fixed properly. I will change the solution for now and point to my above reply to make it easier to find it since both of you confirmed that this works.

Then why is a base code change on your side fixing it?

more options

cor-el said

If the RBC site worked before and the problem only started recently then this fix looks like being caused by some changes RBC made. Flipping the pref is for now only meant as a workaround. Mozilla and RBC need to cooperate and work to get this fixed properly. I will change the solution for now and point to my above reply to make it easier to find it since both of you confirmed that this works.

I don't think that RBC is required to make changes to their proprietary code that makes your (the Firefox) browser work on their website. If their customers can access their info with another secure browser, then they have done their due diligence. The onus is on Mozilla/Firefox developers to make sure their browser code complies with RBC's security and data management environment. not the other way around. RBC is federally regulated, Mozilla is not.

Modified by MrSensible

more options

My wife has Firefox & her CIBC account; no problems signing in or conducting banking. I have Firefox & my RBC account. I can not sign in or conduct any banking.

As I told RBC customer service today; if this problem in not fixed by the time I get back from holidays - all my investments and banking will be transferred to CIBC. Maybe they can afford to lose a 30 year customer; the ball is in their court...

Modified by gord.stamp

more options

cor-el said

Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Did not work for me. :(

Windows 7, Firefox 72.0.2

more options

did not change anything for me, just added some new error messages.

more options

@ johnb6 and bud7 :

Would you consider filing a bug report ?

See my post on page 2 of this thread ....

more options

MrSensible said

cor-el said
Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el.

Worked for me, too. However, I regard this as a temporary workaround until a proper resolution is found. Keeping an open mind about whether RBC or Mozilla is really responsible.

more options

Cor-el's solution to set config to false worked for me as well.

more options

The posted solution/bypass mostly works for me too. I still have the odd issue with this flow, which is a normal flow for me: - sign on to RBC Online Banking - from inside that dialog, switch to RBC Dominion Securities - switch back to Banking as needed

3 times now the Dominion Securities dialog has failed after working in there a while. I don't see any diagnostics, it just announces that it's signing me off. This is usually inside the DS dialog, not when switching back to Banking.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6