Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problems signing in to RBC with latest Firefox release Jan 2020

  • 115 replies
  • 20 have this problem
  • 7607 views
  • Last reply by MrSensible

more options

Unable to properly sign in to RBC (Royal Bank of Canada) online banking since install of the latest Firefox release 72.0.1. Windows 10, up to date. Other sites work. Chrome can access RBC ok. No error messages, it just doesn't get through the bank security protocol for some reason via Firefox. Sits with a blank screen.

Chosen solution

Try to set this pref to false on the about:config page.

  • network.http.spdy.enabled.http2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 8

All Replies (20)

more options

The solution given works for Firefox 72.02 running on Ubuntu 19.10. This was not operating system specific.

Try to set this pref to false on the about:config page.

   network.http.spdy.enabled.http2 = false
more options

Yes, already posted previously.

more options

So I tried the "network.http.spdy.enabled.http2" fix twice and it did not make any difference. Being an old help desk guy I decided to take my own advice and shut everything down completely, power off, computer totally turned off dead then reboot from power on. Once Windows was up I loaded Firefox, made sure no other applications were loaded. Once Firefox loaded went in and set "network.http.spdy.enabled.http2" to false and the RBC site is now accessible, have logged in and out twice with no blank pages or other errors. Hopefully this will continue to work.

more options

Wondering how you would re-set twice? It's either false or enabled.

more options

Confirmed that the posted solution works for me as well. Windows 10, FF 72.0.2 (64-bit). But I spent a couple of hours trying to dig into what I am really changing with this preference, and did not get a clear understanding.

There is one long discussion about potential privacy implications of disabling http2 here: https://github.com/ghacksuserjs/ghacks-user.js/issues/107 which leaves me more in the dark than before I read it :(

more options

You are changing the Firefox config file, not Windows. I use Win 7 64 bit and will never change to 10. Eventually I'll be using Linux. If 'false' allows the web page to display you have to be convinced that Mozilla made a mistake in their code. I had to do this once before 2-3 years ago but cannot recall what the problem was. If the website is https it is secure regardless of Firefox settings.

more options

Disabling HTTP2 is hopefully only necessary temporarily and you can possibly create a separate profile where you disable this feature (i.e. set the pref to false) and use that profile to access RBC and leave HTTP2 enabled in the current profile.

This RBC issue seems to be caused by Firefox closing the connection to the RBC server for some reason due to a server response from the RBC server and because the connection is closed you get an empty window (data is not send by the server).

Modified by cor-el

more options

You are worried about thin air !!

more options

This happens to me when on a multi-ID Win 10 system. It does not happen on a single-ID Win 10 system. On the multi-ID system, one of the FFs always shows "FF is being updated in another instance" in the Help screen. But all 3 instances are the same, and are at the system level, not unique to the ID. I have not yet tried the Config file change.

more options

cor-el said

Disabling HTTP2 is hopefully only necessary temporarily and you can possibly create a separate profile where you disable this feature (i.e. set the pref to false) and use that profile to access RBC and leave HTTP2 enabled in the current profile.

Thanks cor-el, that is a good suggestion so that I can manage this RBC access problem without disabling http2 for all my browsing. Hopefully we will get a more robust solution in the not-too-distant future.

more options

Robcanuck said

You are worried about thin air !!

Thanks for your viewpoint Robcanuck.

There may be others who have concerns that you do not share which is why I included the link in my earlier reply. I realize that I am changing browser preference, not Windows, and I also realize that https helps with the security of the banking access. However security and privacy are two different (sometimes related) concepts.

The link I provided discusses the fact that there are some ways that your privacy (not security) can be compromised by being forced to use http1 instead of http2 (unrelated to https). In this scenario, certain aspects of http2 which can hamper various widespread tracking techniques (despite the tracking and other settings attempting to block tracking) are defeated forcing http1 according to the proposed solution.

However, also discussed are some possible *security* (not privacy) issues with http2 that may mean you wish to disable http2 for that reason. So there is no clear answer as to whether or not the proposed solution is appropriate for everyone. It depends on what you are more concerned about; security or privacy (or neither).

more options

rhennick said

For me this RBC problem only started a couple of days ago. FF 72.0.2, on Win7 32-bit. I don't have any problems with other banking sites, and I do not wish to switch browsers. Tools\Web Developer\Inspector says that this is the problem: "Loading failed for the <script> with source “https://nexus.ensighten.com/rbc/olb/serverComponent.php? ... " " [remainder trimmed] But of course this may not be the *only* problem, just the first one that FF hits. And I find it hard to believe that any credible IT department would still be recommending its clients to use Internet Explorer as an alternative browser...

Same here, problem w/ FF 72.0.2 (but 64-bit) on Win10 64-bit version 1909 OS build 18363.592

Similar observation (when ...spdy.enabled.http2 = true & blank page) via Inspector ... in HTML page, error with "_script/ftagent_ICA23STVbjqr_70002000171032.js:239:34" in the page's header, error with “https://nexus.ensighten.com/rbc/olb/Bootstrap.js:16:430"

Toggling to 'false' allows me to login to RBC online banking.

Interestingly enough, if I toggle "....http2" back to 'true' (after logging in), I can continue to navigate within the RBC online banking (in and out of account details; messages, customer service, ...). It does, however require 2 clicks (sometimes 3!) on each link to successfully navigate to the page requested. I can, similarly, navigate to, and through, Direct Investing Web site. I cannot, however, navigate back to the RBC online banking pages (either using the DI 'HOME' or 'BANKING' links. I get a blank blank page (unless I toggle the setting to 'false' again, before trying to return to the RBC online banking page. I can get the RBC banking page once I've toggle the setting to 'false'). I can return to the RBC DI page by using the back button.

more options

MrSensible said

MrSensible said
cor-el said
Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el. Have tried it several times, and I'm golden. I can navigate through the RBC website as normal. Signin and PVQ works as it used to. Looks good now. Thanks for the fix. If you need any other real world testing, reply to this thread. I will try to help.

M. p.s. Win10, laptop, all MS updates in place, FF 72.0.2.

This config change works for me too. Toggle 'true' = blank RBC login page (w/ Bootstrap.js script error as mentioned above). Set 'false' = back to banking online with RBC.

Win 10 Home; Version 1909; OS build 18363.592

more options

I am QUITE puzzled! Reading about this 2016 github "Determine if SPDY support should be disabled within Firefox?" issue!!!

Even more so when I read ...

ghost's comment "Google developed the protocol ... which is now being deprecated and support has been removed from Chrome version 51."

and

dillbyrne's comment "... since chrome has decided to remove it we are probably better off disabling it ..."!

Perhaps I am taking this out of context and I am not up to date on related matters. But, if Chrome does not use spdy AND Google has deprecated it, WHY would FF use any of it?

more options

gmax said

I am QUITE puzzled! Reading about this 2016 github "Determine if SPDY support should be disabled within Firefox?" issue!!!

Hi gmax, I was puzzled too. It is a twisty trail, but my conclusion after several hours of digging was that SPDY is a fully-deprecated predecessor to HTTP2. All the major browsers, I believe including Firefox, have now dropped support of SPDY in favor of HTTP2. I believe the appearance of "spdy" in the Firefox about:config network preferences is legacy from when SPDY was available but HTTP2 was not yet stable/deployed. So all those preferences that used to relate to SPDY now relate to HTTP2, but the legacy terminology (confusingly) remains ...

more options

Beady said

gmax said
I am QUITE puzzled! Reading about this 2016 github "Determine if SPDY support should be disabled within Firefox?" issue!!!

Hi gmax, I was puzzled too. It is a twisty trail, but my conclusion after several hours of digging was that SPDY is a fully-deprecated predecessor to HTTP2. All the major browsers, I believe including Firefox, have now dropped support of SPDY in favor of HTTP2. I believe the appearance of "spdy" in the Firefox about:config network preferences is legacy from when SPDY was available but HTTP2 was not yet stable/deployed. So all those preferences that used to relate to SPDY now relate to HTTP2, but the legacy terminology (confusingly) remains ...

@Beady - Thank you for taking the time to elaborate.

more options

cor-el said

Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

I followed the directions provided by you and it seems to work ok now...BUT....I have a big question nagging at me: how does this change impact other aspects of Firefox and/or security of my RBC account, and other sites I visit...including another bank?????

If the solution was so 'simple', why did Firefox put in 'true', rather than 'false'.  Seems odd to me.  Bear in mind that I'm old (73) and trying really hard to keep up with the young bucks.  Thank you.
more options

Worked like a charm. Thanks, whoever you are.

more options

Updated to the new 73 and I still can't login to my RBC account. I'm not going to start playing with config files and possible risk my session being compromised. this is something Firefox needs to fix as I can login with no problems using the Chrome Browser.

more options

MrSensible said

cor-el said
Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el.

cor-el said

Try to set this pref to false on the about:config page.
  • network.http.spdy.enabled.http2 = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This worked for me. Thanks cor-el Said

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6