X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 71.0 won't run Java on some websites.

Posted

On sites like forums.lutron.com many of the features just don't work. When I hover over "like this post," a box pops up that says "javascript://" I am unable to click the text. This applies to many of the features like reply, reply with quote, thanks for this post, et. al.

I have checked and Javascript is enabled (about:config). I have tried IE and it does not have this issue. When I hover over and item in IE the pop up box says something like "http://forums.lutron.com/newreply.php?do=newreply&p=32524" and it does work. 

I'm not sure if this is related but when I click "+ Reply to Thread)" any formatting I do is lost. Carriage returns are stripped so everything is just one big run-on sentence. This occurs in both FF & IE.

Lutron suggested I switch to Chrome. That is NOT going to happen!

I have the following addons Adblock - I've tried disabling, text in the popup box changes but still does not work. Facebook Container - site is not in a container tab. Firefox multi-account containers - site is not in a container tab Ghostery - just added today. Google analytics opt out - disabled, no affect. Pop up blocker ultimate - disabled, no affect. Replace Rotate and zoom image.

On sites like forums.lutron.com many of the features just don't work. When I hover over "like this post," a box pops up that says "javascript://" I am unable to click the text. This applies to many of the features like reply, reply with quote, thanks for this post, et. al. I have checked and Javascript is enabled (about:config). I have tried IE and it does not have this issue. When I hover over and item in IE the pop up box says something like "http://forums.lutron.com/newreply.php?do=newreply&p=32524" and it does work. I'm not sure if this is related but when I click "+ Reply to Thread)" any formatting I do is lost. Carriage returns are stripped so everything is just one big run-on sentence. This occurs in both FF & IE. Lutron suggested I switch to Chrome. That is NOT going to happen! I have the following addons Adblock - I've tried disabling, text in the popup box changes but still does not work. Facebook Container - site is not in a container tab. Firefox multi-account containers - site is not in a container tab Ghostery - just added today. Google analytics opt out - disabled, no affect. Pop up blocker ultimate - disabled, no affect. Replace Rotate and zoom image.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

I have the following addons Adblock - I've tried disabling, text in the popup box changes but still does not work. Facebook Container - site is not in a container tab. Firefox multi-account containers - site is not in a container tab Ghostery - just added today. Google analytics opt out - disabled, no affect. Pop up blocker ultimate - disabled, no affect. Replace Rotate and zoom image.

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Wesley Branton
  • Top 10 Contributor
709 solutions 5606 answers

Try running Firefox in Safe Mode to see if the issue happens there too. You have some content blocking extensions installed on Firefox, so it's possible that one of them is blocking scripts on certain websites.

[[Troubleshoot Firefox issues using Safe Mode|Try running Firefox in Safe Mode]] to see if the issue happens there too. You have some content blocking extensions installed on Firefox, so it's possible that one of them is blocking scripts on certain websites.
Was this helpful to you?
Quote

Question owner

I restarted Firefox with addons disabled. I verified they were disabled in tools, addons. When FF started it asked me if I wanted safe mode. I clicked yes.

Exact same results.

I restarted Firefox with addons disabled. I verified they were disabled in tools, addons. When FF started it asked me if I wanted safe mode. I clicked yes. Exact same results.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160809 answers

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. *click the shield icon for more details and possibly disable the protection You can check in the Web Console what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop
Was this helpful to you?
Quote

Question owner

I turned off the tracking protection but it is still blocking some items. The shield has a diagonal line through it and when I hover over it the box says "Enhanced Tracking Protection is OFF for this site."

Some of the items being blocked are from "ajax.googleapis.com." I suspect I really don't want them anyway. Some of the items are from lutron.com and they are items I do want (like post, reply, etc.).

I don't understand why it is still blocking items when it is supposedly turned off.

It's not just the forums.lutron.com site. There are others I have similar issues with to varying degrees.

I turned off the tracking protection but it is still blocking some items. The shield has a diagonal line through it and when I hover over it the box says "Enhanced Tracking Protection is OFF for this site." Some of the items being blocked are from "ajax.googleapis.com." I suspect I really don't want them anyway. Some of the items are from lutron.com and they are items I do want (like post, reply, etc.). I don't understand why it is still blocking items when it is supposedly turned off. It's not just the forums.lutron.com site. There are others I have similar issues with to varying degrees.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160809 answers

If it is blocked by Firefox for some reason then you should find related messages in the Web Console.

If that isn't the case then check for other causes like content blocking extensions.

If it is blocked by Firefox for some reason then you should find related messages in the Web Console. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console If that isn't the case then check for other causes like content blocking extensions. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
Wesley Branton
  • Top 10 Contributor
709 solutions 5606 answers

Is this problem caused by Mixed content blocking in Firefox?

If Firefox loads a secure website (HTTPS), but the page includes insecure content (HTTP scripts, images, etc) then that insecure content will be blocked.

You can try disabling Mixed content blocking by pressing the padlock icon on the Firefox address bar when you visit the website. From there, there should be an arrow button. If you click that, you should then be able to select a Disable protection for now button.

As a side note, the AJAX Google content is likely a code library that the website uses. This is usually added to the page if the developer decided to use jQuery instead of pure Javascript.

If that doesn't help, the only other thing I can think of off the top of my head is your security software. Certain firewall or antivirus programs can inadvertently block some content. Most notably, in the Avast and AVG programs there is a HTTPS filtering option that sometimes slows or blocks content.

Hope this helps.

Is this problem caused by [[Mixed content blocking in Firefox]]? If Firefox loads a secure website (HTTPS), but the page includes insecure content (HTTP scripts, images, etc) then that insecure content will be blocked. You can try disabling Mixed content blocking by pressing the padlock icon on the Firefox address bar when you visit the website. From there, there should be an arrow button. If you click that, you should then be able to select a '''Disable protection for now''' button. <blockquote>As a side note, the AJAX Google content is likely a code library that the website uses. This is usually added to the page if the developer decided to use jQuery instead of pure Javascript.</blockquote> If that doesn't help, the only other thing I can think of off the top of my head is your security software. Certain firewall or antivirus programs can inadvertently block some content. Most notably, in the Avast and AVG programs there is a HTTPS filtering option that sometimes slows or blocks content. Hope this helps.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.