X
Tap here to go to the mobile version of the site.

Support Forum

Firefox turns off my Twitter push notifcations. How do I get them to stay on?

Posted

After a while Firefox turns off my Twitter push notifications. Twitter says they're still on but they aren't. If I turn them off & on again, it repeats. I don't have this problem with Chrome but I don't want to use Chrome.

After a while Firefox turns off my Twitter push notifications. Twitter says they're still on but they aren't. If I turn them off & on again, it repeats. I don't have this problem with Chrome but I don't want to use Chrome.

Chosen solution

rashbaugh3 said

After a while Firefox turns off my Twitter push notifications. Twitter says they're still on but they aren't. If I turn them off & on again, it repeats. I don't have this problem with Chrome but I don't want to use Chrome.

Adding https://twitter.com to Windows 7 Background Apps did the trick. Push notifcations stay on while I'm logged in. If I log out and come back I have to access the Twitter "turn on notifications" page - which is still turned on by the way, but just accessing the page turns them back on again.

Thank you very much McCoy

You too cor-el, even though I didn't get to your solution. ;)

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

McCoy
  • Top 10 Contributor
532 solutions 5034 answers

Hello rashbaugh3,

Would you try this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Send Notifications". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Also see : https://support.mozilla.org/en-US/kb/push-notifications-firefox

And : https://help.twitter.com/en/managing-your-account/enabling-web-and-browser-notifications

Any luck ?

Hello rashbaugh3, Would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Send Notifications". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Also see : https://support.mozilla.org/en-US/kb/push-notifications-firefox And : https://help.twitter.com/en/managing-your-account/enabling-web-and-browser-notifications Any luck ?
Was this helpful to you? 0
Quote

Question owner

I had checked and made sure it was set to "allow" many times in past. It still is. I've wondered if there isn't an about:config setting in Firefox that only allows so many push notifications then cuts them off.

Appreciate the suggestion though.

I had checked and made sure it was set to "allow" many times in past. It still is. I've wondered if there isn't an about:config setting in Firefox that only allows so many push notifications then cuts them off. Appreciate the suggestion though.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
532 solutions 5034 answers

Would you give this a try please :

Type in the address bar about:config (promise to be careful, if asked, but you probably already know the drill)

Type in the search bar dom.push.enabled

and set its value to true

Then type in the search bar dom.webnotifications.enabled

and set its value to true

Then close and restart Firefox.

Note : setting these values to "true" will affect all sites, though ....

(you can always reset the values)

Would you give this a try please : Type in the address bar '''about:config''' (promise to be careful, if asked, but you probably already know the drill) Type in the search bar '''dom.push.enabled''' and set its value to '''true''' Then type in the search bar '''dom.webnotifications.enabled''' and set its value to '''true''' Then close and restart Firefox. Note : setting these values to "true" will affect ''all'' sites, though .... (you can always reset the values)
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
532 solutions 5034 answers

And as I wasn't quite sure that changing the values of those prefs might do the trick, I kept searching, and found this :

https://superuser.com/questions/1298796/why-firefox-forgets-my-web-notifications-for-twitter

Would that last post be what you need ?

And as I wasn't quite sure that changing the values of those prefs might do the trick, I kept searching, and found this : https://superuser.com/questions/1298796/why-firefox-forgets-my-web-notifications-for-twitter Would that last post be what you need ?
Was this helpful to you?
Quote

Question owner

They have been both set to true. Thanks again though. Your next suggestion might do the trick.

They have been both set to true. Thanks again though. Your next suggestion might do the trick.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
532 solutions 5034 answers

Helpful Reply

rashbaugh3 said

Your next suggestion might do the trick.

Will you let us know if it does ? Cause if doesn't, we will just have to keep looking for a solution .....

''rashbaugh3 [[#answer-1250627|said]]'' <blockquote> Your next suggestion might do the trick. </blockquote> Will you let us know if it does ? Cause if doesn't, we will just have to keep looking for a solution .....
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17465 solutions 157833 answers

You can check the Browser Console for service worker related messages.

You can see all registered service workers on these pages: about:serviceworkers and about:debugging#workers You can check WebSockets via this page: about:networking#websockets See also serviceworker.txt in the profile folder.


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can check the Browser Console for service worker related messages. *https://developer.mozilla.org/en-US/Tools/Browser_Console You can see all registered service workers on these pages: <b>about:serviceworkers</b> and <b>about:debugging#workers</b> You can check WebSockets via this page: <b>about:networking#websockets</b> See also serviceworker.txt in the profile folder. ---- Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Chosen Solution

rashbaugh3 said

After a while Firefox turns off my Twitter push notifications. Twitter says they're still on but they aren't. If I turn them off & on again, it repeats. I don't have this problem with Chrome but I don't want to use Chrome.

Adding https://twitter.com to Windows 7 Background Apps did the trick. Push notifcations stay on while I'm logged in. If I log out and come back I have to access the Twitter "turn on notifications" page - which is still turned on by the way, but just accessing the page turns them back on again.

Thank you very much McCoy

You too cor-el, even though I didn't get to your solution. ;)

''rashbaugh3 [[#question-1268386|said]]'' <blockquote> After a while Firefox turns off my Twitter push notifications. Twitter says they're still on but they aren't. If I turn them off & on again, it repeats. I don't have this problem with Chrome but I don't want to use Chrome. </blockquote> Adding https://twitter.com to Windows 7 Background Apps did the trick. Push notifcations stay on while I'm logged in. If I log out and come back I have to access the Twitter "turn on notifications" page - which is still turned on by the way, but just accessing the page turns them back on again. Thank you very much McCoy You too cor-el, even though I didn't get to your solution. ;)
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
532 solutions 5034 answers

rashbaugh3 said

Thank you very much McCoy

My pleasure - I'm just sorry I didn't suggest to check Windows background app first.

''rashbaugh3 [[#answer-1250755|said]]'' <blockquote> Thank you very much McCoy </blockquote> My pleasure - I'm just sorry I didn't suggest to check Windows background app first.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.