X
Tap here to go to the mobile version of the site.

Support Forum

On my website www.goodthinking.space the character "y" is missing everywhere on the site and the character "x" is shown as ". It is not so on Safari or Chromr C

Posted

I was working on the site yesterday and everything was ok. There was a Firefox update on my computer last night and today the problem above is on every page. There is no problem on either Safari or Chrome, I have reloaded the modem, and I have had the domain name supplier check their server and it is looking fine on there too. They have not had the latest update on Firefox. Please help. Kate Hudson

I was working on the site yesterday and everything was ok. There was a Firefox update on my computer last night and today the problem above is on every page. There is no problem on either Safari or Chrome, I have reloaded the modem, and I have had the domain name supplier check their server and it is looking fine on there too. They have not had the latest update on Firefox. Please help. Kate Hudson
Attached screenshots

Chosen solution

Firefox has a problem with the comment at the start of gttest.css that causes the body block to get ignored:

  • http://www.goodthinking.space/gttest.css
  • <!--Version 13 20 may 19-->

Should be:

  • /* Version 13 20 may 19 */

There as quite a few CSS showing in the Web Console and a lot are about unsupported moz prefixed properties (moz-opacity is really ancient as all Firefox version have supported opacity).

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 69.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:69.0) Gecko/20100101 Firefox/69.0
  • Support URL: https://support.mozilla.org/1/firefox/69.0/Darwin/en-US/

Extensions

  • Amazon.co.uk 1.1 (amazon@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Firefox DevTools ADB Extension 0.0.5 (adb@mozilla.org)
  • Google 1.0 (google@search.mozilla.org)
  • Twitter 1.0 (twitter@search.mozilla.org)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)
  • Firebug 2.0.19 (firebug@software.joehewitt.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0863
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVendor:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blacklisted', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'CMSOutputProfile': u'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', u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 1
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shading_language_include GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_disjoint_timer_query EXT_float_blend EXT_frag_depth EXT_shader_texture_lod EXT_sRGB EXT_texture_compression_rgtc EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine
  • webgl1Version: 3.3 NVIDIA-10.0.35 310.90.10.05b12
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4248 solutions 59438 answers

Please provide a public link (no password) that we can check out. No Personal Information Please !


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Please provide a public link (no password) that we can check out. '''No Personal Information Please ! ''' Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4248 solutions 59438 answers

In a Private message, McCoy said

Re :   https://support.mozilla.org/en-US/questions/1268248
I did some searching   -   "Helvetica"  font might be the culprit
(if the site is using it on her side).
See :
https://www.reddit.com/r/chrome/comments/asp5si/letters_x_y_z_dont_appear_on_some_sites_chrome/
In a Private message, [/en-US/user/McCoy-thereal McCoy] said <blockquote> Re : &nbsp; https://support.mozilla.org/en-US/questions/1268248<BR> I did some searching &nbsp; - &nbsp; "Helvetica"&nbsp; font might be the culprit <BR>(if the site is using it on her side).<BR> See :<BR> https://www.reddit.com/r/chrome/comments/asp5si/letters_x_y_z_dont_appear_on_some_sites_chrome/ </blockquote>
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

Hi Kate, it looks okay for me.

Your page doesn't specify a font for the body, so Firefox uses whatever the default "Proportional" font is in your settings. You could check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button.

Near the top there is a character set selector. Since your page is in English, make sure that is set to Latin.

Usually the Proportional font selector is set to Serif -- and therefore Firefox will fall back to using whatever font is selected in the Serif row. I'm attaching a composite screenshot showing how it looks on mine as an example.

Can you get the missing letters back by trying a different font such as Georgia or Palatino, or do they all fail in the same way?

Of course, as the page author, you also have the option to specify a font-family for the body if you want to have more control over how people see your page.

Hi Kate, it looks okay for me. Your page doesn't specify a font for the body, so Firefox uses whatever the default "Proportional" font is in your settings. You could check that here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the Language and Appearance section, and click the '''Advanced...''' button. Near the top there is a character set selector. Since your page is in English, make sure that is set to '''Latin'''. Usually the Proportional font selector is set to '''Serif''' -- and therefore Firefox will fall back to using whatever font is selected in the Serif row. I'm attaching a composite screenshot showing how it looks on mine as an example. Can you get the missing letters back by trying a different font such as Georgia or Palatino, or do they all fail in the same way? Of course, as the page author, you also have the option to specify a font-family for the body if you want to have more control over how people see your page.
Was this helpful to you?
Quote

Question owner

Thanks for your suggestions but I think there is a problem in the latest Firefox update.

In the CSS I have stipulated Verdana, Arial, Sans Serif - so Helvetica not a problem. The site has been working perfectly for about two years on Firefox and all browsers until yesterday. Never had a problem with it. Suddenly it is only Firefox where there is a problem. I have been receiving updates automatically and the new one says Firefox Quantum 69.0 (64 bit) which arrived overnight.

The previous day there was no problem when I was checking it, then yesterday I went to upload some changes and the whole site looked whacky with all "y" and " errors. Overnight a new Firefox Quantum page landed on my computer talking about breaches of security and I think that has something to do with it.

Kate

Thanks for your suggestions but I think there is a problem in the latest Firefox update. In the CSS I have stipulated Verdana, Arial, Sans Serif - so Helvetica not a problem. The site has been working perfectly for about two years on Firefox and all browsers until yesterday. Never had a problem with it. Suddenly it is only Firefox where there is a problem. I have been receiving updates automatically and the new one says Firefox Quantum 69.0 (64 bit) which arrived overnight. The previous day there was no problem when I was checking it, then yesterday I went to upload some changes and the whole site looked whacky with all "y" and " errors. Overnight a new Firefox Quantum page landed on my computer talking about breaches of security and I think that has something to do with it. Kate
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

You currently zoomed out the page (80%). Does it make a difference whether you zoom in or zoom out more?

What font is Firefox using in your case to display this text?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You currently zoomed out the page (80%). Does it make a difference whether you zoom in or zoom out more? What font is Firefox using in your case to display this text? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts

Modified by cor-el

Was this helpful to you?
Quote

Question owner

Cor-el, Thanks for your suggestion. I changed the zoom and no difference. Here is a copy of the Firefox update history from my computer. Allowing for the time difference this happened exactly between the times I have just described. Gotta be this update.

I have checked the inspector as you suggest, and it does look as though something is overriding my suggested fonts.

I don't want to change any fonts because the whole thing was working perfectly checked out on Browsershots on loads of different browsers and it is only Firefox which is the problem!!!

Help Kate

Cor-el, Thanks for your suggestion. I changed the zoom and no difference. Here is a copy of the Firefox update history from my computer. Allowing for the time difference this happened exactly between the times I have just described. Gotta be this update. I have checked the inspector as you suggest, and it does look as though something is overriding my suggested fonts. I don't want to change any fonts because the whole thing was working perfectly checked out on Browsershots on loads of different browsers and it is only Firefox which is the problem!!! Help Kate
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

Hi Kate, I can confidently say from looking at your screenshot that the body text font is not Verdana, Arial, or any sans-serif font. Where did you specify that?

On my system, Firefox, Chrome, and Edge all use Times New Roman for the body text.

Hi Kate, I can confidently say from looking at your screenshot that the body text font is not Verdana, Arial, or any sans-serif font. Where did you specify that? On my system, Firefox, Chrome, and Edge all use Times New Roman for the body text.
Was this helpful to you?
Quote

Question owner

Wow. I haven't specified Times New Roman anywhere. Are you viewing it on Firefox Quantum 69.0 because it is only on that version of Firefox where the problem is. I checked on another computer with earlier Firefox version and no problem.

Attached: Copy of my spec for CSS body font.

This is mad!

Kate

Wow. I haven't specified Times New Roman anywhere. Are you viewing it on Firefox Quantum 69.0 because it is only on that version of Firefox where the problem is. I checked on another computer with earlier Firefox version and no problem. Attached: Copy of my spec for CSS body font. This is mad! Kate
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

Helpful Reply

Note that san-serif should be sans-serif

The padding values in the screenshot are also wrong with ';'

padding:		30px; 35px; 30px; 15px;
Note that <b>san-serif</b> should be <b>sans-serif</b> The padding values in the screenshot are also wrong with ';' padding: 30px; 35px; 30px; 15px;

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

Just a thought. I have a Flipbook embedded lower down on the page. Do you think that could be the problem?? I've not had any problem with it earlier.

Just a thought. I have a Flipbook embedded lower down on the page. Do you think that could be the problem?? I've not had any problem with it earlier.
Was this helpful to you?
Quote

Question owner

Have changed the san to sans on logotext but no difference. Thanks for that.

Have changed the san to sans on logotext but no difference. Thanks for that.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

Chosen Solution

Firefox has a problem with the comment at the start of gttest.css that causes the body block to get ignored:

  • http://www.goodthinking.space/gttest.css
  • <!--Version 13 20 may 19-->

Should be:

  • /* Version 13 20 may 19 */

There as quite a few CSS showing in the Web Console and a lot are about unsupported moz prefixed properties (moz-opacity is really ancient as all Firefox version have supported opacity).

Firefox has a problem with the comment at the start of gttest.css that causes the body block to get ignored: *http://www.goodthinking.space/gttest.css * &lt;!--Version 13 20 may 19--&gt; Should be: * /* Version 13 20 may 19 */ There as quite a few CSS showing in the Web Console and a lot are about unsupported moz prefixed properties (moz-opacity is really ancient as all Firefox version have supported opacity).
Was this helpful to you? 1
Quote

Question owner

Cor-el,

Ah. That's a bit embarrassing isn't it. Will change that and see if makes a difference.

Just done it and tested it on my computer - works perfectly!!! Looks like that is the problem. Man, you are a genius!!! I am just uploading the new gttest.css now.

Thanks so much for your help.

Cor-el, Ah. That's a bit embarrassing isn't it. Will change that and see if makes a difference. Just done it and tested it on my computer - works perfectly!!! Looks like that is the problem. Man, you are a genius!!! I am just uploading the new gttest.css now. Thanks so much for your help.
Was this helpful to you?
Quote

Question owner

Bingo!!! Works perfectly. That'll teach me to not be perfect. Thanks again hugely grateful for your time. cheers, Kate

Bingo!!! Works perfectly. That'll teach me to not be perfect. Thanks again hugely grateful for your time. cheers, Kate
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158000 answers

You're welcome.

That still sounds like a problem with your default font that was used instead of what you specified, so maybe check that font.

I noticed another error in gttest with a ';' : font size; 180%

#smphoto3 {                              
margin:		10px 10px 10px 30px;          /*NEW COMMENT sets margins for image in travel tips*/
float: 		left;
padding:    20px; 
font size;  180%                       /*NEW COMMENT sets float left for image in travel tips*/
}

Note there there are CSS test website.

You're welcome. That still sounds like a problem with your default font that was used instead of what you specified, so maybe check that font. I noticed another error in gttest with a ';' : font size; 180% <pre><nowiki>#smphoto3 { margin: 10px 10px 10px 30px; /*NEW COMMENT sets margins for image in travel tips*/ float: left; padding: 20px; font size; 180% /*NEW COMMENT sets float left for image in travel tips*/ }</nowiki></pre> Note there there are CSS test website. *https://jigsaw.w3.org/css-validator/ *https://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fwww.goodthinking.space%2Fgttest.css&profile=css3svg&usermedium=all&warning=1&vextwarning=&lang=en
Was this helpful to you? 1
Quote

Question owner

Cor-el, I was taught to religiously use validator - obviously I didn't follow that advice this time. Back to basics.

Thanks again, cheers, Kate

Cor-el, I was taught to religiously use validator - obviously I didn't follow that advice this time. Back to basics. Thanks again, cheers, Kate
Was this helpful to you?
Quote

Question owner

Oh dear. I'm not the only one hahaha.

Oh dear. I'm not the only one hahaha.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8704 solutions 71122 answers

Hi Kate, what if you change your default Serif font for the "Latin" character set from "Times" to "Times New Roman" on the Preferences page, then reload that TryIt page.

If using "Times New Roman" restores the missing letters, then Firefox is having a problem with the "Times" font, specifically. Then you might check the FontBook suggestion on the page FredMcD/McCoy linked to earlier in this thread.

(Earlier screenshot: https://user-media-prod-cdn.itsre-sum.../2019-09-07-10-24-38-17fa78.png)

Hi Kate, what if you change your default Serif font for the "Latin" character set from "Times" to "Times New Roman" on the Preferences page, then reload that TryIt page. If using "Times New Roman" restores the missing letters, then Firefox is having a problem with the "Times" font, specifically. Then you might check the FontBook suggestion on the page FredMcD/McCoy linked to earlier in this thread. (Earlier screenshot: [https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-07-10-24-38-17fa78.png])

Modified by jscher2000

Was this helpful to you? 1
Quote

Question owner

Hi Cor-el I sent a reply but somehow it got lost so resending. Changing to Times New Roman for the default serif font fixed the problem in the TryIt page. I checked how my website is displaying and that is ok too. So looks like all is good. Thanks for the screenshot will keep it for future reference.

Thank you so much - I learned a lot from talking to you. cheers, Kate

Hi Cor-el I sent a reply but somehow it got lost so resending. Changing to Times New Roman for the default serif font fixed the problem in the TryIt page. I checked how my website is displaying and that is ok too. So looks like all is good. Thanks for the screenshot will keep it for future reference. Thank you so much - I learned a lot from talking to you. cheers, Kate
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.