Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with online banking after update to version 68.0

  • 30 replies
  • 3 have this problem
  • 880 views
  • Last reply by cor-el

more options

Cannot send secure message to bank while logged in to my bank account. I get a title saying "undefined" and when I go to log off the two buttons for confirm or remain logged on have no text and the title "undefined" is there. However those buttons do actually work. I have logged on to banking using Microsoft Edge and everything worked just fine.

Chosen solution

Hi All, there is a patch rolling out later this month (I don't know the exact timing) for

http://rolb.santanderbank.com/

If you are seeing this problem on a different site, could you mention the host name so it can also get the patch?

By the way, the patch modifies how Firefox identifies itself to the site to trigger a more modern section of its old scripts. It inserts the word "like" and a space before the word Gecko.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) like Gecko/20100101 Firefox/68.0

Read this answer in context 👍 2

All Replies (20)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Hi Jeremy thanks for the reply. Followed your instructions but problem still remains. Attached screenshot, the words undefined should not exist eg. it should say print by print icon and the two round black dots should say yes/no for logoff. I'm going to uninstall/ reinstall Firefox.

more options

Have uninstalled/reinstalled twice used Revo uninstaller to remove registry entries. All to no avail problem still the same. I am obviously not doing a full uninstall because Firefox still remembers my settings. Also did a Firefox clean start refresh.

Modified by dekker

more options

I'm seeing exactly the same thing in Santander banking. No exit text displaying now too. If you click the black circle on the right you can exit

more options

I also see the same effect when looking at e-documents. Plus I cannot send a secure message. If I logon with Microsoft Edge all is good no probs.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks but Safe Mode made no difference. I also removed all traces of Firefox including deleting my profile in App Data.

Modified by dekker

more options

What locale or preferred language do you use?

  • Options/Preferences -> General -> Languages (second setting: language for websites)

Sometimes you might see this when a website wants to replace specific terms, but doesn't support your locale?

more options

My 1st and 2nd languages are english UK. I'm using Santander's UK site. I have been using Fox for years with online banking and never a problem until this latest update. A bit more info. I can view my accounts and perform all banking operations but it is the secure internal communications that fail. I cannot send or read replies with Fox I have to use MS Edge. Please help, I do not want to say goodby after so many years with Firefox. I have done everything I can find on the web, all to no avail. Does someone know how to report this issue to the hierarchy.

Modified by dekker

more options

Much as dekker says.

Clearing history of cookies etc. as suggested did not solve the problem.

Santander bank is aware - maybe they could advise Mozilla, or vice versa, to find a solution ?

Works fine with Google Chrome.

Modified by MAC

more options

Chosen Solution

Hi All, there is a patch rolling out later this month (I don't know the exact timing) for

http://rolb.santanderbank.com/

If you are seeing this problem on a different site, could you mention the host name so it can also get the patch?

By the way, the patch modifies how Firefox identifies itself to the site to trigger a more modern section of its old scripts. It inserts the word "like" and a space before the word Gecko.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) like Gecko/20100101 Firefox/68.0

more options

Excellent, thanks.

more options

Good news, thanks to all contributors.

more options

We are Santander UK - just logged on - problem persists.

https://www.santander.co.uk/personal/support/ways-to-bank/online-banking

Modified by MAC

more options

Hi MAC, what is the host name in the address bar on the problem page? This one looks normal to me:

https://www.santander.co.uk/personal/support/ways-to-bank/online-banking

When I click Log on, these pages look normal to me:

https://retail.santander.co.uk/LOGSUK_NS_ENS/BtoChannelDriver.ssobto?dse_operationName=LOGON&dse_processorState=initial&redirect=S

https://business.santander.co.uk/LGSBBI_NS_ENS/BtoChannelDriver.ssobto?dse_operationName=LGSBBI_LOGON&dse_processorState=initial&redirect=S

This one does not look normal. A bug was filed, but too late for this round of fixes:

https://corporate.santander.co.uk/LOGSCU_NS_ENS/BtoChannelDriver.bto?dse_operationName=OP_LOG_ON

The people creating the patch need the exact host name where you see the problem (the part I made italic in the above links).

more options

The retail link is the one that allows personal banking online access.

It's 22:30 here in Scotland, I'm off to bed !!!

Catch up later.

Thanks for all the good work.

more options

Good night, MAC!

Tomorrow, could you confirm the address on the first bad page? I don't see the problem on the login page (retail.santander.co.uk). Does it go bad after login still on that same server, or does the address change to a different server? Any other U.K. users, same question. Thanks.

more options

You can use a override to modify the user agent for a specific domain with a regexp replace like shown in the bug. You can create a new String pref via the right-click context menu on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Modified by cor-el

more options

No problem with login and using the website, apart from two aspects - the first problem is when you go to secure messages.

At log off there is also an issue as comes up "undefined" - although if you hit the right hand button (no advisory text) as previously it will log off.

Santander advise that they are working on a resolution.

more options

Same as MAC says, no problem @ login or viewing accounts moving money etc. Thank goodness there are other browsers available. I marked the problem as solved when I learned there was a patch on the way, not because the issue was solved

Modified by dekker

  1. 1
  2. 2