Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to view recent transactions on global.americanexpress.com

  • 4 replies
  • 1 has this problem
  • 23 views
  • Last reply by FredMcD

more options

After logging into https://global.americanexpress.com the site always says:

We're sorry, but your transactions are unavailable at this time. Please try again later. We apologize for any inconvenience.

This is not an issue with Chrome or Safari. No content blocking is enabled for this site. Is there some other setting that needs to be adjust to allow these transactions to show?

Chosen solution

Thanks, Fred!

It turns out that Firefox was working properly on one of my Macs and the working one didn't have Flash installed. Removed Flash from the other one and problem solved.

Read this answer in context 👍 0

All Replies (4)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.207

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Chosen Solution

Thanks, Fred!

It turns out that Firefox was working properly on one of my Macs and the working one didn't have Flash installed. Removed Flash from the other one and problem solved.

more options

That was very good work. Well done. Please flag your last post as Solved Problem as this could help others with the same problem.