X
Tap here to go to the mobile version of the site.

Support Forum

screenshot enabled … but does not 'capture' full page.

Posted

win-10: 1903 (64-bit) firefox: 67.0.4 (64-bit)

taking screenshot with firefox's included app … this is not a 3rd-party addon.

have tried in safe-mode (disabled addons) … browser-cache cleared … saved to clipboard and downloaded screenshot as image … results are the same. i have also tried 'refreshing' the webpage … and scrolling down to bottom of page before capturing screenshot … makes no difference. choosing "full page screenshot" does not capture the 'complete' page. firefox seems to attempt full page … and, if the page is not too long, the full page will be captured.

example: https://www.peterborgapps.com/smultron/ approximately 57-58% of complete page is captured … remainder is white space.

is there a setting that can be configured to increase the amount of data/image the screenshot will capture?

i am furnishing two screen-caps for reference purposes.

win-10: 1903 (64-bit) firefox: 67.0.4 (64-bit) taking screenshot with firefox's included app … this is not a 3rd-party addon. have tried in safe-mode (disabled addons) … browser-cache cleared … saved to clipboard and downloaded screenshot as image … results are the same. i have also tried 'refreshing' the webpage … and scrolling down to bottom of page before capturing screenshot … makes no difference. choosing "full page screenshot" does not capture the 'complete' page. firefox seems to attempt full page … and, if the page is not too long, the full page will be captured. example: https://www.peterborgapps.com/smultron/ approximately 57-58% of complete page is captured … remainder is white space. is there a setting that can be configured to increase the amount of data/image the screenshot will capture? i am furnishing two screen-caps for reference purposes.
Attached screenshots

Modified by gnarlyone

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

Helpful Reply

Hi gnarlyone, there is a maximum length after which the "full page" screenshot cuts off, but there shouldn't be a blank section before that maximum length is hit. Also, your example page isn't that long (or at least the full page screenshot works for me).

Does there seem to be any pattern to where it cuts off related to the length or type of content?

Full page screenshot tools generally create an HTML canvas to generate the image. Can you think of any settings you might have changed related to canvases?

Hi gnarlyone, there is a maximum length after which the "full page" screenshot cuts off, but there shouldn't be a blank section before that maximum length is hit. Also, your example page isn't that long (or at least the full page screenshot works for me). Does there seem to be any pattern to where it cuts off related to the length or type of content? Full page screenshot tools generally create an HTML canvas to generate the image. Can you think of any settings you might have changed related to canvases?
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156791 answers

Helpful Reply

There seems to be a size limit for full page screenshots, so a very very large page a full page screenshot won't work properly. This is a canvas limitation in Firefox that only can hold a limited data volume (the screenshot image is drawn on canvas and then saved as a png/jpg file).

There seems to be a size limit for full page screenshots, so a very very large page a full page screenshot won't work properly. This is a canvas limitation in Firefox that only can hold a limited data volume (the screenshot image is drawn on canvas and then saved as a png/jpg file). *https://www.google.com/search?sa=N&num=100&q=canvas.toDataURL%20maximum

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

cor-el said " This is a canvas limitation in Firefox that only can hold a limited data volume"
jscher2000 said " your example page isn't that long (or at least the full page screenshot works for me)."

cor-el thanks for your reply … you had not attempted to save the example page i provided … so i can only speculate your results were similar to jschr's result.

is this something that could be suggested to mozilla … such as "pls increase the canvas-size or amount of data to save" ?

jschr2000 i appreciate your in-depth involvement … thanks.

i been using their screenshot feature almost from the day they offered it. prior to using firefox's utility … i utilized a 2rd party addon called "screengrab" i think it was. similar to firefox … their addon would also "conk out" … after only a certain amount of data was harnessed. so, to answer your last question … the issue has been from inception of firefox's utility.

as to possible culprits … i employ four addons in my arsenal (disabled during the above test) … also retain a substantial history/bookmark portfolio … i do not engage any of firefox's 'sync' options.

i have tried strictly text-only as well as images as well as video (youtube) … same results … nothing bites me on the chin.

<blockquote>''cor-el [[#answer-1232863|said]]'' ''" This is a canvas limitation in Firefox that only can hold a limited data volume''" </blockquote> <blockquote>''jscher2000 [[#answer-1232862|said]]'' ''" your example page isn't that long (or at least the full page screenshot works for me)."''</blockquote> '''cor-el''' thanks for your reply … you had not attempted to save the example page i provided … so i can only speculate your results were similar to jschr's result. is this something that could be suggested to mozilla … such as ''"pls increase the canvas-size or amount of data to save"'' ? '''jschr2000''' i appreciate your in-depth involvement … thanks. i been using their screenshot feature almost from the day they offered it. prior to using firefox's utility … i utilized a 2rd party addon called '''"screengrab"''' i think it was. similar to firefox … their addon would also ''"conk out"'' … after only a certain amount of data was harnessed. so, to answer your last question … the issue has been from inception of firefox's utility. as to possible culprits … i employ four addons in my arsenal ''(disabled during the above test)'' … also retain a substantial history/bookmark portfolio … i do not engage any of firefox's 'sync' options. i have tried strictly text-only as well as images as well as video ''(youtube)'' … same results … nothing bites me on the chin.

Modified by gnarlyone

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156791 answers

With the page you posted I get the full screenshot without issues (blank pages). I'm on Linux, so things might be different on this platform (there are known issues on Windows with large DIV elements).

With the page you posted I get the full screenshot without issues (blank pages). I'm on Linux, so things might be different on this platform (there are known issues on Windows with large DIV elements). *https://www.peterborgapps.com/smultron/.

Modified by cor-el

Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156791 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 1
Quote

Question owner

cor-el said
"… or if hardware acceleration is causing the problem …"

cor-el … bingo! i'd like to thank you … indeed, hardware-acceleration was the culprit … guess mozilla's default value of "8" devoured too much memory. after disabling that feature entirely, and rebooting firefox … away she went! afterward, as a test, decided to enable h/a with value of "8" … and, sure enough, firefox's screenshot went right back to the old issue.

thanks for sticking with me … give my hearty regards to jschr2000 for his valuable insight … i now close this ticket … peace out.

''cor-el [[#answer-1232879|said]]''<blockquote>''"… or if <u>hardware acceleration</u> is causing the problem …"''</blockquote> '''cor-el''' … bingo! i'd like to thank you … indeed, hardware-acceleration was the culprit … guess mozilla's default value of "8" devoured too much memory. after disabling that feature entirely, and rebooting firefox … away she went! afterward, as a test, decided to enable h/a with value of "8" … and, sure enough, firefox's screenshot went right back to the old issue. thanks for sticking with me … give my hearty regards to '''jschr2000''' for his valuable insight … i now close this ticket … peace out.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

Hi gnarlyone, those actually are separate settings. What did you end up with that worked? Did you have to change both of the settings under Performance:

Default

[X] Use hardware acceleration when available

Content process limit: 8 (default)

Example Modification

[  ] Use hardware acceleration when available

Content process limit: 5

Hi gnarlyone, those actually are separate settings. What did you end up with that worked? Did you have to change both of the settings under Performance: ''Default'' [X] Use hardware acceleration when available Content process limit: 8 (default) ''Example Modification'' [&nbsp;&nbsp;] Use hardware acceleration when available Content process limit: 5
Was this helpful to you? 1
Quote

Question owner

jscher2000 said "Hi gnarlyone, those actually are separate settings. What did you end up with that worked?"

i chose to disable h/a entirely … have att'd screen-cap showing the modified settings.

and, while this method has worked for that particular page in question … the screenshot utility still balks at pages with lengthier content. cor-el mentioned there are known issues with regard to win-os 'div' elements … so, i may have hit a road-block or dead-end.

at any rate … i will continue playing around with settings and environmental factors … and will post if anything strikes a chord.

<blockquote>''jscher2000 [[#answer-1233139|said]]'' ''"Hi gnarlyone, those actually are separate settings. What did you end up with that worked?"''</blockquote> i chose to disable h/a entirely … have att'd screen-cap showing the modified settings. and, while this method has worked for that particular page in question … the screenshot utility still balks at pages with lengthier content. '''cor-el''' mentioned there are known issues with regard to win-os 'div' elements … so, i may have hit a road-block or dead-end. at any rate … i will continue playing around with settings and environmental factors … and will post if anything strikes a chord.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.