X
Tap here to go to the mobile version of the site.

Support Forum

Firefox suddenly disabled my Adobe Acrobat extension. How do I get that back???

Posted

I had an icon in the menu bar in the upper right corner that allowed me to convert web pages to Adobe PDF files. It's suddenly disappeared and I can't figure out how to get it back. Any suggestions are greatly appreciated. Thanks, nkyinla

I had an icon in the menu bar in the upper right corner that allowed me to convert web pages to Adobe PDF files. It's suddenly disappeared and I can't figure out how to get it back. Any suggestions are greatly appreciated. Thanks, nkyinla

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 1
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Helpful Reply

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

If you need an immediate workaround to get work done, I've read that setting your system clock back to before midnight GMT, then exiting and restarting Firefox, may resolve the issue. However, I don't know if that is true for third party external installs like Acrobat or only extensions from the Mozilla Add-ons site. If you try it, please let me know what happens.

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon. If you need an immediate workaround to get work done, I've read that setting your system clock back to before midnight GMT, then exiting and restarting Firefox, may resolve the issue. However, I don't know if that is true for third party external installs like Acrobat or only extensions from the Mozilla Add-ons site. If you try it, please let me know what happens.
Was this helpful to you? 1
Quote

Question owner

Thanks for your quick reply. It also disabled my Norton add-ons. I can't work without either one of these. Thanks for your suggestion. How do I set my system clock back to before midnight GMT? I am in the PDT time zone. I'm willing to try anything at this point!

Thanks for your quick reply. It also disabled my Norton add-ons. I can't work without either one of these. Thanks for your suggestion. How do I set my system clock back to before midnight GMT? I am in the PDT time zone. I'm willing to try anything at this point!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Hi nkyinla, perhaps it is simplest to change the date from May 3rd to May 2nd (24-hour rollback).

Hi nkyinla, perhaps it is simplest to change the date from May 3rd to May 2nd (24-hour rollback).
Was this helpful to you?
Quote
mozfellow 1 solutions 33 answers

jscher2000 said

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon. If you need an immediate workaround to get work done, I've read that setting your system clock back to before midnight GMT, then exiting and restarting Firefox, may resolve the issue. However, I don't know if that is true for third party external installs like Acrobat or only extensions from the Mozilla Add-ons site. If you try it, please let me know what happens.

It's really odd jscher2000. As I wrote in my post on this issue, I'm not seeing the problem in the same version of FF with the same addons I have installed on a Windows 10 PC. It's only the copy on my Windows 7 PC where I'm seeing the problem.

''jscher2000 [[#answer-1218014|said]]'' <blockquote> Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon. If you need an immediate workaround to get work done, I've read that setting your system clock back to before midnight GMT, then exiting and restarting Firefox, may resolve the issue. However, I don't know if that is true for third party external installs like Acrobat or only extensions from the Mozilla Add-ons site. If you try it, please let me know what happens. </blockquote> It's really odd jscher2000. As I wrote in my post on this issue, I'm not seeing the problem in the same version of FF with the same addons I have installed on a Windows 10 PC. It's only the copy on my Windows 7 PC where I'm seeing the problem.
Was this helpful to you?
Quote

Question owner

I tried changing the clock both ways, just rolling it back 24 hours and changing to pre-midnite UTC. Neither worked. I appreciate your suggestions, but this is a serious issue. I'm sure I can't be the only one affected by this. Does Mozilla have any idea when this will be corrected? Adobe and Norton are used by more than a couple of people.

I tried changing the clock both ways, just rolling it back 24 hours and changing to pre-midnite UTC. Neither worked. I appreciate your suggestions, but this is a serious issue. I'm sure I can't be the only one affected by this. Does Mozilla have ''any'' idea when this will be corrected? Adobe and Norton are used by more than a couple of people.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

nkyinla said

I'm sure I can't be the only one affected by this.

Many thousands of people are affected, many more each hour. Official updates are expected to be posted here when available:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

''nkyinla [[#answer-1218077|said]]'' <blockquote>I'm sure I can't be the only one affected by this. </blockquote> Many thousands of people are affected, many more each hour. Official updates are expected to be posted here when available: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047
Was this helpful to you?
Quote

Question owner

Thank you.

Thank you.
Was this helpful to you?
Quote
Chris Ilias
  • Moderator
353 solutions 1940 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Was this helpful to you? 1
Quote

Question owner

Thanks, Chris Ilias. I was following the forums last night. What a nightmare! I appreciate that the Mozilla folks worked so hard to get a fix in place quickly. Cheers.

Thanks, Chris Ilias. I was following the forums last night. What a nightmare! I appreciate that the Mozilla folks worked so hard to get a fix in place quickly. Cheers.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.