Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I Use the Save Page As menu option, it no longer saves the page properly.

  • 7 replies
  • 2 have this problem
  • 646 views
  • Last reply by icemandave

more options

I frequently save web pages to disk. The last 40 days or so, the page first fails to save. When I instruct Firefox to try again, the page doesn't display properly. What do I need to do to get this indispensable feature to work correctly?

Thanks, RMikeS

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (7)

more options

Hi RMikeS, which format do you usually choose, and does it make any difference to this problem? The options are:

  • Web page, complete -- this is the default, I think, and it should save the HTML of the page as rendered along with a folder of accompanying files; sometimes there are issues with "too long" file names in the folder
  • Web page, HTML only -- this saves the page code as originally received by Firefox, so it may not reflect the current data in the page
  • Text Files -- this only saves the visible text of the page, similar to if you used Select All (Ctrl+A) and pasted into Notepad or another editor that doesn't understand formatting or images
more options

I use Web page, complete. It worked fine until about a month and a half ago.

I've tried to find a setting I may have inadvertently changed in Firefox settings and am drawing a blank. I can't find any setting that should effect this.

I'm wondering if an update could be responsible. Is there a Firefox setting that may control cache size?

Let me know if you need anything else from me. Mike

more options

Is there any pattern to what is missing from the saved page?

I don't use this feature enough to have an instinct about the problem.

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

The problem, as I've pointed out in another thread, is that Firefox is trying to save the webpages in .htm, which is unusable, instead of .html, which is what Firefox uses to read the page as a complete webpage.

I've found that if I add the "l" to the end of the file extension to make it ".html" then save as "webpage complete", it will save it as a readable webpage. You most likely will also have to retry the download using the downloads pulldown menu at the top of the browser and pressing the circular arrow. (see pic)

This isn't a solution, merely a workaround that works for me. I hope it does for you as well.

I should note that saving webpages in Google Chrome still works as normal, so I think this is a problem with Firefox and not our computers, so I wouldn't muck about with any registry editing or suggested "fixes" to your computer if I were you.

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

This did it. It was uBlock Origin that was causing the problem. I don't know why it just started doing it, I've used uBlock for several years now.


icemandave said

The problem, as I've pointed out in another thread, is that Firefox is trying to save the webpages in .htm, which is unusable, instead of .html, which is what Firefox uses to read the page as a complete webpage.

Firefox IS SAVING as an .html file. Not sure why yours doesn't. It was uBlock Origin that was interfering with my page saves.

more options

I'm glad you found a solution. I disabled U-Block and reset Firefox, but it's still saving pages as .htm files, so I guess I'll have to stick with my workaround.