X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

Suddenly can't make PayPal payments on eBay using Firefox.

Posted

I have used Firefox for years and have paid many eBay purchases by PayPal. However from yesterday when I go to the eBay payment screen and check the PayPal box it ghosts out the 'Confirm and Pay' button. A little icon of a red circle with a diagonal line appears at the cursor. It works with no problem with Chrome and Edge. Its odd that it has only just started. I have cleared cache without succes.

Any advice would be appreciated.

I have used Firefox for years and have paid many eBay purchases by PayPal. However from yesterday when I go to the eBay payment screen and check the PayPal box it ghosts out the 'Confirm and Pay' button. A little icon of a red circle with a diagonal line appears at the cursor. It works with no problem with Chrome and Edge. Its odd that it has only just started. I have cleared cache without succes. Any advice would be appreciated.

Chosen solution

Hi, try: 3-bar menu > Options > Privacy & Security, then under Content Blocking, remove all blocks; also under Permissions, deselect any block on Pop-up windows.

Now reload the site. If that works, should you wish, you can make an exception for the site.

If you are using an ad-blocker try disabling it, or turn it off on that site, then reload the page. (3-bar menu > Add-ons > Extensions).

If you have other extensions, try disabling them, or hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Scribe 714 solutions 3428 answers

Chosen Solution

Hi, try: 3-bar menu > Options > Privacy & Security, then under Content Blocking, remove all blocks; also under Permissions, deselect any block on Pop-up windows.

Now reload the site. If that works, should you wish, you can make an exception for the site.

If you are using an ad-blocker try disabling it, or turn it off on that site, then reload the page. (3-bar menu > Add-ons > Extensions).

If you have other extensions, try disabling them, or hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Hi, try: 3-bar menu > Options > Privacy & Security, then under Content Blocking, remove all blocks; also under Permissions, deselect any block on Pop-up windows. Now reload the site. If that works, should you wish, you can make an exception for the site. If you are using an ad-blocker try disabling it, or turn it off on that site, then reload the page. (3-bar menu > Add-ons > Extensions). If you have other extensions, try disabling them, or hold down the Shift key when you start Firefox to start in Safe Mode. More - [[Troubleshoot Firefox issues using Safe Mode]]. ''If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!''
Was this helpful to you? 1
Quote

Question owner

I tried the advice in the first paragraph but that did not resolve it. Disabling the Ad Blocker did! Odd as it has been installed for yonks without any problem.

Thank you for your help.

Regards

I tried the advice in the first paragraph but that did not resolve it. Disabling the Ad Blocker did! Odd as it has been installed for yonks without any problem. Thank you for your help. Regards
Was this helpful to you?
Quote

Question owner

Odder still - when I re-enabled the Ad Blocker PayPal still worked. Must have been a gremlin in the works as all the settings are back as they were and it is now fine.

Odder still - when I re-enabled the Ad Blocker PayPal still worked. Must have been a gremlin in the works as all the settings are back as they were and it is now fine.
Was this helpful to you?
Quote
Diotallevi 0 solutions 1 answers

I'm having the same problem and nothing is working. The only thing that worked was to make my paypal purchase using Chrome. No problems there.

I'm having the same problem and nothing is working. The only thing that worked was to make my paypal purchase using Chrome. No problems there.
Was this helpful to you?
Quote

Question owner

You need to add www.paypal.com or whatever paypal site you use to the Exceptions under Block Pop-Ups in Privacy & Security.

Click the three little lines in the top right hand corner and select Options. On the left hand side click Privacy & Security. Scroll down to the Block Pop-Ups check box. Click the Exceptions button and type www.paypal.com or www.paypal.your country suffix

You need to add www.paypal.com or whatever paypal site you use to the Exceptions under Block Pop-Ups in Privacy & Security. Click the three little lines in the top right hand corner and select Options. On the left hand side click Privacy & Security. Scroll down to the Block Pop-Ups check box. Click the Exceptions button and type www.paypal.com or www.paypal.your country suffix
Was this helpful to you?
Quote
aiikimmell 0 solutions 3 answers

Once I disabled the Amazon Assistant for Firefox extension add on PayPal worked fine. Try disabling one extension at a time it could be as simple as that.

Once I disabled the Amazon Assistant for Firefox extension add on PayPal worked fine. Try disabling one extension at a time it could be as simple as that.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.