X
Tap here to go to the mobile version of the site.

Support Forum

I have used Firefox since 2004 and it worked well. Now it is very problematic and I use Chrome instead. What did you do to it that made it so buggy?

Posted

Problems: 1. Refuses to play Youtube videos - it immediately becomes unresponsive and crashes the browser. 2. Weird page refresh behavior: loads yesterday's page not today's page - actually it alternates between the two.

Problems: 1. Refuses to play Youtube videos - it immediately becomes unresponsive and crashes the browser. 2. Weird page refresh behavior: loads yesterday's page not today's page - actually it alternates between the two.

Chosen solution

AndrewHulme said

2. Weird page refresh behavior

This could be caused by several things. Let's try this first,

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4028 solutions 56339 answers

Helpful Reply

AndrewHulme said

1. Refuses to play Youtube videos

Youtube currently uses the HTML5 player.

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

''AndrewHulme [[#question-1244741|said]]'' <blockquote> 1. Refuses to play Youtube videos </blockquote> Youtube currently uses the HTML5 player. https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4028 solutions 56339 answers

Chosen Solution

AndrewHulme said

2. Weird page refresh behavior

This could be caused by several things. Let's try this first,

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History.

''AndrewHulme [[#question-1244741|said]]'' <blockquote> 2. Weird page refresh behavior </blockquote> This could be caused by several things. Let's try this first, Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on '''Cache''' and '''Form And Search History'''.
Was this helpful to you? 1
Quote

Question owner

FredMcD said

AndrewHulme said
1. Refuses to play Youtube videos

Youtube currently uses the HTML5 player.

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

Gotcha. Added an HTML5 add-on. Problem has gone away, Thanks. But ... Chrome just works with Youtube 'out of the box'; Firefox should too. Once again ... thank you.

Oh oh... Youtube is freezing again.

''FredMcD [[#answer-1183630|said]]'' <blockquote> ''AndrewHulme [[#question-1244741|said]]'' <blockquote> 1. Refuses to play Youtube videos </blockquote> Youtube currently uses the HTML5 player. https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues </blockquote> Gotcha. Added an HTML5 add-on. Problem has gone away, Thanks. But ... Chrome just works with Youtube 'out of the box'; Firefox should too. Once again ... thank you. Oh oh... Youtube is freezing again.

Modified by AndrewHulme

Was this helpful to you?
Quote

Question owner

FredMcD said

AndrewHulme said
2. Weird page refresh behavior

This could be caused by several things. Let's try this first,

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History.

Many thanks - that seems to have fixed the reload problem .

''FredMcD [[#answer-1183633|said]]'' <blockquote> ''AndrewHulme [[#question-1244741|said]]'' <blockquote> 2. Weird page refresh behavior </blockquote> This could be caused by several things. Let's try this first, Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on '''Cache''' and '''Form And Search History'''. </blockquote> Many thanks - that seems to have fixed the reload problem .
Was this helpful to you?
Quote
James
  • Top 25 Contributor
  • Moderator
1584 solutions 11104 answers

AndrewHulme said

Gotcha. Added an HTML5 add-on. Problem has gone away, Thanks. But ... Chrome just works with Youtube 'out of the box'; Firefox should too. Once again ... thank you.

There is no need to install Any HTML5 related Extensions from addons.mozilla.org in order to use HTML5 players for video, audio, games etc in Firefox like the HTML5 players used by Youtube, Twitch and many other sites.

See https://www.youtube.com/html5/ as all checkmarks should ideally be blue. If two or three are red then you may have a N or KN edition of Windows 10 and not have the Media Feature Pack installed.

https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Chrome kind of cheats by coming with its own codecs and not use the codecs on Windows OS.

''AndrewHulme [[#answer-1183649|said]]'' <blockquote>Gotcha. Added an HTML5 add-on. Problem has gone away, Thanks. But ... Chrome just works with Youtube 'out of the box'; Firefox should too. Once again ... thank you. </blockquote> There is no need to install Any HTML5 related Extensions from addons.mozilla.org in order to use HTML5 players for video, audio, games etc in Firefox like the HTML5 players used by Youtube, Twitch and many other sites. See https://www.youtube.com/html5/ as all checkmarks should ideally be blue. If two or three are red then you may have a N or KN edition of Windows 10 and not have the Media Feature Pack installed. https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows Chrome kind of cheats by coming with its own codecs and not use the codecs on Windows OS.
Was this helpful to you?
Quote

Question owner

First of all, thank you very much for responding to my question.

I read the page at https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows and can assure you that it provides *no* useful information to resolve my problem. I recommend that you review your online help articles and put yourself in the place of a typical would-be user; online help should actually help.

So... I removed the HTML5 add-on and opened the page at https://www.youtube.com/html5/. *All* of the boxes were checked, incl. HTML5 player. I also checked the registry and MediaFeaturePack is definitely installed. Removed all add ons and Youtube playback still freezes. I'm a self-employed software engineer (Java, C#, .NET, SQL Server, ODBC etc) so I hope that qualifies me as 'not a total dummy'. My point is that if I (a 14-year Firefox user) am struggling to get Firefox to work to my satisfaction how many other people are having similar problems?

First of all, thank you very much for responding to my question. I read the page at https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows and can assure you that it provides *no* useful information to resolve my problem. I recommend that you review your online help articles and put yourself in the place of a typical would-be user; online help should actually help. So... I removed the HTML5 add-on and opened the page at https://www.youtube.com/html5/. *All* of the boxes were checked, incl. HTML5 player. I also checked the registry and MediaFeaturePack is definitely installed. Removed all add ons and Youtube playback still freezes. I'm a self-employed software engineer (Java, C#, .NET, SQL Server, ODBC etc) so I hope that qualifies me as 'not a total dummy'. My point is that if I (a 14-year Firefox user) am struggling to get Firefox to work to my satisfaction how many other people are having similar problems?

Modified by AndrewHulme

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4028 solutions 56339 answers

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

Thanks for the excellent suggestion. Firefox started in Safe Mode plays Youtube videos to perfection. I then ruthlessly deleted any add-ons of dubious provenance and brought the remainder back online one-by-one. (Remainder = AdBlock Plus, Youtube Ad Blocker and Ummy Video downloader.)

Problem solved ! ... fingers crossed.

Once again, many thanks.

Thanks for the excellent suggestion. Firefox started in Safe Mode plays Youtube videos to perfection. I then ruthlessly deleted any add-ons of dubious provenance and brought the remainder back online one-by-one. (Remainder = AdBlock Plus, Youtube Ad Blocker and Ummy Video downloader.) Problem solved ! ... fingers crossed. Once again, many thanks.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4028 solutions 56339 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.