X
Tap here to go to the mobile version of the site.

Support Forum

Firefox does not display home page upon opening but the open previous page

Posted

Since the new Firefox V64.0, the homepage as set in settings, Options, Home, New tabs and pages does not work. My Homepage was always set to https://www.google.com/ but since the update Firefox always open the last page I was on, does not matter which page.

Since the new Firefox V64.0, the homepage as set in settings, Options, Home, New tabs and pages does not work. My Homepage was always set to https://www.google.com/ but since the update Firefox always open the last page I was on, does not matter which page.
Attached screenshots

Chosen solution

Hello greenleader,

Just to make sure : Would you please go the 3-bar menu => Options => General Under 'Startup' make sure that 'Restore previous session' is unchecked.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

FredMcD
  • Top 10 Contributor
4274 solutions 59946 answers

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf files.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' files. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox.

Question owner

If I rename the file, then Firefox does not start. If I remove the file, then Firefox dos not start.

If I rename the file, then Firefox does not start. If I remove the file, then Firefox dos not start.
FredMcD
  • Top 10 Contributor
4274 solutions 59946 answers

That is odd. Firefox should recreate new files.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


BTW, what is your homepage?

That is odd. Firefox should recreate new files. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? BTW, what is your homepage?
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

Chosen Solution

Hello greenleader,

Just to make sure : Would you please go the 3-bar menu => Options => General Under 'Startup' make sure that 'Restore previous session' is unchecked.

Hello greenleader, Just to make sure : Would you please go the 3-bar menu => Options => General Under 'Startup' make sure that 'Restore previous session' is '''un'''checked.

Question owner

Thank you very much, McCoy. That does the trick. Why on earth would a new installation overwrite previous settings. Regards

Thank you very much, McCoy. That does the trick. Why on earth would a new installation overwrite previous settings. Regards
FredMcD
  • Top 10 Contributor
4274 solutions 59946 answers

Helpful Reply

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.