X
Tap here to go to the mobile version of the site.

Support Forum

no images in google shopping

Posted

I have no images displaying in Google shopping. Also Target.com the images won't load. I updated Adobe & cleared cookies & cache.

I have no images displaying in Google shopping. Also Target.com the images won't load. I updated Adobe & cleared cookies & cache.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

FredMcD
  • Top 10 Contributor
4224 solutions 58935 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

Question owner

Content is not blocking. In safe mode the images show up.

Content is not blocking. In safe mode the images show up.
FredMcD
  • Top 10 Contributor
4224 solutions 58935 answers

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

I disabled all add ons & extensions. I disabled Hardware Acc. Still no images. I updated Adobe also.

I disabled all add ons & extensions. I disabled Hardware Acc. Still no images. I updated Adobe also.
McCoy
  • Top 10 Contributor
520 solutions 4891 answers

Hello kevinbore,

Would you try this please :

When you're on those sites (Google Shopping and Target.com), click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work  ?

Hello kevinbore, Would you try this please : When you're on those sites (Google Shopping and Target''.''com), click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Does that work ?

Question owner

It worked once. Then it went back. I keep unchecking, but when I go back the check is back. Also I noticed I am using a 32 bit so I installed the 64 bit version. Firefox still shows a 32 bit version though. Should I uninstall it completely?

It worked once. Then it went back. I keep unchecking, but when I go back the check is back. Also I noticed I am using a 32 bit so I installed the 64 bit version. Firefox still shows a 32 bit version though. Should I uninstall it completely?
McCoy
  • Top 10 Contributor
520 solutions 4891 answers

Would you go back to Page Info (when you're on those sites), and this time click on the Media tab - is "Block Images" unchecked  ?

Would you go back to Page Info (when you're on those sites), and this time click on the Media tab - is "Block Images" '''un'''checked ?

Question owner

The "Block Images" is uncheck.

The "Block Images" is uncheck.
McCoy
  • Top 10 Contributor
520 solutions 4891 answers

Probably a rhetorical question, but just to make sure : after you had unchecked "Use Default" and checked "Allow" under the Permissions tab : did you close and restart Firefox  ?

Probably a rhetorical question, but just to make sure : after you had unchecked "Use Default" and checked "Allow" under the Permissions tab : did you close and restart Firefox ?

Question owner

Yes. I am closing & restarting every time I make changes.

Yes. I am closing & restarting every time I make changes.
McCoy
  • Top 10 Contributor
520 solutions 4891 answers

Not giving up just yet ....

Would you go over this article please and see if maybe there is something that we have overlooked  ?

https://support.mozilla.org/en-US/kb/fix-problems-images-not-show

Not giving up just yet .... Would you go over this article please and see if maybe there is something that we have overlooked ? https://support.mozilla.org/en-US/kb/fix-problems-images-not-show

Question owner

I actually started troubleshooting this problem with that article. I just went through it again. I appreciate all your help & time. I am going to uninstall & start over.

I actually started troubleshooting this problem with that article. I just went through it again. I appreciate all your help & time. I am going to uninstall & start over.
WestEnd
  • Top 25 Contributor
60 solutions 5366 answers

kevinbore said

I actually started troubleshooting this problem with that article. I just went through it again. I appreciate all your help & time. I am going to uninstall & start over.

When you do this make sure your finding all firefox install and deleting all mozilla folder in the x86 Program files and also in the Program files. That way if there was something there that wasn't there should at least insure a clean install.

''kevinbore [[#answer-1176983|said]]'' <blockquote> I actually started troubleshooting this problem with that article. I just went through it again. I appreciate all your help & time. I am going to uninstall & start over. </blockquote> When you do this make sure your finding all firefox install and deleting all mozilla folder in the x86 Program files and also in the Program files. That way if there was something there that wasn't there should at least insure a clean install.

Question owner

I plan to remove all traces of Firefox. Thanks.

I plan to remove all traces of Firefox. Thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157309 answers

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.


Some standard things to try:

If images are missing then check that you do not block images from some domains.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions".

Check "Tools -> Page Info -> Media" for blocked images

  • select the first image and use the cursor Down key to scroll through the list
  • if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain

You can check this pref on the about:config page.

  • permissions.default.image (1)

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

See also:

Make sure you allow pages to choose their own colors. *Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working. ---- Some standard things to try: If images are missing then check that you do not block images from some domains. *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions". Check "Tools -> Page Info -> Media" for blocked images *select the first image and use the cursor Down key to scroll through the list *if an image in the list is grayed and "<i>Block Images from...</i>" has a checkmark then remove this checkmark to unblock images from this domain You can check this pref on the <b>about:config</b> page. *permissions.default.image (1) <hr> If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more detail and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems See also: *https://support.mozilla.org/en-US/kb/fix-problems-images-not-show *https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently
Pj 42 solutions 869 answers

kevinbore said

Content is not blocking. In safe mode the images show up.
  • What Extensions do you have?
  • I did notice a while back when I had Ad Block Plus, even though I had it Disabled, there was stuff still being blocked. Once I removed my Custom Filters, the blocked content reappeared.
  • Also, some stuff may not appear or a page may not work right if any Blocker is blocking any Google URL with Tags, Analytics, and APIS. Not always, but I after trying to find out why something wasn't working right, I finally found it by unblocking the above-mentioned.
  • I turned-OFF FF's Tracking and let one or more Track-Blocking Extensions do their thing, with optional controls.
  • To make sure any of my Shopping sites work, I always 'White-List' them. I do not run any Blocking Script/Extensions with these sites. I learned long ago my Shopping problems with some sites were due to the Blocking.


~Pj

''kevinbore [[#answer-1176840|said]]'' <blockquote> Content is not blocking. In safe mode the images show up. </blockquote> * What Extensions do you have? * I did notice a while back when I had Ad Block Plus, even though I had it Disabled, there was stuff still being blocked. Once I removed my Custom Filters, the blocked content reappeared. * Also, some stuff may not appear or a page may not work right if any Blocker is blocking any Google URL with '''Tags''', '''Analytics''', and '''APIS'''. Not always, but I after trying to find out why something wasn't working right, I finally found it by unblocking the above-mentioned. * I turned-OFF FF's Tracking and let one or more Track-Blocking Extensions do their thing, with optional controls. * To make sure any of my Shopping sites work, I always 'White-List' them. I do not run any Blocking Script/Extensions with these sites. I learned long ago my Shopping problems with some sites were due to the Blocking. ~Pj

Modified by Pj

cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157309 answers

Note that in case Firefox tracking protection is blocking content then you see this by a the shield icon on the location bar. If you use content blocking extensions then you never know what is blocked if you use several of these extensions then it might not be obvious that essential content is blocked. Firefox also shows more detail in the Web Console about what content is blocked, either mixed content or by Content Blocking.

Note that in case Firefox tracking protection is blocking content then you see this by a the shield icon on the location bar. If you use content blocking extensions then you never know what is blocked if you use several of these extensions then it might not be obvious that essential content is blocked. Firefox also shows more detail in the Web Console about what content is blocked, either mixed content or by Content Blocking.

Question owner

I have these extension Adblock plus Avast YouTube down loader I disabled adblock

I have these extension Adblock plus Avast YouTube down loader I disabled adblock
FredMcD
  • Top 10 Contributor
4224 solutions 58935 answers

And . . .

And . . .

Question owner

Still no images. I just removed all add ons. No change. I am noticing more sites that are not displaying images. I am going to another browser. I will miss Firefox, I can't keep spending all this time on it. Thanks everyone for their help.

Still no images. I just removed all add ons. No change. I am noticing more sites that are not displaying images. I am going to another browser. I will miss Firefox, I can't keep spending all this time on it. Thanks everyone for their help.