Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps changing UI language in certain cases

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I am a Polish person, but I am fluent in English and I reckon browsing web is better in English - most of the webpages I visit are in English anyway. I've downloaded the EN-GB Firefox installer - even though I had to download "EN-GB language pack" and enable it.

Sometimes, when Firefox crashes, the window with "do you want to send your report to Mozilla" is in Polish. When I start Firefox in safe mode, all of UI is in Polish.

How can I make Firefox permanently English? (And after that, if needed, download Polish Language Pack?)

All Replies (1)

more options

I think that the Firefox user interface is in the main language (i.e. the language version you downloaded without possible language packs) when you start Firefox in Safe Mode.

The crash reporter works with its own settings and probably uses the Windows default language, so if you have a Polish Windows version then you could get a Polish crash reporter window.

Do you mean that you still get a user interface in the wrong language when you start Firefox normally (i.e. not in Safe Mode)?

If you download an English Firefox version like en-US or en-GB then you should get always get the Firefox user interface in English. Note that you might have a 32-bit and 64-bit Firefox version installed in different languages.

  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

If you occasionally want to have a Polish user interface then you can install a Polish language pack and modify the related pref to use this language.

You can set intl.locale.requested to the language code of an installed language pack to select a language.