X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox autofilling the address bar with URLS I've never visited?

Posted

All of the sudden Firefox has started autofilling the address bar with URLS I've never visited.

For example. I regularly type "weather" in the address bar to do a quick google search for the local forecast. It used to be that I only needed to type "wea" and hit enter as it would autofill "weather".

Now, it autofills to something called "weasner.com" and then "weather-widget.apk.black", neither of which appear in my search history. Since the second one includes the word weather, I have to not only type the full word out but then erase the irrelevant part of the erroneous url.

Where did this come from? Is there some way to turn it off and restrict Firefox to only suggesting terms I have searched before?

All of the sudden Firefox has started autofilling the address bar with URLS I've never visited. For example. I regularly type "weather" in the address bar to do a quick google search for the local forecast. It used to be that I only needed to type "wea" and hit enter as it would autofill "weather". Now, it autofills to something called "weasner.com" and then "weather-widget.apk.black", neither of which appear in my search history. Since the second one includes the word weather, I have to not only type the full word out but then erase the irrelevant part of the erroneous url. Where did this come from? Is there some way to turn it off and restrict Firefox to only suggesting terms I have searched before?
Attached screenshots

Chosen solution

jscher2000,

I just noticed something. I don't know whether this is a recent development or somehow I managed to be oblivious to it previously, but a star now appears next to the offending URLs within the address bar drop-down menu as I'm typing (see attached). Which makes it obvious that these addresses are both being drawn from my bookmarks.

I was too cautious to visit them when they first propagated, not recalling what they were, but now I recognize them and I do recall bookmarking them in case they may be of use again in future.

The odd part is that I have not revisited them since they were initially bookmarked several years ago, and thus had not seen them since. So Firefox seems to have changed how it is propagating the address bar - not simply from frequently used search terms but from bookmarks, as well. Or perhaps I have inadvertently switched this feature on, somehow.

Anyway, that's what's going on. I still don't like it and would love to change the behavior back to frequently visited links only, but at least we know what's going on.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

sadolino 0 solutions 41 answers

Did you try to to delete the autofill cache ?

Did you try to to delete the autofill cache ?
Was this helpful to you?
Quote

Question owner

I tried to delete these specific urls from my Cookies and Site Data, but they did not exist.

I tried to delete these specific urls from my Cookies and Site Data, but they did not exist.
Was this helpful to you?
Quote
sadolino 0 solutions 41 answers

Hi,

try these links first of all:

Another thing to try, is:

Give in 'about:config' in the adress field and search for autocomplete. Post your settings in the forum, pls, to recognize if you have the default settings. (?)

When these wouldn't help try to go to the Windows Control Panel > Internet Options > Advanced (Settings) > there are AutoComplete settings,too. But so you can check if there is a malfunction of settings in Windows or a malware what is blocking some of these 'dictionary complete' settings. Check also the folder options under Windows Control Panel. There is also a registry method, don't forget to restart your machine after the registry change. Check this link, please:

The other point is there are differents in the definition of these names, 'autofill' is for autofilling forms and 'autocomplete' is to complete a word. For me there is no different because is always a 'textfield'. :)

Try to reset the firefox browser and test it again.

When all these settings positions don't work, make a backup of your mozilla profile folder, backup of the bookmarks and so on, uninstall the browser, restart, then shutdown the computer, stuck the power cord for 10min, start again and reinstall the firefox browser. Try it first, without to import the backup or bookmarks.

Scan your pc with the newest version of adaware-cleaner. Try also a reg-cleaner, to be sure your pc is clean of mal-files.

From the point it was working until you see that it didn't, did you install something new, drivers or apps ?


Please write back.

Greets

Hi, try these links first of all: *[https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar] *[https://support.mozilla.org/en-US/kb/firefox-doesnt-save-web-form-entries Firefox doesn't save web form entries] *[https://support.mozilla.org/en-US/kb/search-web-address-bar Search the web from the address bar] Another thing to try, is: Give in 'about:config' in the adress field and search for autocomplete. Post your settings in the forum, pls, to recognize if you have the default settings. (?) When these wouldn't help try to go to the Windows Control Panel > Internet Options > Advanced (Settings) > there are AutoComplete settings,too. But so you can check if there is a malfunction of settings in Windows or a malware what is blocking some of these 'dictionary complete' settings. Check also the folder options under Windows Control Panel. There is also a registry method, don't forget to restart your machine after the registry change. Check this link, please: *[https://troubleshooter.xyz/wiki/enable-or-disable-inline-autocomplete-in-windows-10 Autocomplete methods] The other point is there are differents in the definition of these names, 'autofill' is for autofilling forms and 'autocomplete' is to complete a word. For me there is no different because is always a 'textfield'. :) Try to reset the firefox browser and test it again. When all these settings positions don't work, make a backup of your mozilla profile folder, backup of the bookmarks and so on, uninstall the browser, restart, then shutdown the computer, stuck the power cord for 10min, start again and reinstall the firefox browser. Try it first, without to import the backup or bookmarks. Scan your pc with the newest version of adaware-cleaner. Try also a reg-cleaner, to be sure your pc is clean of mal-files. From the point it was working until you see that it didn't, did you install something new, drivers or apps ? Please write back. Greets

Modified by sadolino

Was this helpful to you?
Quote

Question owner

Hi sadolino,

I've attached a screenshot from my firefox about:config settings. As far as I can tell, the windows settings only apply to the microsoft browser, which I don't use.

I haven't installed anything, to my knowledge, to account for the sudden change in the autocomplete behavior, but it strikes me as similar to the autocomplete behavior I've long noticed in the Incognito browser, where it fills in URLS that I've never visited (see attached). I always figured this was because the incognito browser didn't have a history to draw from, and so supplements with businesses that probably paid Mozilla for the bump. I don't care too much there, but this behavior is much more obstructive in my regular browser.

Hi sadolino, I've attached a screenshot from my firefox about:config settings. As far as I can tell, the windows settings only apply to the microsoft browser, which I don't use. I haven't installed anything, to my knowledge, to account for the sudden change in the autocomplete behavior, but it strikes me as similar to the autocomplete behavior I've long noticed in the Incognito browser, where it fills in URLS that I've never visited (see attached). I always figured this was because the incognito browser didn't have a history to draw from, and so supplements with businesses that probably paid Mozilla for the bump. I don't care too much there, but this behavior is much more obstructive in my regular browser.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8194 solutions 67035 answers

Helpful Reply

Hi wynden, there is a small list of "top sites" that Firefox will suggest in the address bar if you don't have any history. These include, for example, Amazon, BBC, eBay and Facebook. However, I don't think "hotukdeals" would be on the list! Perhaps that opened in a pop-up window once and that's why Firefox has a record of it??

To remove a suggestion that could be linked to history, there is a special procedure you can try. There may be delay in the deletion of the data, but it gives the most complete result in the end.

(A) Open the Library window using either:

  • Show all History
  • Ctrl+Shift+h

(B) In the search box at the upper right, enter enough of the unwanted address to give you unique results. In other words, hotukdeal and not deal by itself.

(C) Right-click any matching history entry and choose Forget About This Site -- this is a particularly thorough/destructive type of cleaning that goes beyond just deleting a single visit to a site from your history.

Within a minute or two, Firefox should stop suggesting that site after it completes the purge in the background.

Any improvement?

Hi wynden, there is a small list of "top sites" that Firefox will suggest in the address bar if you don't have any history. These include, for example, Amazon, BBC, eBay and Facebook. However, I don't think "hotukdeals" would be on the list! Perhaps that opened in a pop-up window once and that's why Firefox has a record of it?? To remove a suggestion that could be linked to history, there is a special procedure you can try. There may be delay in the deletion of the data, but it gives the most complete result in the end. (A) Open the Library window using either: * Show all History * Ctrl+Shift+h (B) In the search box at the upper right, enter enough of the unwanted address to give you unique results. In other words, ''hotukdeal'' and not ''deal'' by itself. (C) Right-click any matching history entry and choose '''Forget About This Site''' -- this is a particularly thorough/destructive type of cleaning that goes beyond just deleting a single visit to a site from your history. Within a minute or two, Firefox should stop suggesting that site after it completes the purge in the background. Any improvement?
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8194 solutions 67035 answers

Helpful Reply

wynden said

I haven't installed anything, to my knowledge, to account for the sudden change in the autocomplete behavior

I think it's best to investigate extensions as a possible culprit for loading unexpected pages that then show up in suggestions.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

''wynden [[#answer-1176339|said]]'' <blockquote> I haven't installed anything, to my knowledge, to account for the sudden change in the autocomplete behavior </blockquote> I think it's best to investigate extensions as a possible culprit for loading unexpected pages that then show up in suggestions. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement?
Was this helpful to you? 1
Quote

Question owner

Thank you, jscher2000, once again. I did find the offending URLS in the history library, though they had not come up when I'd searched Cookies and Site data through settings. I was able to determine that these were sites I had visited years ago, so the only mystery is why Firefox suddenly started suggesting them as though they were frequently/recently accessed. (I never visited hotukdeals to my knowledge, so you may be right about a pop up.)

At any rate, I've told Firefox to forget them and they no longer appear in the History. Unfortunately they are still cropping up in autocomplete. Perhaps it takes longer for autocomplete to reflect the change than I expected.

Thank you, jscher2000, once again. I did find the offending URLS in the history library, though they had not come up when I'd searched Cookies and Site data through settings. I was able to determine that these were sites I had visited years ago, so the only mystery is why Firefox suddenly started suggesting them as though they were frequently/recently accessed. (I never visited hotukdeals to my knowledge, so you may be right about a pop up.) At any rate, I've told Firefox to forget them and they no longer appear in the History. Unfortunately they are still cropping up in autocomplete. Perhaps it takes longer for autocomplete to reflect the change than I expected.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8194 solutions 67035 answers

wynden said

I've told Firefox to forget them and they no longer appear in the History. Unfortunately they are still cropping up in autocomplete. Perhaps it takes longer for autocomplete to reflect the change than I expected.

It shouldn't take more than a couple of minutes. However, I haven't tested this in recent months, so maybe something has changed...


I tested in a new profile with very little history, and the effect of Forget About This Site on whether domains are suggested for in-URL-bar autofill was quick. However, in a large database with a lot of history, and perhaps especially one that was migrated from before Firefox Quantum, it might be different. I'll have to do some more testing.

''wynden [[#answer-1176357|said]]'' <blockquote> I've told Firefox to forget them and they no longer appear in the History. Unfortunately they are still cropping up in autocomplete. Perhaps it takes longer for autocomplete to reflect the change than I expected. </blockquote> It shouldn't take more than a couple of minutes. However, I haven't tested this in recent months, so maybe something has changed... ---- I tested in a new profile with very little history, and the effect of Forget About This Site on whether domains are suggested for in-URL-bar autofill was quick. However, in a large database with a lot of history, and perhaps especially one that was migrated from before Firefox Quantum, it might be different. I'll have to do some more testing.

Modified by jscher2000

Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16995 solutions 153453 answers

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry
You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page<br>in case errors are reported close and restart Firefox and retry
Was this helpful to you?
Quote

Question owner

jscher2000 said

It shouldn't take more than a couple of minutes. However, I haven't tested this in recent months, so maybe something has changed...

I tested in a new profile with very little history, and the effect of Forget About This Site on whether domains are suggested for in-URL-bar autofill was quick. However, in a large database with a lot of history, and perhaps especially one that was migrated from before Firefox Quantum, it might be different. I'll have to do some more testing.

It's very odd; I was sure that would work, too, because I thought I recalled doing something similar before (just couldn't recall which menu I'd had to delete it from). I've attached a screenshot - you can see that the search term no longer appears in the History, so I don't know where autofill is drawing it from. Perhaps you're right, and it has something to do with the migration to Quantum. Thanks for trying.

''jscher2000 [[#answer-1176358|said]]'' <blockquote> It shouldn't take more than a couple of minutes. However, I haven't tested this in recent months, so maybe something has changed... ---- I tested in a new profile with very little history, and the effect of Forget About This Site on whether domains are suggested for in-URL-bar autofill was quick. However, in a large database with a lot of history, and perhaps especially one that was migrated from before Firefox Quantum, it might be different. I'll have to do some more testing. </blockquote> It's very odd; I was sure that would work, too, because I thought I recalled doing something similar before (just couldn't recall which menu I'd had to delete it from). I've attached a screenshot - you can see that the search term no longer appears in the History, so I don't know where autofill is drawing it from. Perhaps you're right, and it has something to do with the migration to Quantum. Thanks for trying.
Was this helpful to you?
Quote

Chosen Solution

jscher2000,

I just noticed something. I don't know whether this is a recent development or somehow I managed to be oblivious to it previously, but a star now appears next to the offending URLs within the address bar drop-down menu as I'm typing (see attached). Which makes it obvious that these addresses are both being drawn from my bookmarks.

I was too cautious to visit them when they first propagated, not recalling what they were, but now I recognize them and I do recall bookmarking them in case they may be of use again in future.

The odd part is that I have not revisited them since they were initially bookmarked several years ago, and thus had not seen them since. So Firefox seems to have changed how it is propagating the address bar - not simply from frequently used search terms but from bookmarks, as well. Or perhaps I have inadvertently switched this feature on, somehow.

Anyway, that's what's going on. I still don't like it and would love to change the behavior back to frequently visited links only, but at least we know what's going on.

jscher2000, I just noticed something. I don't know whether this is a recent development or somehow I managed to be oblivious to it previously, but a star now appears next to the offending URLs within the address bar drop-down menu as I'm typing (see attached). Which makes it obvious that these addresses are both being drawn from my bookmarks. I was too cautious to visit them when they first propagated, not recalling what they were, but now I recognize them and I do recall bookmarking them in case they may be of use again in future. The odd part is that I have not revisited them since they were initially bookmarked several years ago, and thus had not seen them since. So Firefox seems to have changed how it is propagating the address bar - not simply from frequently used search terms but from bookmarks, as well. Or perhaps I have inadvertently switched this feature on, somehow. Anyway, that's what's going on. I still don't like it and would love to change the behavior back to frequently visited links only, but at least we know what's going on.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8194 solutions 67035 answers

Hi wynden, something did change. In Firefox 62.0, bookmarks STOPPED being used for autofill suggestions unless those addresses were also in history. In response to wails of protest, the algorithm was adjusted in the Firefox 62.0.2 minor update to consider bookmarks again (Release Notes). It's still different overall from how it worked in Firefox 61 and people remain dissatisfied in various ways. I only spent about a minute reading comments, and um, it's a little deep for me.

Hi wynden, something did change. In Firefox 62.0, bookmarks STOPPED being used for autofill suggestions unless those addresses were also in history. In response to wails of protest, the algorithm was adjusted in the Firefox 62.0.2 minor update to consider bookmarks again ([https://www.mozilla.org/firefox/62.0.2/releasenotes/ Release Notes]). It's still different overall from how it worked in Firefox 61 and people remain dissatisfied in various ways. I only spent about a minute reading comments, and um, it's a little deep for me.
Was this helpful to you? 1
Quote

Question owner

Thanks for verifying. I wonder if they couldn't make it an optional feature, in future. There must be some barrier to that if they haven't done so, already, because I can see both variations being more useful according to individual practices. At any rate, thanks again. At least we know what's going on, and I don't have to keep messing with settings.

Thanks for verifying. I wonder if they couldn't make it an optional feature, in future. There must be some barrier to that if they haven't done so, already, because I can see both variations being more useful according to individual practices. At any rate, thanks again. At least we know what's going on, and I don't have to keep messing with settings.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.