Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Text on the page won't show up — empty spaces instead

  • 3 replies
  • 1 has this problem
  • Last reply by cor-el

more options

Mozilla Portable. Mostly everything is fine with text on pages but Disqus comments have empty spaces instead of text. Also email subscription and push notification popups can have the same effect. Modal window but no text. I tried the tips found in this support forum (sandbox something value 2 or 1 or 0) — didn't help. Note: in screenshot text won't show but hyperlinked text (active URL) was shown correctly (hidden by black marker) If you can help somehow I would really appreciate it!

Attached screenshots

Modified by zveroboy

All Replies (3)

more options

UPD: I discovered that on the page the font Helvetica Neue is used for disqus comments. I am aware that I have such font on my PC and it doesn't support cyrillic letters. The text on the page IS cyrillic. If I turn off the "allow pages to use their own fonts" in Mozilla Settings I can see the text well on the given page.

So, I can solve the issue this way but then every website will have dull font style. So what to do?

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

What font do you currently use?

Can't you use another font that works with more (all) web pages like DejaVu?

Note the you can use @-moz-document domain(<domain>){*{font-famile: xxx !important;}} rules in userContent.css to force a specific font on this domain.