Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I restore the number of search results that used to appear at the top of my results?

  • 3 replies
  • 1 has this problem
  • 122 views
  • Last reply by McCoy

more options

The results page for a google query used to show the number of results at the very top of the page. It just disappeared and I can't find any way to restore it except to use a different browser. I prefer Firefox, but it just cut out the first essential tool for my research, so it's now useless. Please help!

Chosen solution

Hello bethmadeline,

Maybe the solution in this old thread will work for you as well.

The solution mentioned there is :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

Read this answer in context 👍 0

All Replies (3)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 31.0.0.122

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Chosen Solution

Hello bethmadeline,

Maybe the solution in this old thread will work for you as well.

The solution mentioned there is :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")