Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Home Page > Top Sites > Search Icon

more options

This is annoying. I want to go to the home pages as I always have. How do I get rid of the search icon on top of my top sites?

All Replies (9)

more options

this search icon.

more options
  1. Hover over the tile until the menu (three horizontal dots) appears.
  2. Click Dismiss.
more options

See also the Firefox Home settings in "Options/Preferences -> Home".


There are other things that need attention.

The System Details list shows that you have an outdated Flash plugin , current is 31.0.0.122 (31.0 r0).

  • Shockwave Flash 25.0 r0

You can find the installation path of a plugin on the about:plugins page.

You can download the latest NPAPI Flash plugin for Firefox on this page.

Make sure to remove checkmarks for including unwanted additional software.

more options

Oops .....

Modified by McCoy

more options

@TyDraniu, Dismiss removes the top site icon.

@cor-el, Preferences completely removes the top sites.

I don't want the top sites to be gone, so these solutions will not work. I'm only looking to have the magnifying glass that is on top of the icon to be removed. So when I click the top site I will be taken to that page. Like it was before this update. Right now clicking a top site pulls up a variety of links to choose from. I find having to look through these numerous links to be annoying.

Thank you.

more options

jpsdyb said

I'm only looking to have the magnifying glass that is on top of the icon to be removed.

Hello jpsdyb,

Did you notice my "Oops .... " post  ? What I deleted was : Does that magnifying glass appear on other tiles as well  ?

Maybe not such a dumb question after all - does that magnifying glass appear on other tiles, or just on Amazon (and other search engine tiles)  ?

more options

jpsdyb said

Right now clicking a top site pulls up a variety of links to choose from. I find having to look through these numerous links to be annoying.

Maybe you could try this : Hover over the tile till the three horizontal dots show - click on them and then on 'Edit'.

Then change the URL to one that leads to the page of your choice.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

This is a new feature that gives you a quick way to search amazon. If you click the icon, it will add "@amazon " to the address bar. If you then type a search term and hit enter, you'll go to the amazon search result page for that term.

To get the old version back, dismiss the new one (like TyDraniu explained) and then edit another site. Change the name to Amazon and the URL to https://amazon.com. Then it will work like it did before.