Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox displays ’s “BENEFACTOR”

more options

Firefox displays characters that are not correctly translated

   NYC mansion of Oleg Deripaska, Manafort’s “BENEFACTOR” has been frozen alongside all of his U.S. assets, according to the NY Post.
   Hmmmm.
   ⁦@dcpoll⁩  https://t.co/XqwwdzC6wm
   — (((DuneMyThang™))) (@Kris_Sacrebleu) October 8, 2018

Chosen solution

The Inspector shows that the affected content is part of a link and the page uses the downloaded proxima-nova font.

So this might actually be a font issue as it takes some time to download and apply this font.


You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Read this answer in context 👍 1

All Replies (13)

more options

This is usually an encoding issue if you see the individual combining Unicode characters instead of the real Unicode character. Make sure that Unicode UTF-8 encoding is selected.

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

That did it.. Takes a few seconds to clear those characters and display the desired data, but it works. Thanks for the help

more options

You're welcome.

What worked? Is that about the encoding or about clearing cache and cookies?

more options

cor-el said

You're welcome. What worked? Is that about the encoding or about clearing cache and cookies?

Starting in safe mode. Does NOT work unless in safe mode. I cleared cache, cookies, disabled all extensions and plugins, works in safe mode, not in normal mode.

more options

That is weird.

In Firefox Safe mode these changes are effective:

  • hardware acceleration is disabled (Options/Preferences -> General -> Performance)
  • all extensions are disabled (about:addons)
  • default theme is used (no lightweight theme)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
  • plugins are not affected
  • preferences are not affected

What extensions do you have? You may have to uninstall all extensions in case some components are cached.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

rnielson@cox.net said

cor-el said
You're welcome. What worked? Is that about the encoding or about clearing cache and cookies?

Starting in safe mode. Does NOT work unless in safe mode. I cleared cache, cookies, disabled all extensions and plugins, works in safe mode, not in normal mode.

Surprising to me, I also had a problem in the website (https://www.dailykos.com/stories/2018/10/8/1802830/-Oleg-Deripaska-has-US-holdings-seized-what-hath-Manafort-wrought?utm_campaign=trending) creating Facebook posts. In regular mode, it just doesn't work. In safe mode, the Facebook post is created!

more options

I think browser is set as requested to be as close to safe mode as I can make it. One thing I did change was hardware acceleration changed to disabled .

Extensions are:

BitDefender Wallet Facebook Container Honey Roboform Password Manager UBlock Origin

All are disabled. I always browse in private mode, if that makes a difference.

more options

Another thing I should mention. When the web page first displays, for an instant, the 1st paragraph has some of the unwanted characters, and then this is rapidly replaced with a picture of Putin and Deripaska. Then there are some shaded inset paragraphs where these characters appear, but not the websites they refer to.

This would appear in the gray shaded area:

       NYC mansion of Oleg Deripaska, Manafort’s “BENEFACTOR” has been frozen alongside all of his U.S. assets, according to the NY Post.
       Hmmmm.
       ⁦@dcpoll⁩  https://t.co/XqwwdzC6wm
       — (((DuneMyThang™))) (@Kris_Sacrebleu) October 8, 2018
   Washington has frozen Deripaska’s US-based assets, including massive mansions in Manhattan and Washington, DC. But the feds are also negotiating with him to give up some of his European-based operations to keep them running free of sanctions, Treasury officials say.
   Deripaska’s US assets include a mansion at 11 E. 64th St. The uber-posh residence is just down the street from fellow Ukrainian-born oligarch Len Blavatnik’s mansion, which he bought for a record $90 million earlier this year.
   But although the US government has frozen Deripaska’s US assets, including his property, Deripaska has arranged to have the children and ex-wife of his business partner, the oligarch Roman Abramovich, live within its secure walls, The Post has learned.
   nypost.com/...
more options

rnielson@cox.net said

I always browse in private mode, if that makes a difference.

Does it make any difference if you switch off "Tracking Protection" for the page using the shield icon toward the left end of the address bar? See: What happened to Tracking Protection?.

more options

No, does not make a difference with tracking protection set to never.

more options

Perhaps the easiest solution is to reset Firefox back to its default configuration. Then I can test addon's, customizations, one by one until I find the problem.

How do I do that?

more options

Chosen Solution

The Inspector shows that the affected content is part of a link and the page uses the downloaded proxima-nova font.

So this might actually be a font issue as it takes some time to download and apply this font.


You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

more options

After letting the browser sit for a while (TV break) the correct information did display. And the link to facebook works, too.

Thanks!