X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla default dictionary doesn't change permanently

Posted

Hello, I am from Hellas (Greece) and I have installed an English-Greek dictionary, these two languages are 100% non conflicting since we have different alphabet thus the dictionary automatically spell checks both languages at once.

I used to have this dictionary default and it worked perfectly until a recent update keeps changing the spelling dictionary to the default, which is the local language -> just Greek.

If I change the spelling dictionary it will work until I restart mozilla (or sometimes until I restart the pc). This is kinda irritating at worst, not a big issue, but having to change my selected dictionary every time is ridiculous.

See the attached image to understand what Mozilla does by default.

~~~~~~~~~~~~~

The solution is given below but I'll write it here:

1) Go to about:config (hit I accept the risk there)

2) Right click on a blank area

3) Select: New->String

4) Name that new string as: spellchecker.dictionary

5) Set the value of it the name of the spell checker, in my case it is: English & Greek

6) You are done!

To see the name of the string you need, simply install a dictionary you want, go to a page that you can write something (lets say facebook) and right click, select "spell checking" and then scroll to see the dictionary options you have, the name of your dictionary is the one you see in that little drop down menu like in the image I provided.

Hello, I am from Hellas (Greece) and I have installed an English-Greek dictionary, these two languages are 100% non conflicting since we have different alphabet thus the dictionary automatically spell checks both languages at once. I used to have this dictionary default and it worked perfectly until a recent update keeps changing the spelling dictionary to the default, which is the local language -> just Greek. If I change the spelling dictionary it will work until I restart mozilla (or sometimes until I restart the pc). This is kinda irritating at worst, not a big issue, but having to change my selected dictionary every time is ridiculous. See the attached image to understand what Mozilla does by default. ~~~~~~~~~~~~~ The solution is given below but I'll write it here: 1) Go to about:config (hit I accept the risk there) 2) Right click on a blank area 3) Select: New->String 4) Name that new string as: spellchecker.dictionary 5) Set the value of it the name of the spell checker, in my case it is: English & Greek 6) You are done! To see the name of the string you need, simply install a dictionary you want, go to a page that you can write something (lets say facebook) and right click, select "spell checking" and then scroll to see the dictionary options you have, the name of your dictionary is the one you see in that little drop down menu like in the image I provided.
Attached screenshots

Modified by AlexandrosArxaggelos

Chosen solution

The spellchecker.dictionary pref may not exist by default and in that case Firefox might choose a dictionary randomly. If you want to set a specific default dictionary then you will have to create a new Boolean pref with the name spellchecker.dictionary and set its value to the dictionary you want to use (Greek = el-GR).

Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.

  • if you see a warning message then you can confirm that you want to access the about:config page.
  • new preferences can be created via the right-click context menu: New -> String, Integer, Boolean
Name: spellchecker.dictionary
Value for Greek: el-GR 
Value for English: en-US

See also:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Question owner

Bump, this is an irritating thing

Bump, this is an irritating thing

Modified by AlexandrosArxaggelos

Shadow110 1072 solutions 14836 answers

Hi, SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

If issue is still there then please give this a try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

If the above program control files reinstall did not work then please try this : Profile : Make a new one and test ...:

If is your Profile :

Please let us know if this solved your issue or if need further assistance.

Hi, SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ? If issue is still there then please give this a try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ If the above program control files reinstall did not work then please try this : Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
17520 solutions 158427 answers

You can check this pref on the about:config page.

  • spellchecker.dictionary

You can consider to use the user.js file in the profile folder to initialize this pref on each Firefox start.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

See also:

You can check this pref on the <b>about:config</b> page. *spellchecker.dictionary You can consider to use the user.js file in the profile folder to initialize this pref on each Firefox start. *http://kb.mozillazine.org/user.js_file You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox See also: *https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

Pkshadow said

Hi, SAFE MODE In Firefox Safe mode these changes are effective:
  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
TEST''''is issue still there ? If issue is still there then please give this a try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer If the above program control files reinstall did not work then please try this : Profile : Make a new one and test ...: If is your Profile : Please let us know if this solved your issue or if need further assistance.

I am sorry you could re-read my question because what you wrote is irrelevant. You are telling me to enter safe mode, thus disable any spelling dictionary and see what then?

My problem is that Mozilla forces its own dictionary at every start instead of the one I installed and selected as default.

''Pkshadow [[#answer-1141704|said]]'' <blockquote> Hi, SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ? If issue is still there then please give this a try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ If the above program control files reinstall did not work then please try this : Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Please let us know if this solved your issue or if need further assistance. </blockquote> I am sorry you could re-read my question because what you wrote is irrelevant. You are telling me to enter safe mode, thus disable any spelling dictionary and see what then? My problem is that Mozilla forces its own dictionary at every start instead of the one I installed and selected as default.

Modified by AlexandrosArxaggelos

Question owner

cor-el said

You can check this pref on the about:config page.
  • spellchecker.dictionary
You can consider to use the user.js file in the profile folder to initialize this pref on each Firefox start. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. See also:

In my about:config, there are 4 entries with "spell" in them but I am not sure what I should change.

See attachment

''cor-el [[#answer-1141812|said]]'' <blockquote> You can check this pref on the <b>about:config</b> page. *spellchecker.dictionary You can consider to use the user.js file in the profile folder to initialize this pref on each Firefox start. *http://kb.mozillazine.org/user.js_file You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox See also: *https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save </blockquote> In my '''about:config''', there are 4 entries with "spell" in them but I am not sure what I should change. See attachment
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

AlexandrosArxaggelos said

In my about:config, there are 4 entries with "spell" in them but I am not sure what I should change.

Would this article help  ?

http://kb.mozillazine.org/Layout.spellcheckDefault

''AlexandrosArxaggelos [[#answer-1141864|said]]'' <blockquote> In my '''about:config''', there are 4 entries with "spell" in them but I am not sure what I should change. </blockquote> Would this article help ? http://kb.mozillazine.org/Layout.spellcheckDefault
cor-el
  • Top 10 Contributor
  • Moderator
17520 solutions 158427 answers

Helpful Reply

You can try to create a new string pref spellchecker.dictionary and set its value to the preferred language.

See also this comment:

You can try to create a new string pref <b>spellchecker.dictionary</b> and set its value to the preferred language. *http://kb.mozillazine.org/about:config See also this comment: *https://dxr.mozilla.org/mozilla-release/source/editor/spellchecker/EditorSpellCheck.cpp#817

Question owner

My reply might sound pissed, but this is not my intention. I am not going to code anything, nor try to create any weird rules etc, it just seems mozilla has an issue.

If I am going to have to code to get a simple dictionary to be set as default then this browser just failed.

Thanks everyone for their effort to help, but mozilla keeps getting less and less user friendly and I have little to no expectation they will ever start seeing their product before they release it.

My reply might sound pissed, but this is not my intention. I am not going to code anything, nor try to create any weird rules etc, it just seems mozilla has an issue. If I am going to have to code to get a simple dictionary to be set as default then this browser just failed. Thanks everyone for their effort to help, but mozilla keeps getting less and less user friendly and I have little to no expectation they will ever start seeing their product before they release it.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

You never mentioned trying the link that FredMcD gave you :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

You never mentioned trying the link that FredMcD gave you : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Question owner

McCoy said

You never mentioned trying the link that FredMcD gave you : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists.

''McCoy [[#answer-1142223|said]]'' <blockquote> You never mentioned trying the link that FredMcD gave you : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save </blockquote> I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists.

Modified by AlexandrosArxaggelos

McCoy
  • Top 10 Contributor
545 solutions 5139 answers

AlexandrosArxaggelos said

I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists.

Just to make sure : After you changed the value of that preference, did you then close and restart Firefox, in order for the change to take effect  ?

''AlexandrosArxaggelos [[#answer-1143692|said]]'' <blockquote> I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists. </blockquote> Just to make sure : After you changed the value of that preference, did you then close and restart Firefox, in order for the change to take effect ?
cor-el
  • Top 10 Contributor
  • Moderator
17520 solutions 158427 answers

Chosen Solution

The spellchecker.dictionary pref may not exist by default and in that case Firefox might choose a dictionary randomly. If you want to set a specific default dictionary then you will have to create a new Boolean pref with the name spellchecker.dictionary and set its value to the dictionary you want to use (Greek = el-GR).

Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.

  • if you see a warning message then you can confirm that you want to access the about:config page.
  • new preferences can be created via the right-click context menu: New -> String, Integer, Boolean
Name: spellchecker.dictionary
Value for Greek: el-GR 
Value for English: en-US

See also:

The <b>spellchecker.dictionary</b> pref may not exist by default and in that case Firefox might choose a dictionary randomly. If you want to set a specific default dictionary then you will have to create a new Boolean pref with the name spellchecker.dictionary and set its value to the dictionary you want to use (Greek = el-GR). Type <b>about:config</b> in the location (address) bar and press the <i>Enter</i> key to open the <i>about:config</i> page like you open a website by typing the URL in the location bar. *if you see a warning message then you can confirm that you want to access the about:config page. *new preferences can be created via the right-click context menu: New -> String, Integer, Boolean Name: spellchecker.dictionary Value for Greek: el-GR Value for English: en-US See also: *http://kb.mozillazine.org/about:config

Question owner

cor-el said

The spellchecker.dictionary pref may not exist by default and in that case Firefox might choose a dictionary randomly. If you want to set a specific default dictionary then you will have to create a new Boolean pref with the name spellchecker.dictionary and set its value to the dictionary you want to use (Greek = el-GR). Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.
  • if you see a warning message then you can confirm that you want to access the about:config page.
  • new preferences can be created via the right-click context menu: New -> String, Integer, Boolean
Name: spellchecker.dictionary Value for Greek: el-GR Value for English: en-US See also:

So do I choose string or integer or boolean? And I do not want two options for spell checking, I have ONE dictionary that has both English and Greek spell checking abilities at the same time and I want this to be the default. It worked for years this way and one day Mozilla decided to keep changing the default dictionary to the default language that Mozilla is installed on. I don't even have an option in what language to install Mozilla, it automatically changes according to my location, which I never asked for.

''cor-el [[#answer-1143784|said]]'' <blockquote> The <b>spellchecker.dictionary</b> pref may not exist by default and in that case Firefox might choose a dictionary randomly. If you want to set a specific default dictionary then you will have to create a new Boolean pref with the name spellchecker.dictionary and set its value to the dictionary you want to use (Greek = el-GR). Type <b>about:config</b> in the location (address) bar and press the <i>Enter</i> key to open the <i>about:config</i> page like you open a website by typing the URL in the location bar. *if you see a warning message then you can confirm that you want to access the about:config page. *new preferences can be created via the right-click context menu: New -> String, Integer, Boolean Name: spellchecker.dictionary Value for Greek: el-GR Value for English: en-US See also: *http://kb.mozillazine.org/about:config </blockquote> So do I choose string or integer or boolean? And I do not want two options for spell checking, I have ONE dictionary that has both English and Greek spell checking abilities at the same time and I want this to be the default. It worked for years this way and one day Mozilla decided to keep changing the default dictionary to the default language that Mozilla is installed on. I don't even have an option in what language to install Mozilla, it automatically changes according to my location, which I never asked for.

Modified by AlexandrosArxaggelos

Question owner

McCoy said

AlexandrosArxaggelos said
I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists.

Just to make sure : After you changed the value of that preference, did you then close and restart Firefox, in order for the change to take effect  ?

It still changes to the default after a restart. I disabled the spell checker from mozilla hoping that it would stop forcing its own spell checker, but it also disabled the spell checking dictionary I installed.

So this wouldn't work either. I'll have to live with changing the language every time, this is such a solo incident, I doubt many people around the planet use double dictionary addons to have this problem, hence mozilla will think their product's decisions are correct.

I really hate chrome and I do not want to go there.

''McCoy [[#answer-1143696|said]]'' <blockquote> ''AlexandrosArxaggelos [[#answer-1143692|said]]'' <blockquote> I did, it doesn't solve the problem that the default dictionary keeps changing back to the default. These 0, 1 or 2 options are irrelevant to my problem. By default it was in 1 and I changed it to 2 (0 means disable it) and the problem still persists. </blockquote> Just to make sure : After you changed the value of that preference, did you then close and restart Firefox, in order for the change to take effect ? </blockquote> It still changes to the default after a restart. I disabled the spell checker from mozilla hoping that it would stop forcing its own spell checker, but it also disabled the spell checking dictionary I installed. So this wouldn't work either. I'll have to live with changing the language every time, this is such a solo incident, I doubt many people around the planet use double dictionary addons to have this problem, hence mozilla will think their product's decisions are correct. I really hate chrome and I do not want to go there.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Stab in the dark :

Would you uninstall the dictionary and then reinstall it  ?

(but you may already have tried .... )

Stab in the dark : Would you uninstall the dictionary and then reinstall it ? (but you may already have tried .... )
purple 0 solutions 3 answers

I was just about ready to open a new thread as I had the same issue and have been looking for days for a solution. All threads I could find were quite old and offered no fix.

Even though I found the about:config / spellchecker.dictionary solution, the string was not there and I had no clue I could add one. I am using this dictionary: https://addons.mozilla.org/en-US/firefox/addon/greek-english-spell-dictionary/ And to fix the problem I used the solution suggested by cor-el. I created a new string named spellchecker.dictionary and saved the value el-GR-en-US and problem solved. I just hope it won't come back later.

Thanks cor-el.

I was just about ready to open a new thread as I had the same issue and have been looking for days for a solution. All threads I could find were quite old and offered no fix. Even though I found the '''about:config / spellchecker.dictionary''' solution, the string was not there and I had no clue I could add one. I am using this dictionary: https://addons.mozilla.org/en-US/firefox/addon/greek-english-spell-dictionary/ And to fix the problem I used the solution suggested by cor-el. I created a new string named spellchecker.dictionary and saved the value el-GR-en-US and problem solved. I just hope it won't come back later. Thanks cor-el.

Question owner

McCoy said

Stab in the dark : Would you uninstall the dictionary and then reinstall it  ? (but you may already have tried .... )

Yes I did it and it didn't solve it

purple said

I was just about ready to open a new thread as I had the same issue and have been looking for days for a solution. All threads I could find were quite old and offered no fix. Even though I found the about:config / spellchecker.dictionary solution, the string was not there and I had no clue I could add one. I am using this dictionary: https://addons.mozilla.org/en-US/firefox/addon/greek-english-spell-dictionary/ And to fix the problem I used the solution suggested by cor-el. I created a new string named spellchecker.dictionary and saved the value el-GR-en-US and problem solved. I just hope it won't come back later. Thanks cor-el.

I use a similar by Papadakos. It worked like a charm all these years, but Mozilla decided to fix things that didn't need to be fixed.

Somebody in mozilla developing team woke up one day and decided to add code that will turn the default dictionary to the original by Mozilla no matter your own preference. that guy needs to be fired.

''McCoy [[#answer-1143882|said]]'' <blockquote> Stab in the dark : Would you uninstall the dictionary and then reinstall it ? (but you may already have tried .... ) </blockquote> Yes I did it and it didn't solve it ''purple [[#answer-1144251|said]]'' <blockquote> I was just about ready to open a new thread as I had the same issue and have been looking for days for a solution. All threads I could find were quite old and offered no fix. Even though I found the '''about:config / spellchecker.dictionary''' solution, the string was not there and I had no clue I could add one. I am using this dictionary: https://addons.mozilla.org/en-US/firefox/addon/greek-english-spell-dictionary/ And to fix the problem I used the solution suggested by cor-el. I created a new string named spellchecker.dictionary and saved the value el-GR-en-US and problem solved. I just hope it won't come back later. Thanks cor-el. </blockquote> I use a similar by Papadakos. It worked like a charm all these years, but Mozilla decided to fix things that didn't need to be fixed. Somebody in mozilla developing team woke up one day and decided to add code that will turn the default dictionary to the original by Mozilla no matter your own preference. that guy needs to be fired.

Modified by AlexandrosArxaggelos

cor-el
  • Top 10 Contributor
  • Moderator
17520 solutions 158427 answers

This combined dictionary doesn't have a valid language code, so I'm not sure if/how you can set it as the default.

See also:

This combined dictionary doesn't have a valid language code, so I'm not sure if/how you can set it as the default. See also: *https://addons.mozilla.org/firefox/addon/multilingual-dictionary/
purple 0 solutions 3 answers

cor-el said

This combined dictionary doesn't have a valid language code, so I'm not sure if/how you can set it as the default. See also:

In case you were replying to me, I don't know what to say. It works repeatedly after every restart. Since I did as I described above, I did not have to change the dictionary that is being used. Firefox will now always use that custom dictionary as the default. And I'm really glad it is finally working as I want it to work.

It would be really helpful though if Firefox gave the option to choose a default dictionary so that we wouldn't have to mess with about:config to do so.

''cor-el [[#answer-1144437|said]]'' <blockquote> This combined dictionary doesn't have a valid language code, so I'm not sure if/how you can set it as the default. See also: *https://addons.mozilla.org/firefox/addon/multilingual-dictionary/ </blockquote> In case you were replying to me, I don't know what to say. It works repeatedly after every restart. Since I did as I described above, I did not have to change the dictionary that is being used. Firefox will now always use that custom dictionary as the default. And I'm really glad it is finally working as I want it to work. It would be really helpful though if Firefox gave the option to choose a default dictionary so that we wouldn't have to mess with about:config to do so.