Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get rid of the white border in firefox?

  • 9 replies
  • 1 has this problem
  • 9 views
  • Last reply by Aelyss

more options

On windows 10 I have this very annoying white border in the dark theme on the left, right and bottom of my window. I can temporarily get rid of it by checking the "title bar" option in "customize". However, it keeps the borders on the tab bar/title bar. After repositioning the window on my desktop via mini/maximize, it's back.

How do I get rid of this white border? No I won't re-install, it's quite bothersome and doesn't solve the issue.

All Replies (9)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Hmm, I don't think there should be left and right borders on a maximized window, however, Windows 10 has some differences from Windows 7.

One Windows 10 user who had set the Taskbar to the left side discovered that the borders went away if they moved the Windows Task Bar to the bottom and back to the left side.

more options

You can find the screenshot here where you can clearly see the white borders: https://imgur.com/a/y07vMeY

more options

Was that default FF install or did you use css customizations?

more options

Default install, very little customized and no external profile syncs. I also have a bare minimum of addons installed and it's the default dark theme.

more options

Aelyss said

Default install, very little customized and no external profile syncs. I also have a bare minimum of addons installed and it's the default dark theme.

Remove the theme and return to default and see if anything changes.

more options

Hi, you can check things this way : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

See Pkshadow's post in this thread :

https://support.mozilla.org/en-US/questions/1197359

which was marked 'Chosen Solution' ......

more options

I've tried in safe mode and the issue persists. I can't uninstall the dark theme from the UI, I can only disable it and that doesn't solve the problem. The "Default" theme has the exact same issue of the border.

I did a little playing around with the windows settings and here's what I've found:

  • My primary monitor doesn't have it (external screen 1920x1080)
  • My laptop screen has this issue (1920x1080)
  • The issue goes away when I change my scale from 125% to 100%

So it seems related to the windows scaling, but as firefox is the only application with this issue, it's probably related to the part where it hides the title bar and integrates the tabs instead. When I have the title bar, the issue isn't present at 125%.

And as I mentioned, I won't uninstall, that's far too much effort for such a simple bug. reinstalling an application should _never_ be a solution to a bug like this! Do not ask people to go through all this effort instead of solving the actual issue!

Modified by Aelyss