X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 61.0.1 scrambles sound playback.

Posted

Firefox 61.0.1 OSX 10.9.5 Audio playback problem I'm a helper elf on the Audacity sound editor forum. I posted several example sound clips on my web page.

Scroll down to - Clips - Professional.

http://www.kozco.com/tech/audacity/audacity.html

All these clips were intended to be single track tagged "mono" so they play to left and right speakers.

The fourth track "Roman Mars" plays to left and right speakers as intended. The four other tracks

play to Left only, only on one machine, and only in Firefox. 

Safari works fine, all my other machines work OK, and friend's machines work OK. The clips all play to Left and Right.

This problem pops up on other MP3 sound samples as well. There doesn't seem to be anything common except the browser. Everyone is baffled.

Koz

Firefox 61.0.1 OSX 10.9.5 Audio playback problem I'm a helper elf on the Audacity sound editor forum. I posted several example sound clips on my web page. Scroll down to - Clips - Professional. http://www.kozco.com/tech/audacity/audacity.html All these clips were intended to be single track tagged "mono" so they play to left and right speakers. The fourth track "Roman Mars" plays to left and right speakers as intended. The four other tracks play to Left only, only on one machine, and only in Firefox. Safari works fine, all my other machines work OK, and friend's machines work OK. The clips all play to Left and Right. This problem pops up on other MP3 sound samples as well. There doesn't seem to be anything common except the browser. Everyone is baffled. Koz

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Shadow110 1072 solutions 14836 answers

HI, Please work through these : VIDEO AUDIO

If still have issues and no information was provided when you created the question please : Try Firefox Safe Mode to TEST and see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

HI, Please work through these : VIDEO AUDIO *https://support.google.com/youtube/topic/3014746 *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues *https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox *https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows If still have issues and no information was provided when you created the question please : '''Try Firefox Safe Mode''' to '''TEST''' and see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

Try to set this pref to true on the about:config page.

  • media.forcestereo.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set this pref to true on the <b>about:config</b> page. *media.forcestereo.enabled = true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Modified by cor-el

Question owner

Pkshadow said

HI, Please work through these : VIDEO AUDIO If still have issues and no information was provided when you created the question please : Try Firefox Safe Mode to TEST and see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem.
''Pkshadow [[#answer-1130987|said]]'' <blockquote> HI, Please work through these : VIDEO AUDIO *https://support.google.com/youtube/topic/3014746 *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues *https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox *https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows If still have issues and no information was provided when you created the question please : '''Try Firefox Safe Mode''' to '''TEST''' and see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. </blockquote>

Question owner

Terrific. I'll start cranking through that tomorrow. It's such an odd duck nobody could figure out troubleshooting techniques. I know we're all going to laugh when I sort why only some MP3's do it. Koz

Terrific. I'll start cranking through that tomorrow. It's such an odd duck nobody could figure out troubleshooting techniques. I know we're all going to laugh when I sort why only some MP3's do it. Koz

Question owner

cor-el said

Try to set this pref to true on the about:config page.
  • media.forcestereo.enabled = true
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.
''cor-el [[#answer-1130990|said]]'' <blockquote> Try to set this pref to true on the <b>about:config</b> page. *media.forcestereo.enabled = true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config </blockquote>

Question owner

Thank you for your response. I didn't post a goal [slapping wrist]. Goal number 2 is to get everything working. I will check that setting. Goal number 1 is to see why that's happening. The answer to that is going to spill over on to the other forums. Why only some MP3's and only on one machine?

As we go.

Thanks again.

Koz

Thank you for your response. I didn't post a goal [slapping wrist]. Goal number 2 is to get everything working. I will check that setting. Goal number 1 is to see ''why that's happening''. The answer to that is going to spill over on to the other forums. Why only some MP3's and only on one machine? As we go. Thanks again. Koz
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

There is currently a problem with the mozillaZine website.


There has been a bug reported that affects some when playing some media files.

  • bug 1461131 - Mono sounds play through left speaker only on multi-channel speakers

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

There is currently a problem with the mozillaZine website. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox ---- There has been a bug reported that affects some when playing some media files. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1461131 bug 1461131] - Mono sounds play through left speaker only on multi-channel speakers (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Question owner

I have a Left-Only problem and I'm using the plain stereo Headphone Out connection of a Mac Mini to drive a speaker power amplifier and separate speakers. No Sound Blaster.

Last two Firefox versions 61.0.1 and 61.0.0 both do it. So the version before that was OK? I don't use these sound files very often, so this is rough to nail down. I could just blow it all away and start over, but can I assume y'all want me to keep it going for testing?

Koz

I have a Left-Only problem and I'm using the plain stereo Headphone Out connection of a Mac Mini to drive a speaker power amplifier and separate speakers. No Sound Blaster. Last two Firefox versions 61.0.1 and 61.0.0 both do it. So the version before that was OK? I don't use these sound files very often, so this is rough to nail down. I could just blow it all away and start over, but can I assume y'all want me to keep it going for testing? Koz