Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitch tab stutters everytime I change to another tab

  • 12 replies
  • 10 have this problem
  • 6659 views
  • Last reply by Ranmilia

more options

Whenever I'm watching twitch and the open a new tab/change to another, the twitch stream always stops loading when I go back to the twitch tab it resumes playing. This started since the last time firefox updated.

Chosen solution

thanks, in this case please reset media.suspend-bkgnd-video.enabled again and try if setting network.http.throttle.version to 1 & restarting the browser once improves things...

Read this answer in context 👍 2

All Replies (12)

more options

I have the exact same issue and can replicate it alot of times, I can also confirm with my setup 3 screens, if i open 2 twitch streams open the "advanced stats" on both, and start em at the same time and tap into a 3rd tap, i have no stuttering, but if i focus eaither of the taps with a player in em the one not in focus looses its ability to load the video feed, and the buffer size stops filling up, if i quickly tap away from the player thats droping to other player or the third none player tap it instantly starts buffering again with no issue. The issue only seems to trigger the second the player window is not "alone" and not in focus

more options

first is when neither of the players are in focus

more options

second is the second i focus one of the players it freezes to a halt and never returns unless i tap to the third tap or the player thats frozen(going to the frozen player freezes the other player)

more options

hi, does this change when you set the media.suspend-bkgnd-video.enabled preference in about:config to false?

more options

philipp said

hi, does this change when you set the media.suspend-bkgnd-video.enabled preference in about:config to false?

I set media.suspend-bkgnd-video.enabled to False (it was set to true) but still doesn't fix it.

more options

philipp said

hi, does this change when you set the media.suspend-bkgnd-video.enabled preference in about:config to false?

dident fix for me either

more options

Chosen Solution

thanks, in this case please reset media.suspend-bkgnd-video.enabled again and try if setting network.http.throttle.version to 1 & restarting the browser once improves things...

Modified by philipp

more options

philipp said

thanks, in this case please reset media.suspend-bkgnd-video.enabled again and try if setting network.http.throttle.version to 1 & restarting the browser once improves things...

This seems to have solved the problem! Thank you very much.

more options

fixed it for me too THX alot! just out of curiosity what does that setting exactly change ?

more options

Hi LoopeeDK, HTTP throttling ensures that active tabs have priority over background tabs.

The difference between version 1 and version 2 is... I really don't know, but version 1 is less aggressive in throttling background data and version 2 is more aggressive.

more options

See also:

  • bug 1386746 - HTTP response throttling: experiment with limiting the amount of data we read during the short don't-block-read period

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)


Some comments in the source code: https://dxr.mozilla.org/mozilla-release/source/modules/libpref/init/all.js#2114

Modified by cor-el

more options

I also had this issue, but when I looked in about:config, network.http.throttle.version was already set to 1. I set it to 0 and that seems to have solved the issue, for now.