Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Non-active tabs download speed reduction?

  • 2 replies
  • 1 has this problem
  • 496 views
  • Last reply by gerdesan

more options

When browsing through several open tabs only active one loads and works properly. For example when i am watching twitch stream and open another webpage in new tab and switch to it, twitch stream stops almost immediately. Same happens if i start playing video on youtube and then switch to new tab, video will play preloaded part (light grey part) and will stop there and wont even try to load rest of the video until i select youtube tab again. I never had this problem until few months ago. I was able to open 4-5 twitch streams in highest quality at the same time and all them worked fine. I can still do it in another web-browser but i dont want to switch from firefox. Can someone help me fix this?

Chosen solution

To improve performance for active tabs, the bandwidth allotted to background tabs can be "throttled." You can ease up on the throttling so background tabs have more network access. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste throttle and pause while the list is filtered

(3) Double-click the network.http.throttle.version preference and edit the value from 2 to 1 and click OK

Test for a few hours. If that doesn't give you the right balance, you can try this:

(4) Double-click the network.http.throttle.enable preference to switch the value from true to false

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

To improve performance for active tabs, the bandwidth allotted to background tabs can be "throttled." You can ease up on the throttling so background tabs have more network access. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste throttle and pause while the list is filtered

(3) Double-click the network.http.throttle.version preference and edit the value from 2 to 1 and click OK

Test for a few hours. If that doesn't give you the right balance, you can try this:

(4) Double-click the network.http.throttle.enable preference to switch the value from true to false

more options

jscher2000 said

To improve performance for active tabs, the bandwidth allotted to background tabs can be "throttled." You can ease up on the throttling so background tabs have more network access. Here's how: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste throttle and pause while the list is filtered (3) Double-click the network.http.throttle.version preference and edit the value from 2 to 1 and click OK Test for a few hours. If that doesn't give you the right balance, you can try this: (4) Double-click the network.http.throttle.enable preference to switch the value from true to false

network.http.throttle.version was set to 1 by default so i went with your second suggestion and switched network.http.throttle.enable to false and it fixed my problem. Thank you!