X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Developer Edition does not refresh

Posted

Double-post: https://stackoverflow.com/questions/50475736/firefox-developer-edition-doesnt-refresh

I'm working on a Wordpress-site (using https) and I use Firefox Developer Edition (61.0b7 (64-bit)) to see and test my changes. But whenever I make changes in the content or the display, these changes are not reflected in Firefox Developer Edition (FDE). I'm logged into the back-end in a a normal Firefox browser.

Things I've tried:

  • Normal refresh F5
  • Refresh by hitting ctrl+F5 and ctrl+shift+R
  • Options > Cookies and Site Data > Clear Data
  • Options > Cookies and Site Data > Block cookies and site data (may cause websites to break)
  • Reinstall the browser

If I for instance change the logo and the CSS of the menu, these changes does not appear in the FDE-window. But if I navigate to a page on the site that I have not visited in that browser before, the changes are there.

How do I make FDE refresh whenever I ask? Thanks for any suggestions!

Double-post: https://stackoverflow.com/questions/50475736/firefox-developer-edition-doesnt-refresh I'm working on a Wordpress-site (using https) and I use Firefox Developer Edition (61.0b7 (64-bit)) to see and test my changes. But whenever I make changes in the content or the display, these changes are not reflected in Firefox Developer Edition (FDE). I'm logged into the back-end in a a normal Firefox browser. Things I've tried: * Normal refresh F5 * Refresh by hitting ctrl+F5 and ctrl+shift+R * Options > Cookies and Site Data > Clear Data * Options > Cookies and Site Data > Block cookies and site data (may cause websites to break) * Reinstall the browser If I for instance change the logo and the CSS of the menu, these changes does not appear in the FDE-window. But if I navigate to a page on the site that I have not visited in that browser before, the changes are there. How do I make FDE refresh whenever I ask? Thanks for any suggestions!

Modified by mimmiNor

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

iamjayakumars 489 solutions 5951 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

Thank you, but the problem persists in Safe Mode (in Firefox Developer Edition there is no Safe Mode in Help, but I chose: Restart with add-ons disabled, and the warning in your screen shot came up.)

I guess there must be a setting somewhere that stops the page from refreshing.

Thank you, but the problem persists in Safe Mode (in Firefox Developer Edition there is no Safe Mode in Help, but I chose: Restart with add-ons disabled, and the warning in your screen shot came up.) I guess there must be a setting somewhere that stops the page from refreshing.
Gerd 4 solutions 41 answers

Are you caching your website through a CDN (e.g. Cloudflare)? If so, you need to disable caching on your cdn as well.

Are you caching your website through a CDN (e.g. Cloudflare)? If so, you need to disable caching on your cdn as well.
cor-el
  • Top 10 Contributor
  • Moderator
17410 solutions 157269 answers

A reload and bypass the cache (ctrl+F5 and ctrl+shift+R) should normally instruct all servers in the connection chain to request the page from the server and not to use their caches.

You can try a New Private Window or a new profile to be sure that this isn't a Firefox issue.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

A reload and bypass the cache (ctrl+F5 and ctrl+shift+R) should normally instruct all servers in the connection chain to request the page from the server and not to use their caches. You can try a New Private Window or a new profile to be sure that this isn't a Firefox issue. You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox