X
Tap here to go to the mobile version of the site.

Support Forum

Development: Ctrl+Shift+R don't clean the cash (only manually or through plugin)

Posted

I am developing a web application (Wildfly, JS, html, css & co.). I am checking that in both Chrome and Firefox, but in Firefox every time i want to refresh a page to see changes, i must clean the cache, while in Chrome i just press F5. I installed Firefox Developer Edition because of that, but the problem is also there.

Even Ctrl+Shift+R doesn't solve the problem (or not always).

I added: https://addons.mozilla.org/it/firefox/addon/empty-cache-button/ and it works great. But still, why doesn't work just F5 as it happens in Chrome? Is there an option "automatically clean cache"? Or some "Developement mode" that allows to refresh everything silently?

The biggest disappointment was when i saw that this happens also in "Firefox Developer Edition" Maybe i am doing something wrong or the option is present?

I remember some problems like that in the past, but now they happens almost on always change.

I am developing a web application (Wildfly, JS, html, css & co.). I am checking that in both Chrome and Firefox, but in Firefox every time i want to refresh a page to see changes, i must clean the cache, while in Chrome i just press F5. I installed Firefox Developer Edition because of that, but the problem is also there. Even Ctrl+Shift+R doesn't solve the problem (or not always). I added: https://addons.mozilla.org/it/firefox/addon/empty-cache-button/ and it works great. But still, why doesn't work just F5 as it happens in Chrome? Is there an option "automatically clean cache"? Or some "Developement mode" that allows to refresh everything silently? The biggest disappointment was when i saw that this happens also in "Firefox Developer Edition" Maybe i am doing something wrong or the option is present? I remember some problems like that in the past, but now they happens almost on always change.

Chosen solution

Hi Xixo.

I would advise you to just use Ctrl+F5 shortcut instead, which should work in all browsers to reload the page bypassing cache. Or you can just disable cache (set it to 0 MB) in Firefox in Settings > Advanced > Network tab.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Foxit Reader Plug-In For Firefox and Netscape
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.41212.0
  • VLC media player Web Plugin
  • VMware Remote Console Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

Michal Stanke
  • Moderator
182 solutions 990 answers

Chosen Solution

Hi Xixo.

I would advise you to just use Ctrl+F5 shortcut instead, which should work in all browsers to reload the page bypassing cache. Or you can just disable cache (set it to 0 MB) in Firefox in Settings > Advanced > Network tab.

Hi Xixo. I would advise you to just use ''Ctrl+F5'' shortcut instead, which should work in all browsers to reload the page bypassing cache. Or you can just disable cache (set it to 0 MB) in Firefox in ''Settings > Advanced > [https://support.mozilla.org/en-US/kb/advanced-panel-settings-in-firefox#w_network-tab Network tab]''.
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158459 answers

If you change the content, but leave the file (image) names the same then consider to add extra GET parameters like a date-time string to the URL to make each file unique.

If you change the content, but leave the file (image) names the same then consider to add extra GET parameters like a date-time string to the URL to make each file unique.

Helpful Reply

The answer of Michal Stanke seems working. Anyway, I would expect that as default for Firefox Developer Edition, because I suppose it's a common need for developers.

The answer of Michal Stanke seems working. Anyway, I would expect that as default for Firefox Developer Edition, because I suppose it's a common need for developers.
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158459 answers

Ctrl+F5 works the same way as Ctrl+Shift+R and bypasses the cache, so both should work. You may have to use it more than once.

See also:

Ctrl+F5 works the same way as Ctrl+Shift+R and bypasses the cache, so both should work. You may have to use it more than once. See also: *http://kb.mozillazine.org/browser.cache.check_doc_frequency

Question owner

cor-el said

You may have to use it more than once.

That's the problem actually (did i press that enought times?).

The link you gave about browser.cache.check_doc_frequency seems quite interesting, i will try to set its value to 1.

''cor-el [[#answer-832589|said]]'' <blockquote> You may have to use it more than once. </blockquote> That's the problem actually (did i press that enought times?). The link you gave about browser.cache.check_doc_frequency seems quite interesting, i will try to set its value to 1.
Narvey 2 solutions 10 answers

<snark>Cleaning the cash... is that like laundering money? </snark>

<snark>Cleaning the cash... is that like laundering money? </snark>

Question owner

Narvey said

<snark>Cleaning the cash... is that like laundering money? </snark>

You know, in English the pronuciation and the writing is not always logically related... so may be :)

''Narvey [[#answer-838367|said]]'' <blockquote> <snark>Cleaning the cash... is that like laundering money? </snark> </blockquote> You know, in English the pronuciation and the writing is not always logically related... so may be :)

Modified by Xixo