Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Window 7: Can not set Firefox as a default application

  • 23 replies
  • 1 has this problem
  • Last reply by stormcloud

more options

This morning Firefox upgraded its self. Since then I've not been able to click on links in e-mail to open up web pages. Every time I manually launch Firefox it asks me if I want to make make it my default browser. I reply Yes, so it asks me which account (my or the Administrator) I want to use. It does not appear to make any difference as Firefox does not become my default browser.

In increasing levels of desperation I've tried:

  • Tools | Options | Make Default
  • Rebooting the PC
  • Deleting my Firefox Profile
  • Reinstalling the latest version of Firefox
  • Reinstalling an old version of Firefox

No luck. Following other threads in this forum I've selected Start -> Control Panel -> Default Programs -> Set Default programs

Firefox is not listed.

How to I make Firefox my default browser?

All Replies (20)

more options

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder.

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux;

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again. This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

I do have a C:\Program Files (x86)\Mozilla Firefox directory, but it contains almost nothing. For some reason Firefox has installed it's self at: C:\Users\<user-name>\AppData\Local\Mozilla Firefox

Should I delete this directory instead?

more options

Yes. Remove any Firefox or Mozilla folders. BUT, do not remove the profile folders.

These should be under; C:\Users\=<user name>=\ AppData\Roaming\Mozilla\Firefox\Profiles

more options

I've tried all of that but no luck - Firefox will not make it's self my default web browser application. The Windows Control panel will not update to include Firefox as an application that can be defaulted

more options

I called for more help.

more options

Thank you. I'd appreciate all the help I can get resolving this

more options

stormcloud, start from the begining. Launch cmd as admin, type: sfc /scannow and press enter. Wait for finish and tell about result to us.

Modified by PavelkoT

more options

As requested, I've run the scan. The results are:

C:\WINDOWS\system32> sfc /scannow

Beginning system scan. This process will take some time.

Beginning verification phase of system scan. Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

more options
more options

Firefox still isn't registered as a default program, but the scan show no other problems on my machine

more options

@FredMcD, Any news from the people you asked?

more options

I called again.

more options

From what I understand, the default browser needs to be set from the Administrator's account on Windows 7.

A few suggested solutions:

  1. Start with the 3 Horizontal Bar Menu(sometimes called the Hamburger) in Firefox - then >Options>General>"Always check if Firefox is your default browser"
  2. Originally I found this thread as it seems to have been an issue starting in 57 here
  • Are there any pending updates to your version of Windows? I would suggest making an update.
  • Is Firefox listed in this menu of default programs? illustrated here
  1. You already ran a malware scan, do you have any other antiviruses installed on your computer? Temporarily disable these from the administrator's account to see if this is the cause.
more options

Two more questions if you don't mind.

  1. What version did you upgrade Firefox from, and did you use an installer or the update Firefox prompt?
  2. Have you updated to Firefox 60?

Thank you!

Modified by guigs

more options

Hi @guigs,

In answer to your questions:

> Start with the 3 Horizontal Bar Menu(sometimes called the Hamburger) in Firefox - then >Options>General>"Always check if Firefox is your default browser"

This was the first thing I tried - but it didn't help.

I'm running Firefox version 60.0.1 (64 bit)

I am using Windows 7 With service pack 1 installed and all of the latest OS updates. My PC regularly virus scanned and checked for Malware, so I'm as confident as I can be that there are no issues there.

The link you sent is for question 1207775 applies to Windows 10. I didn't see anything similar for Windows 7.

more options

I've just upgraded to 60.0.2 (64-bit), but it has not helped

more options

Hi, I think everyone has done what they can for you here. I think it is now time to hand this off to a Windows 7 forum to help you further since it seems it is not Firefox as the problem but is a Windows 7 hiccup.

Please try one of these respected sites and refer ti this posting so they know what we have tried :

Let us know what transpires. All above are good people/places.

more options

Thanks for the time you've spent trying to help. If i find out what the problem was I'll update this thread.

  1. 1
  2. 2