Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does the first page requested refresh right after loading?

  • 5 replies
  • 1 has this problem
  • 6 views
  • Last reply by FredMcD

more options

Use an URL as a shortcut to open Firefox and go to a page. Firefox opens, and the requested page opens. As soon as the page finishes loading, it clears itself, and reloads. Once that first page has stabilized, using URLs to request additional pages does not cause that behavior. Only the first page requested after Firefox opens automatically refreshes after opening. Happens on multiple sites, including https://mail.google.com/mail/#inbox and http://radar.weather.gov/...

Firefox 59.0.x, including 59.0.3 (64 bit) Windows 7 SP1 (64 bit)

All Replies (5)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

That seemed to solve it.

Add-ons and extensions running: Awesome RSS Facebook Container Notifier for Gmail RSS Feed Reader

The problem appeared with the upgrade to version 59. These extensions have been running for some time, and there were no problems prior to the upgrade.

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Found the culprit. This add-on has been running for years without problems. Version 59 caused the incompatibility. "IBM Security Rapport". As this was "recommended" (pretty much forced upon me) by the bank, I hesitate to leave it disabled. Hardware acceleration was not a problem.

I suppose I can live with the refresh on the first load, IF the security is really needed.

more options

Contact its support. They may need to update for the current Firefox.